shotwell fails to import iphone photos

Bug #1453336 reported by Herminio on 2015-05-09
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Shotwell
Incomplete
Medium
shotwell (Ubuntu)
Medium
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

[Impact]
Shotwell fails to import photos from an iPhone using iOS 8+.

[Test Case]
Plug in iPhone with iOS8+ and try to import photos.

[Regression Potential]
This patch is not yet mainline shotwell, but has already been applied in Debian.

---

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: shotwell 0.20.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
Uname: Linux 3.19.0-16-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.17.2-0ubuntu1
Architecture: amd64
CurrentDesktop: Unity
Date: Fri May 8 21:26:59 2015
InstallationDate: Installed on 2015-05-08 (0 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
SourcePackage: shotwell
UpgradeStatus: No upgrade log present (probably fresh install)

Herminio (herminio-hernandezjr) wrote :
Herminio (herminio-hernandezjr) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
valent (valent-turkovic) wrote :

Is there any workaround to somwhow import photos?

valent (valent-turkovic) wrote :

Hmm, why is Shotwell having issues with importing images when I can use any file browser, open DCIM folder that I see mounted from iPhone and add, copy or delete images from it.

Changed in shotwell (Ubuntu):
importance: Undecided → Medium
Herminio (herminio-hernandezjr) wrote :

I noticed that as well that I can copy pictures from the file browser. I also believe this is an issue iOS 8. When I mount an iPhone with iOS 7 I can import to Shotwell with no issues.

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Kostadin Stoilov (kmstoilov) wrote :

I think this bug has already been reported upstream - https://bugzilla.gnome.org/show_bug.cgi?id=742295.

Yeah, the upstream sounds like this bug, although gphoto2 is fairly successful at importing photos from my iPhone 5s running iOS 8.3, using these args:

gphoto2 –port=usb: -R -P

I picked that up from a bug report of the same problem in Fedora 21, on RedHat's bugzilla:

https://bugzilla.redhat.com/show_bug.cgi?id=1178256

Looks like there hasn't been any action on the upstream bug in a while, so getting the photos out of the camera via gphoto2 or the file manager, then importing into Shotwell, looks like it'll be our workaround for a while.

Just ran into this bug as well, is there any resolution or workaround for that?

Manual copy

Sent from my iPhone

> On Aug 6, 2015, at 2:20 PM, Markus Padourek <email address hidden> wrote:
>
> Just ran into this bug as well, is there any resolution or workaround
> for that?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1453336
>
> Title:
> shotwell fails to import iphone photos
>
> Status in shotwell package in Ubuntu:
> Confirmed
>
> Bug description:
> Shotwell when view my photos on iPhone see double and fails to import.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 15.04
> Package: shotwell 0.20.2-0ubuntu3
> ProcVersionSignature: Ubuntu 3.19.0-16.16-generic 3.19.3
> Uname: Linux 3.19.0-16-generic x86_64
> NonfreeKernelModules: nvidia wl
> ApportVersion: 2.17.2-0ubuntu1
> Architecture: amd64
> CurrentDesktop: Unity
> Date: Fri May 8 21:26:59 2015
> InstallationDate: Installed on 2015-05-08 (0 days ago)
> InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
> SourcePackage: shotwell
> UpgradeStatus: No upgrade log present (probably fresh install)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/shotwell/+bug/1453336/+subscriptions

Changed in shotwell (Ubuntu):
status: Confirmed → Won't Fix
status: Won't Fix → Triaged

Encountered this bug using Ubuntu MATE 16.04, connecting an iPhone 6S with iOS 10.2, and using Shotwell 0.22.0. Reports that it is "Starting import, please wait..." forever (overnight). Not worth having on my 'puter...

Chris J Arges (arges) wrote :
Chris J Arges (arges) wrote :
description: updated
tags: added: patch
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu Trusty):
status: New → Confirmed
Changed in shotwell (Ubuntu Xenial):
status: New → Confirmed
Changed in shotwell (Ubuntu Yakkety):
status: New → Confirmed
Jens Georg (yg-jensge) wrote :

You have seen the comment on the upstream ticket saying "Ok, here's a quick patch that will do for the moment. It's a TERRIBLE hack which will need you to quit the application to release the camera"?

Bugspriet (c-steimann) wrote :

It started not to work anymore when I upgraded iOS to 10.2.1

Rory (rory) wrote :

Still not working... on 16.04

Linux mylaptop 4.4.0-66-generic #87-Ubuntu SMP Fri Mar 3 15:29:05 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Incomplete
Lindsey Cormier (ilovecoffee) wrote :

I am having this problem when I try to connect my iphone 7 plus. I am on Ubuntu 17.04. I tried installing libimobiledevice and it showed my photos in shotwell, but when I went to import them I get an error (failed to import). I don't want to switch back to Windows (uggggh) on this computer, but I need my photos!

Jeremy Bicha (jbicha) wrote :

The proposed patch that was applied to Debian is now in Ubuntu 17.10 Beta with shotwell 0.26.3-1ubuntu1.

Changed in shotwell (Ubuntu):
status: Triaged → Fix Released
Jacob Hoffman-Andrews (jsha) wrote :

This seems worthwhile to backport to Ubuntu 16.04.3 LTS.

Jacob Hoffman-Andrews (jsha) wrote :

FYI I figured out that for me at least, shotwell was stuck in this state because I needed to unlock my phone and select an item from the notifications dropdown to enable photo transfer. The notification didn't show up from the lock screen.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.