uoa publishing on flickr, corrupted double-linked list error

Bug #1382843 reported by Mike on 2014-10-18
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
libsignon-glib (Ubuntu)
High
Unassigned
Trusty
Undecided
Unassigned
Utopic
Undecided
Unassigned
shotwell (Ubuntu)
High
Alberto Mardegan
Utopic
Undecided
Unassigned

Bug Description

* Impact
Trying to upload photos makes shotwell hit a segfault

* Test case
Try to publish a photo to an online configured through online-accounts

* Regression potential
Check that you can add and use online accounts without issues (in shotwell and other unity7 desktop components)

Related branches

Mike (0x656b694d) on 2014-10-18
description: updated
Janne Moren (jan-moren-gmail) wrote :

This may be the same bug I hit all the time since upgrading to 14.10. Shotwell is all but unusable right now. The situation is the same. It seems to happen in these cases:

* I try to upload things to Flickr and it starts opening the upload dialog;
* It uploaded, but then I try to remove the flag on the selected picture with ctrl-g;
* Once it died just from trying to scroll the image list.

But the message I get is somewhat different from above. One of these two, generally:

*** Error in `shotwell': free(): invalid size: 0x0000000010fa7eb0 ***
Avbruten (SIGABRT) (minnesutskrift skapad)

*** Error in `shotwell': malloc(): memory corruption (fast): 0x0000000011b6a290 ***
Avbruten (SIGABRT) (minnesutskrift skapad)

It happens with the latest version as of today (0.20.2), and the previous version. I've attached a backtrace and a log.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu):
status: New → Confirmed
arzitek (lucm) wrote :

I recently upgraded to Ubuntu 14.10 (from 14.04) so it upgraded Shotwell from 18.x to 20.2, and now I see this same problem (corrupted double-linked list error message) while trying to upload to Flickr. Usually before the upload actually starts (sometimes when I hit Cancel so not even starting to upload).
So far it worked after restarting shotwell from scratch so it looks like a sporadic (but frequent) bug.

Jim Nelson (yorba-jim) wrote :

This problem appears to be associated with the Ubuntu Online Account (UOA) integration with Shotwell. Yorba's version (w/o UOA) doesn't have this bug.

arzitek (lucm) wrote :

Interesting... Is there a PPA where I could get a clean upstream 0.20.2 to confirm this?

Jim Nelson (yorba-jim) wrote :

The Yorba PPA is at https://launchpad.net/~yorba/+archive/ubuntu/ppa but only has 0.20.2 for 14.04 (Trusty). Our Daily Build PPA (https://launchpad.net/~yorba/+archive/ubuntu/daily-builds) has 0.20.2 for 14.10 (Utopic), but note the warnings at the top of the page about that PPA.

Janne Moren (jan-moren-gmail) wrote :

Hm, I'm wary of entrusting my photo lib to daily builds. Any idea if or when stable builds will appear for 14.10?

Jim Nelson (yorba-jim) wrote :

As policy we don't release builds for same-version packages in Ubuntu's repos to avoid name and version conflicts. (In other words, since shotwell 0.20.2 is in the 14.10 repo, we don't release 0.20.2 for 14.10 in our PPA.) That decision is complicated with Ubuntu maintaining their own fork w/ UOA for Shotwell, but it's just how it goes.

Another possibility would be to download the 0.20.2 tarball from GNOME, build it, and run it directly from the build directory (that is, you don't even need to install it). I know that's more painful but it would give a way to test the issue.

Sebastien Bacher (seb128) wrote :

Hey Alberto, do you think you could have a look to that one?

summary: - corrupted double-linked list
+ uoa publishing, corrupted double-linked list error
Changed in shotwell (Ubuntu):
importance: Undecided → High
assignee: nobody → Alberto Mardegan (mardy)
summary: - uoa publishing, corrupted double-linked list error
+ uoa publishing on flickr, corrupted double-linked list error
Alberto Mardegan (mardy) wrote :

I will. I don't think I reworked the UOA patch for 14.10, but maybe something changed upstream so that the old patch, while still applying, behaves in a wrong way.

Sebastien Bacher (seb128) wrote :

do you think it's something you can investigate? I tried to run shotwell under valgrind but it's checking for new files for ever (on a test user with 4 files in ~/Images) and the publish item are never enabled so I can't try the action to get more debug info...

arzitek (lucm) wrote :

I have a "test" Ubuntu 14.10 box where I could test the daily PPA. I first have to check that it currently has the same issue so that I could reproduce the problem. More on this later today hopefully.

arzitek (lucm) wrote :

I could easily reproduce the problem with my test PC (Ubuntu 14.10, Shotwell 0.20.2 from the distribution repo). The corrupted linked list crash happened immediately after an otherwise successful upload to Flickr even with just one photo.

Then I removed shotwell & shotwell-common and reinstalled 0.20.2 from the daily PPA. I could upload 12 more photos and shotwell didn't crash. I did then quit shotwell normally, still no core dump.

So I can confirm this doesn't happen with the yorba version:
ii shotwell 0.20.2+2639~ amd64 Digital photo manager

Is this already reported as an Ubuntu bug ?

Jim Nelson (yorba-jim) wrote :

Yes, this is reported as an Ubuntu bug.

Sebastien Bacher (seb128) wrote :

@Jim, do you have any recommendation on how to run shotwell under valgrind? The publish option seems to never activate when using it (or it takes more than half an hour with a library having only 4 images...)

Alberto Mardegan (mardy) wrote :

I'm working on this bug. I found at least one error in the libsignon-glib vala bindings, which causes a GHashTable to be unreferenced one time too many, but that doesn't seem to be the same issue here.

I can run shotwell under valgrind, and it seems to work fine; but unfortunately, while I can easily reproduce the crash under gdb, it seems to never happen under valgrind. I'll try to play with the G_SLICE environment variable and see if that helps.

Alberto Mardegan (mardy) on 2014-12-04
Changed in shotwell (Ubuntu):
status: Confirmed → In Progress
Sebastien Bacher (seb128) wrote :
Changed in libsignon-glib (Ubuntu):
importance: Undecided → High
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsignon-glib - 1.12+15.04.20141209-0ubuntu1

---------------
libsignon-glib (1.12+15.04.20141209-0ubuntu1) vivid; urgency=medium

  [ Alberto Mardegan ]
  * New upstream release.
    - Introspection: fix transfer type of some methods
    - Update VALA bindings (LP: #1382843)

  [ Ubuntu daily release ]
  * New rebuild forced
 -- Ubuntu daily release <email address hidden> Tue, 09 Dec 2014 13:48:27 +0000

Changed in libsignon-glib (Ubuntu):
status: In Progress → Fix Released
description: updated
description: updated
Sebastien Bacher (seb128) wrote :

Uploaded to vivid and SRUed to utopic

Hello Mike, or anyone else affected,

Accepted libsignon-glib into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libsignon-glib/1.10daily13.06.25-0ubuntu3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

no longer affects: shotwell (Ubuntu Trusty)
no longer affects: shotwell (Ubuntu Utopic)
Changed in libsignon-glib (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed
Chris J Arges (arges) wrote :

So I noticed libsignon-glib was uploaded for Trusty, but not Utopic. Can this fix be uploaded there?

no longer affects: libsignon-glib (Ubuntu Utopic)
Brian Murray (brian-murray) wrote :

Shotwell has been uploaded to the utopic proposed queue, but it depends on a libsignon-glib that doesn't exist there.

+ libsignon-glib-dev (>= 1.10daily13.06.25-0ubuntu3),

Janne Moren (jan-moren-gmail) wrote :

Something happened in the last week or so of updates for 14.10. Instead of crashing directly or shortly after uploading, now the Flickr dialog hangs busy-waiting for a minute or two, after which Shotwell crashes. Now it's impossible to upload things at all, in other words.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in libsignon-glib (Ubuntu Utopic):
status: New → Confirmed
Changed in shotwell (Ubuntu Utopic):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.20.2-0ubuntu2

---------------
shotwell (0.20.2-0ubuntu2) vivid; urgency=medium

  * debian/control.in:
    - updated libsignon-glib requirement

  [ Alberto Mardegan ]
  * debian/patches/06_uoa.patch:
    Don't use the deprecated libaccounts and libsignon APIs
    Introspection annotations are wrong in some of those. (lp: #1382843)
 -- Sebastien Bacher <email address hidden> Fri, 12 Dec 2014 16:20:31 +0100

Changed in shotwell (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

sorry, looks like I mixed series, I uploaded libsignon-glib to utopic now

Sebastien Bacher (seb128) wrote :

the trusty libsignon-glib upload was intended to utopic, I don't think we plan to SRU to trusty, maybe that upload should be cleared out

Chris J Arges (arges) wrote :

Hello Mike, or anyone else affected,

Accepted libsignon-glib into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/libsignon-glib/1.10daily13.06.25-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in libsignon-glib (Ubuntu Utopic):
status: Confirmed → Fix Committed
Chris J Arges (arges) wrote :

Hello Mike, or anyone else affected,

Accepted shotwell into utopic-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shotwell/0.20.2-0ubuntu0.14.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shotwell (Ubuntu Utopic):
status: Confirmed → Fix Committed
Steve Langasek (vorlon) wrote :

package removed from trusty-proposed.

Changed in libsignon-glib (Ubuntu Trusty):
status: Fix Committed → Invalid
Sebastien Bacher (seb128) wrote :

Could somebody test the utopic updates and verify if they fix the issue for them?

Mike (0x656b694d) wrote :

Thank you guys for the fix.
I didn't have a chance to really upload anything yet, but Shotwell doesn't crash anymore when I click on Publish for any number of photos. I tried with a single photo, a couple and quite plenty several times.

Janne Moren (jan-moren-gmail) wrote :

I can't figure out how to test it without upgrading almost a hundred packages in total. I rely on this machine and don't want to add anything else that might conceivably break other things.

Janne Moren (jan-moren-gmail) wrote :

Never mind; I tried it again and now the selective upgrade worked for me. Yes, it seems to fix the bug. I uploaded two images, one image at a time and some image editing in between, to Flickr without causing a crash. That would not have worked earlier.

Sebastien Bacher (seb128) wrote :

thanks for testing

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package libsignon-glib - 1.10daily13.06.25-0ubuntu3.1

---------------
libsignon-glib (1.10daily13.06.25-0ubuntu3.1) utopic; urgency=medium

  * Backport upstream commit (lp: #1382843)
    "Introspection: fix transfer type of some methods
     Update the VALA bindings accordingly."
 -- Sebastien Bacher <email address hidden> Mon, 08 Dec 2014 18:54:06 +0100

Changed in libsignon-glib (Ubuntu Utopic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for libsignon-glib has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.20.2-0ubuntu0.14.10.2

---------------
shotwell (0.20.2-0ubuntu0.14.10.2) utopic; urgency=medium

  * debian/control.in:
    - updated libsignon-glib requirement

  [ Alberto Mardegan ]
  * debian/patches/06_uoa.patch:
    Don't use the deprecated libaccounts and libsignon APIs
    Introspection annotations are wrong in some of those. (lp: #1382843)
 -- Sebastien Bacher <email address hidden> Fri, 12 Dec 2014 16:27:05 +0100

Changed in shotwell (Ubuntu Utopic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers