Remote publishing does not work in Unity on trusty/utopic

Bug #1314904 reported by Jens Georg on 2014-05-01
98
This bug affects 21 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

[Impact]

The publish dialogue fails to open the online account configuration.

[Test Case]

* Click on a photo
* Select 'Publish' in the 'File' menu
* Click on the top right corner where it says 'Piwigo'
* Click on 'Add more accounts...'

That should open the account configuration panel from settings.

[Regression Potential]

The fix just changes the command called by that code, so there is no real risk of regression.

Jens Georg (yg-jensge) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report.
Indeed the Depends was added and reverted because other desktops didn't want to pull those binaires
https://launchpad.net/ubuntu/+source/shotwell/0.18.0-0ubuntu4

Changed in shotwell (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Jim Nelson (yorba-jim) wrote :

Sebastien, this seems to be affecting a number of people. Is there some reason this is marked Low?

Sebastien Bacher (seb128) wrote :

Jim, I can bump the setting to high if you want but I doubt it's going to make a difference.

I don't think anyone on our side is going to have the free slots, this cycle, to make the publishing work without ubuntu-online-account. In those conditions the obvious fix would be to add back the depends/recommends that got dropped, but the Ubuntu GNOME remix team didn't want of that depends ...

Do you see any other easy solution to the issue? (I guess we could work on adding a dialog telling users "you need to install UOA to use that feature", that shouldn't be that much work)

Jim Nelson (yorba-jim) wrote :

So, first: If the users install ubuntu-online-account, does that fix the problem for them? If so, we should communicate that to them.

As far as easy solutions, if adding back the dependency is off the table, then my only other suggestion is to distribute an unmodified version of Shotwell (or, at least, w/o the UOA plugins and w/ Shotwell's). I suspect that's also off the table, in which case I don't have any suggestion other than more code changes, i.e. a warning dialog.

Sebastien Bacher (seb128) wrote :

Thanks Jim. Having another build of shotwell without those changes is mostly up to the derivatives (e.g Ubuntu GNOME), they can maintain a package/build for that if they feel the need. If I were in that team I would just add UOA as a depends, since it's an infrastructure component in Ubuntu, but that's not my call

Jim Nelson (yorba-jim) wrote :

How can I elevate this with those teams (i.e. who should I email)? This is really a poor situation for our users.

Sebastien Bacher (seb128) wrote :

not sure, the gnome3 team has a mailing list on https://launchpad.net/~gnome3-team

Tim Lunn (darkxst) wrote :

The patch that introduces UOA support in shotwell, needs to be tweaked to fallback to the upstream behaviour if UOA is not installed. We have no intention of shipping a seperate shotwell build.

Also adding a depend on UOA pulls in pretty much the entire unity-control-center stack, so clearly that is not an option either.

I am using Ubuntu 14.04 and this happened also to me both on Gnome and Unitiy desktops.
BUT after I established my Google account in "System Settings -> Online Accounts" this worked perfectly for me, i.e. need to establish the account first !

Cardamom (marcofritz) wrote :

I wish it was as simple as Heiðar's case...I actually have set my google account which works for evolution calendar linked to google calendar and empathy with google talk/hangouts; but for Shotwell and PiCasa publishing still doesn't work.

Francisco Rodríguez (flinana) wrote :

Any news? I changed to XFCE expecting better things.

Celian (r-launchpad-celian-dk) wrote :

Running Gnome Shell Ubuntu 14.04, same error. I have already set up my flickr and google accounts in Online Accounts, could only see Piwigo, though in preferences I can see that Flickr and Facebook were there.

Chris J Arges (arges) on 2014-06-25
summary: - Remote publishing does not work in GNOME/XFCE on trusty
+ Remote publishing does not work in Unity/GNOME/XFCE on trusty/utopic
Changed in shotwell (Ubuntu):
importance: Low → High

I can reproduce this issue on Unity with Trusty and Utopic. Here is how I reproduced the issue:
1) Click on a photo; Click on 'Publish'
2) Click on the top right corner where it says 'Piwigo' and click on 'Add more accounts...'

At this point the dialog disappears and if you run via the command line I get the same message as described above.

While I understand using 'ubuntu online accounts' is a way to accomplish adding an account; I would hope that the dialog wouldn't close without any information.

Sebastien Bacher (seb128) wrote :

@Chris: thanks, there was indeed still a wrong command called in the situation you described, I'm uploading a fix for utopic and trusty

description: updated
Changed in shotwell (Ubuntu):
status: Triaged → Fix Committed

Hello Jens, or anyone else affected,

Accepted shotwell into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shotwell/0.18.0-0ubuntu4.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shotwell (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed

Verified in Trusty that I get the ubuntu-online-accounts dialog when clicking on 'Add more accounts...'
Thanks!

tags: added: trusty-verification-done
removed: verification-needed
tags: added: verification-done-trusty
removed: trusty-verification-done
Cardamom (marcofritz) wrote :

Hi to everybody,

I've tried what Chris suggested and actually the ubuntu-online-account appeared to me (so the bug is partially solved), the problem is I still cannot add PiCasa web publishing account in that dialogue window!

I've already set my google account in the online accounts and it's perfectly working for the calendar and empathy IM, but when I try to set in the ubuntu-online-account dialogue, by clicking on the menu "show accounts related with--> Shotwell" I got the message "there are no available account provider related with this application" (I'm attaching a screenshot, sorry it's in Italian).

Tanks :)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.18.0-0ubuntu7

---------------
shotwell (0.18.0-0ubuntu7) utopic; urgency=medium

  * debian/patches/06_uoa.patch: use the correct uoa command (lp: #1314904)

  [ Martin Pitt ]
  * autopkgtest: Drop local copy of autopilot3-sandbox-run and bump test dep to
    the version that ships it.
 -- Sebastien Bacher <email address hidden> Wed, 25 Jun 2014 12:41:43 +0200

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released
Cardamom (marcofritz) wrote :

Hi,

sorry it was my fault not to understand...I finally found the right package simply in the software centre named as a "account-plugin-google", I've just tried and it works like a charm!

thanx a lot! :)

tags: added: verification-done-trusty

Jens Georg (yg-jensge) wrote :

Ehm. In WHAT universe does this fix the issue that shotwell doesn't work in non-UOA environments?

Jim Nelson (yorba-jim) wrote :

I agree with Jens, as I understand things this is still a problem with non-UOA spins. Could someone re-open the ticket?

Sebastien Bacher (seb128) wrote :

the bug comments describe different issues, only one got resolved, the non Unity/uoa one remains indeed

Changed in shotwell (Ubuntu):
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shotwell - 0.18.0-0ubuntu4.1

---------------
shotwell (0.18.0-0ubuntu4.1) trusty; urgency=medium

  * debian/patches/06_uoa.patch: use the correct uoa command (lp: #1314904)
 -- Sebastien Bacher <email address hidden> Wed, 25 Jun 2014 12:50:39 +0200

Changed in shotwell (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for shotwell has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

This bug exist on about 10 PC I manage.
Xubuntu 14.10 final release
Shotwell 0.20.1
PicasaWeb publish plugin eanbled

When I run shotwell with this command & SHOTWELL_LOG=1 SHOTWELL_LOG_FILE=:console: shotwell
then here is the result when I click on Publish button then select the create new account option in the top right corner.

L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:322: PublisingDialog: discovered 5 pluggable publishing services.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'YouTube'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Flickr'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Picasa Web Albums'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Facebook'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Gallery3'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:446: PublishingDialog.go( )
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:322: PublisingDialog: discovered 5 pluggable publishing services.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'YouTube'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Flickr'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Picasa Web Albums'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Facebook'.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:337: PublishingDialog: discovered pluggable publishing service 'Gallery3'.
L 5807 2014-10-24 07:22:50 [DBG] ConfigurationInterfaces.vala:331: ConfigurationFacade: engine reports property 'LAST_USED_SERVICE' changed.
L 5807 2014-10-24 07:22:50 [DBG] PublishingPluginHost.vala:114: ConcretePublishingHost.start_publishing( ): invoked.
L 5807 2014-10-24 07:22:50 [DBG] GalleryConnector.vala:837: GalleryPublisher: starting interaction.
L 5807 2014-10-24 07:22:50 [DBG] GalleryConnector.vala:926: ACTION: showing service welcome pane.
L 5807 2014-10-24 07:22:50 [DBG] PublishingUI.vala:573: PublishingDialog: install_pane( ): invoked.
L 5807 2014-10-24 07:22:56 [DBG] PublishingUI.vala:488: Starting Online Accounts...

(shotwell:5807): GLib-GIO-CRITICAL **: g_app_info_get_commandline: assertion 'G_IS_APP_INFO (appinfo)' failed

(shotwell:5807): GLib-CRITICAL **: g_spawn_command_line_async: assertion 'command_line != NULL' failed
L 5807 2014-10-24 07:22:56 [DBG] PublishingUI.vala:514: PublishingDialog: on_close_cancel_clicked( ): invoked.
L 5807 2014-10-24 07:22:56 [DBG] PublishingPluginHost.vala:100: ConcretePublishingHost.stop_publishing( ): invoked.
L 5807 2014-10-24 07:22:56 [DBG] GalleryConnector.vala:867: GalleryPublisher: stop( ) invoked.

Gabor (magicf) on 2014-10-25
tags: added: shotwell0.20.1 utopic
O Gopal (jswami) wrote :

I already had Picasa configured. But after I upgraded to Trusty, functionality seems to have been lost. I get the "Publish" dialog box, but nothing else happens, and the only clickable button is "Cancel."

tags: removed: shotwell0.20.1
Changed in shotwell (Ubuntu Trusty):
importance: Undecided → High
Mathew Hodson (mathew-hodson) wrote :

Since this bug only fixed the issue when Unity is installed, I have reopened bug #1244099 to deal with remote publishing with GNOME and Xfce, which do not have ubuntu-online-account.

summary: - Remote publishing does not work in Unity/GNOME/XFCE on trusty/utopic
+ Remote publishing does not work in Unity on trusty/utopic
Changed in shotwell (Ubuntu):
status: Triaged → Fix Released
description: updated
Greg Rundlett (greg.rundlett) wrote :

I know Google has already discontinued Picasa in favor of Google Photos[1], so at first I was not surprised "insert" is not valid in Google's Picasa API [2]. However, with more investigation, I couldn't find any separate API for Google Photos (it seems that the Picasa API still serves as the API for Google Photos). So, perhaps there is something wrong with *this* API interaction.

Although I've setup the Google account in Ubuntu System Settings -> "Online Accounts", I'm unable to use that account in Shotwell to publish to 'Picasa' (Google Photos). I get a 400 error Invalid request.

tail ~/.cache/shotwell/shotwell.log

L 16198 2017-03-15 14:31:16 [WRN] RESTSupport.vala:188: Publishing error: Service https://picasaweb.google.com/data/feed/api/user/default returned HTTP status code 400 Bad Request
L 16198 2017-03-15 14:31:16 [WRN] RESTSupport.vala:189: response validation failed. bad response = 'Insert is no longer supported'.

Shotwell 0.25.5 (cfb0e920a3328d07787dab0e7751d6da7a9cf72a)
on Ubuntu 16.04.2 LTS

[1] https://googlephotos.blogspot.co.uk/2016/02/moving-on-from-picasa.html
[2] https://developers.google.com/picasa-web/forum

Jens Georg (yg-jensge) wrote :

You are trying to create a new album. this is not supported anymore. Recent versions of Shotwell (0.25.90) don't offer the option anymore.

If you want to create a new album, you have to do it in the Google Photos web application first, then it appears in Shotwell

But this is not related to the original bug

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers