Menus of a time set to "12:00:00" are initialised at "00:00:00"

Bug #1159821 reported by Thibault D on 2013-03-25
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Shotwell
Fix Released
Medium
shotwell (Ubuntu)
Undecided
Unassigned

Bug Description

1. Select any .jpeg file
2. Photos > Adjust Date and Time...
3. Set it to "12:00:00" with "24hrs" and click "OK"
4. Photos > Adjust Date and Time...

What you should see : the +/- menus should be set at "12:00:00" - "24hrs"
What you do see : "00:00:00" - "24hrs"

However, the information recorded seems correct as you see in the left side : "Original: 03/25/2013, 12:00:00"
(see screenshot attached)

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: shotwell 0.14.0-0ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
Uname: Linux 3.8.0-14-generic i686
ApportVersion: 2.9.2-0ubuntu2
Architecture: i386
CasperVersion: 1.330
Date: Mon Mar 25 14:37:30 2013
LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130325)
MarkForUpload: True
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: shotwell
UpgradeStatus: No upgrade log present (probably fresh install)

Thibault D (thibdrev) wrote :

reproduced

Changed in shotwell (Ubuntu):
status: New → Confirmed
Lucas Beeler (lucas-yorba) wrote :

In the US interpretation of 24 hour time, midnight is zero hour and the twelfth hour is noon. If they were both "12," how could you differentiate between them without an am/pm suffix, and the whole point of 24 hour time is that there is no am/pm suffix so all ambiguity is resolved. How is calling midnight zero hour a problem?

Thibault D (thibdrev) wrote :

The bug title was not accurate : I just changed it without mentioning AM or PM.

The bug is that even if "12:00:00" seems to be correctly recorded, the next time you open "Adjust Date and Time...", the +/- menus will be initialised at "00:00:00" instead of "12:00:00" (see the screenshot).

summary: - "12:00:00" is considered as "12 PM" and not 12 AM"
+ Menus of a time set to "12:00:00" are initialised at "00:00:00"

well it can be a problem for apps who try to read the values. and it is irritating and makes the user confused.

Van: Lucas Beeler
Verzonden: ‎25‎-‎mrt‎-‎13 ‎22‎:‎39
Aan: <email address hidden>
Onderwerp: [Bug 1159821] Re: "12:00:00" is considered as "12 PM" and not 12 AM"

In the US interpretation of 24 hour time, midnight is zero hour and the
twelfth hour is noon. If they were both "12," how could you
differentiate between them without an am/pm suffix, and the whole point
of 24 hour time is that there is no am/pm suffix so all ambiguity is
resolved. How is calling midnight zero hour a problem?

--
You received this bug notification because you are subscribed to the bug
report.
https://bugs.launchpad.net/bugs/1159821

Title:
  "12:00:00" is considered as "12 PM" and not 12 AM"

Status in “shotwell” package in Ubuntu:
  Confirmed

Bug description:
  1. Select any .jpeg file
  2. Photos > Adjust Date and Time...
  3. Set it to "12:00:00" with "24hrs" and click "OK"
  4. Photos > Adjust Date and Time...

  What you should see : the +/- menus should be set at "12:00:00" - "24hrs"
  What you do see : "00:00:00" - "24hrs"

  However, the information recorded seems correct as you see in the left side : "Original: 03/25/2013, 12:00:00"
  (see screenshot attached)

  ProblemType: Bug
  DistroRelease: Ubuntu 13.04
  Package: shotwell 0.14.0-0ubuntu2
  ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
  Uname: Linux 3.8.0-14-generic i686
  ApportVersion: 2.9.2-0ubuntu2
  Architecture: i386
  CasperVersion: 1.330
  Date: Mon Mar 25 14:37:30 2013
  LiveMediaBuild: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130325)
  MarkForUpload: True
  ProcEnviron:
   PATH=(custom, no user)
   XDG_RUNTIME_DIR=<set>
   LANG=en_US.UTF-8
   SHELL=/bin/bash
  SourcePackage: shotwell
  UpgradeStatus: No upgrade log present (probably fresh install)

To manage notifications about this bug go to:
https://bugs.launchpad.net/ubuntu/+source/shotwell/+bug/1159821/+subscriptions

Lucas Beeler (lucas-yorba) wrote :

Okay. The problem is much clearer now. Ticketed upstream here: http://redmine.yorba.org/issues/6672.

Changed in shotwell:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in shotwell:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.