shotwell doesn't get the new pictures since a few days

Bug #1025598 reported by Andreas Bartels on 2012-07-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
shotwell (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

My Galaxy Nexus was allways working fine with shotwell. Since a few days I am not more able to load pictures direct in. I don't know if the Galaxy is the problem, because in that time there was an update for its software too.

I've got Model Galaxy Nexus with Android 4.1.1, Baseband-Version I9250XXLFI, Kernel-Version 3.0.31-g6fb96c9 android-build@vpbs1 ) #1 SMP PREEMPT Thu Jun 28 11:02:39 PDT 2012, Build-Nummer JRO03C

I don't know since when it is not more working fine but I've got all pictures in until 12th,Juli 2012 - any new picture I am not able to load in with shotwell.

There is an error msg like the camera does a fault and because of it couldn't be the <count of the missing pitures> pictures loaded in!

Hope I did translate the errormsg well, because is in german and my English is only limitet.

Maybe someone knows a sollution

Didier Roche (didrocks) wrote :

confirmed here with 4.1

Changed in shotwell (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thanks for the report and for confirming, it might be an issue with the android update, not sure if the problem come from shotwell or some library it's using though (libgphoto?)

Changed in shotwell (Ubuntu):
importance: Undecided → High
Changed in shotwell (Ubuntu Precise):
importance: Undecided → High
Lucas Beeler (lucas-yorba) wrote :

We've ticketed this upstream here: http://redmine.yorba.org/issues/5566

I can confirm this happened after on my Samsung Galaxy after it upgraded from, if I recall correctly, v4.0.1 to v4.1.1.

What's interesting is after the upgrade I was able to sync only those photos which were taken before the updated, i.e. it's specific to the images and not the OS in general.

Something else to note is this only involves sync, not display. If I retrieve a post v4.1.1 image from the device using the the android tools I'm able to view it.

FWIW, I've attached the EXIF information from an images taken under v4.0.1 and a v4.1.1. The information was retrieved with exiftool. Note the change in "Exif Byte Order" values.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shotwell (Ubuntu Precise):
status: New → Confirmed

Looks like it's been fixed upstream. See: http://redmine.yorba.org/issues/5566

Perhaps this can be closed?

Jim Nelson (yorba-jim) wrote :

Yes, our testing indicates this is resolved with gPhoto 2.5.

Changed in shotwell (Ubuntu):
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

the new gphoto version is in Ubuntu 13.10, closing the bug

Changed in shotwell (Ubuntu):
status: Fix Committed → Fix Released

I am a little late to the party, however I briskly read through the majority of the comments on this and the related threads. I have a Samsung Galaxy Note 2, and I had this problem. However, it stems I believe from the MTP, and the new setup from the new USB protocol upon the phone's connection. When plugging mine in I had to switch its function from normal media device(MTP), to Camera(PTP). This is in the notification drop down menu, which comes down from the top of the screen, and on my Samsung Galaxy Note2, I found it was in the topmost window below the general settings horizontal slide toolbar. My Motorola XOOM, which operates on an older OS, w/o MTP, does not have this problem, and I tested it just again to make sure. Thus, the MTP causes problems, and thus Shotwell isn't the cause. Hopefully this helps! Also, I am using Ubuntu 12.04, and to get my Galaxy Note 2 to work I downloaded the latest backported openMTP ppa, with the link enclosed below:

https://launchpad.net/~langdalepl/+archive/gvfs-mtp

Hope this helps!

I just wanted to update, upon import however it appears that out of 250+ photos, 40 or so weren't able to be imported due to some sort of file incompatibility. But I double checked and it appears that these work, so there may be a couple glitches, however the majority of them were fine, and imported w/o fail. Again, this is on Ubuntu 12.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers