Ubuntu

Albatross: GTK3 apps are hard to read (white on light grey)

Reported by pqwoerituytrueiwoq on 2012-04-27
72
This bug affects 14 people
Affects Status Importance Assigned to Milestone
shimmer-themes (Ubuntu)
Undecided
Simon Steinbeiß

Bug Description

Using the Albatross theme on xubuntu 12.04
Take the password prompt for example

affected applications list (just a few examples, i could go on all day long)
gcalctool
software-center
password prompt (attached screenshot)
simple scan preferences
abiword
file roller (about dialog)
character map
transmission
update manager
mines
sudoku
solitaire (games->statistics, help->about)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shimmer-themes (Ubuntu):
status: New → Confirmed
MorrisseyJ (morrissey-james1) wrote :

This bug afffects me.

It seems to do the same thing using the HOPE and HOPE DT themes in Ubuntu.

Karl Kropf (ksk-clara) wrote :

I am getting unpredictable results using AmbianceBlue and Ambiance Colors - white text on light grey backgrounds in applications such as Advanced Settings (Gnome Tweak) as well as the shut down pop up. Worse still is Nautilus. the left hand panel has the white on light grey but the main window has a black background but sometimes dark grey and the pop up slider is black.

Ambiance seems to work fine

Michael Russo (mikeossur) wrote :

I am having the same issue with Albatross. If I use Greybird or Bluebird, all is good. It is not a critical problem but it sure annoying. I am surprised they released Xubuntu 12.04 with such a obvious bug.

@mikeossur
this is nothing compared to the fact that 80% of the themes do not even support gtk3 at all

Michael Russo (mikeossur) wrote :

@pqwoerituytrueiwoq
       I can live with the fact 88% don't work with gtk3 but at least make sure the ones Xubuntu provides, and especially the popular ones do. Come on folks!

@mikeossur
i was referring to the stock themes
i think only 2 or 3 of the 15 to 20 pre-installed themes actually support gtk3

Xan (dxpublica) wrote :

In 11.10 all was fine. When, I update to 12.04, I have this reading problems....

Michael Russo (mikeossur) wrote :

The prior version of Xubuntu did not have this problem. I only encountered it on the upgrade. :(

ubuntu 12.04 was the 1st to have gtk3 apps, before everything was gtk2 so there was no issue

braway (braway) wrote :

i attached a temporary solution for the albatross theme
that fixed it for me (after a restart)

braway (braway) wrote :

forgot to attach the patch :(

thanks for the patch loging out of mate and into xubuntu session worked for me
and here is a complete file for thoes who want a drop-in replacemet
it is the same patch as above just a complete file

i think the patch needs a patch for the weather applet it is dark text on dark backgorund in the panel

The attachment "albatross gtk3 patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch

This is what happens in audacious. In other cited programs, the same happens....

Nice to meet you,
Xan.

Michael Russo (mikeossur) wrote :

@pqwoerituytrueiwoq
           I tried to down load the file but it seemed to be incomplete.

probably got a wring file extension it is a .tar.gz also available here:
http://ubuntuforums.org/attachment.php?attachmentid=216911&d=1335756601

Pasi Lallinaho (knome) on 2012-05-02
summary: - GTK3 apps are extremlly hard to read
+ Albatross: GTK3 apps are hard to read (white on light grey)
Aai (aaimaai) wrote :

Since the tar.gz file of pqwoerituytrueiwoq cannot be opened I added an attachment with the complete file with the above patch applied to it. It can be placed in /usr/share/themes/Albatross/gtk-3.0/ overwriting the existing file.

Paul (paulsantman) wrote :

I can confim this bug as well (Xubuntu 12.04) and (for example) Ambiance-Xfce-LXDE theme. The suggested changes to the gtk.widgets.css solve this issue.

Just to be clear; the changes should be applied to the gtk.widgets.css file in the gtk-3.0 folder of the specific theme.
Lines with a (-) in front need to be removed. Lines with (+) in front need to be added.

tim (acmeinc) wrote :

The suggested fix has worked for the most part. However, all window titles are blurry, even the top-most window. Previously, only background window titles were blurry.

Paul (paulsantman) wrote :

I have to agree with Tim;

the patch creates some new problems. For example, on various applications, icons now show a annoying white border around themselves. It is visible for applications like Gcalctool, the Update Manager and in general most Dialogue screens. I have attached a screenshot to compare an unpatched theme and a patched theme.

Simon Steinbeiß (ochosi) wrote :

I'll fix this for real in due time, since there has been (staggeringly slow) progress on revitalising Albatross, I'm hesitant to update the gtk3 theme when I'll maybe have to change it again soon.
Sorry for the inconvenience in the meantime.

(Btw, if any of you are interested in helping out with theme-maintenance feel free to contact me, I don't have enough time for all of it anyway.)

Simon Steinbeiß (ochosi) wrote :

There is now a release of Albatross that fixes all these issues with Gtk3.
You can grab it here: https://github.com/shimmerproject/Albatross/tarball/v1.2

This will land in Quantal, since it's a complete rewrite of the Gtk3 theme it probably won't get to Precise :(

Changed in shimmer-themes (Ubuntu):
assignee: nobody → Simon Steinbeiß (simon-steinbeiss)
status: Confirmed → Fix Committed

Weather applet text is still the wrong color :(

Simon Steinbeiß (ochosi) wrote :

The weather applet is Gtk2, please report a separate bug for it (I'll try to fix it though).

jcfp (jcfp) wrote :

Finally, I can see and use all those applications again. Simon and others, thanks for the information and the fixed theme.

Personally, I'd love to see a regression this severe fixed with a stable release update (https://wiki.ubuntu.com/StableReleaseUpdates). The fact that this bug essentially makes a whole lot of applications absolutely unusable, including high profile onces such as the update manager, should help to make a case for such an update. Although canonical might want some minimal changes fix for the theme that's in precise right now rather than an all new version.

Simon Steinbeiß (ochosi) wrote :

Sorry, from what I know it's too many changes (a rewrite of the Gtk3 theme) to get backported. Only small fixes usually get approved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shimmer-themes - 1.5.0-0ubuntu1

---------------
shimmer-themes (1.5.0-0ubuntu1) quantal; urgency=low

  * Update Greybird to latest tag (v0.9). lp: #924853,#947436,#982820,#1016713
  * Update Bluebird to latest tag (v0.6). lp: #686239,#977431
  * Update Albatross to latest tag (v1.2). lp: #989814,#1023056
  * debian/control: demote gtk3-engines-unico to recommends as most themes
    are now engine-free.
  * debian/shimmer-wallpapers.install: update paths, wallpapers are in their
    own branch/subtarball now.
  * debian/shimmer-themes.install: ship Albatross' metacity theme.
  * debian/shimmer-themes.links: drop greybird -> Greybird compatibility
    symlinks. lp: #985320
 -- Lionel Le Folgoc <email address hidden> Sat, 28 Jul 2012 22:28:31 +0200

Changed in shimmer-themes (Ubuntu):
status: Fix Committed → Fix Released
Cvetan Simsic (cvetan-simsic) wrote :

I just installed shimmer themes 1.5.

Why have the blue color replaced gray in menu items on Greybird? It doesn't look like Greybird anymore. :( It looks like Mac theme. :(

ceg (ceg) wrote :

Will the resizing handle in the bottom right window corner and albatross readability fix come to the LTS?

Simon Steinbeiß (ochosi) wrote :

@ceg, please read my comments above.

ceg (ceg) wrote :

Thanks for the honest assessment. Too bad if LTS "support" is such that it means to be stuck with countless bugs.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers