Split theme packages do not properly declare conflicts

Bug #1347705 reported by Wellington Torrejais da Silva on 2014-07-23
122
This bug affects 15 people
Affects Status Importance Assigned to Milestone
shimmer-themes (Ubuntu)
Low
Unassigned

Bug Description

Separated shimmer themes do not install correctly due to incorrectly reporting the Provided name as well as setting Conflicts. Split themes should not be co-installable except as part of an overall package.

ProblemType: Package
DistroRelease: Ubuntu 14.10
Package: albatross-gtk-theme (not installed)
ProcVersionSignature: Ubuntu 3.16.0-5.10-generic 3.16.0-rc6
Uname: Linux 3.16.0-5-generic x86_64
ApportVersion: 2.14.4-0ubuntu2
Architecture: amd64
Date: Wed Jul 23 10:50:34 2014
DpkgTerminalLog:
 Preparing to unpack .../albatross-gtk-theme_1.7.3-0ubuntu2_all.deb ...
 Unpacking albatross-gtk-theme (1.7.3-0ubuntu2) ...
 dpkg: error processing archive /var/cache/apt/archives/albatross-gtk-theme_1.7.3-0ubuntu2_all.deb (--unpack):
  a tentar sobre-escrever '/usr/share/themes/Albatross/gtk-3.0/assets/radio-selected.png', que também está no pacote shimmer-themes 1.7.3-0ubuntu1
DuplicateSignature: package:albatross-gtk-theme:(not installed):a tentar sobre-escrever '/usr/share/themes/Albatross/gtk-3.0/assets/radio-selected.png', que também está no pacote shimmer-themes 1.7.3-0ubuntu1
ErrorMessage: a tentar sobre-escrever '/usr/share/themes/Albatross/gtk-3.0/assets/radio-selected.png', que também está no pacote shimmer-themes 1.7.3-0ubuntu1
InstallationDate: Installed on 2014-05-16 (67 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: shimmer-themes
Title: package albatross-gtk-theme (not installed) failed to install/upgrade: a tentar sobre-escrever '/usr/share/themes/Albatross/gtk-3.0/assets/radio-selected.png', que também está no pacote shimmer-themes 1.7.3-0ubuntu1
UpgradeStatus: No upgrade log present (probably fresh install)

tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shimmer-themes (Ubuntu):
status: New → Confirmed
summary: - package albatross-gtk-theme (not installed) failed to install/upgrade: a
- tentar sobre-escrever '/usr/share/themes/Albatross/gtk-3.0/assets/radio-
- selected.png', que também está no pacote shimmer-themes 1.7.3-0ubuntu1
+ Split theme packages do not properly declare conflicts
description: updated
description: updated

From Xubuntu Bugs Overwatch, the following workaround is offered:

Do not install more than one theme package at a time. Currently the packages are not co-installable. Action will need to be taken to ensure the packaging of the themes are updated to ensure that you cannot attempt to install more than one theme at the same time.

Changed in shimmer-themes (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
LAZA (laza74) wrote :

To Xubuntu Bugs Overwatch:

I for myself installed *no* additional theme packages, just a plain Xubuntu 14.04 and some packages i regularly use (Libreoffice, VLC, Rhythmbox, ...)

Then i did a upgrade to upcoming 14.10 and got this yesterday updating the system.

Maybe there should be a extra window at installation with the choice which of the themes should be installed...

LAZA,

The hint that this was a co-installables failure was when you showed the packages removed and you had numix removed according to the automatic resolution apt did. If you got numix from a PPA that particular package had some known issues just like the new split themes such as albatross-gtk-theme. That was the key to what tied these several bugs together. In 14.04, the themes were all in one package "shimmer-themes" which the numix package did not play nice with when installed alongside. Broken apart as they are in 14.10, they present a packaging error that is being fixed.

The numix package counts as a "theme" like the others do for the purpose of determining how everything on your screen is decorated even though it is normally thought of only in regards to the icon set.

Elfy (elfy) wrote :

@skellat - just for the record - I have had exactly the same issue for all of the default installed xubuntu themes - I am completely positive that all I did was upgrade shimmer-themes, Sean was aware within a few minutes of it all going wrong for me - the same happened to him :)

Sean Davis (bluesabre) wrote :

Thanks for the bug report. I've fixed this in the upcoming shimmer-themes 1.8.0 package. This should land in the archive later today.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shimmer-themes - 1.8.0-0ubuntu1

---------------
shimmer-themes (1.8.0-0ubuntu1) utopic; urgency=medium

  * Fix package upgrades from previous shimmer-themes (LP: #1347705)
    - debian/control:
      - Add Breaks and Replaces for shimmer-themes (<< 1.8.0)
 -- Sean Davis <email address hidden> Fri, 25 Jul 2014 08:15:06 -0400

Changed in shimmer-themes (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers