Ubuntu

GTK3 application themes broken with xubuntu 13.04 themes

Reported by Kristian Rink on 2013-04-02
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
shimmer-themes (Ubuntu)
Undecided
Unassigned

Bug Description

Starting someday around mid March 2013, GTK+ 3.0 based applications started looking ugly on Xubuntu 13.04 applications with "stock" Xubuntu themes. Attached a sample for that (gthumb). Reproducibly happens on two different machines (laptop, netbook, both running Xubuntu 13.04 installed from a daily build), and only with GTK + 3.0 applications (evince, gthumb, lightdm-gtk-greeter) with GreyDay and Grey/BlueBird themes.

Kristian Rink (kawazu) wrote :
affects: gtk+3.0 (Ubuntu) → ubuntu
affects: ubuntu → xubuntu-default-settings (Ubuntu)
affects: xubuntu-default-settings (Ubuntu) → shimmer-themes (Ubuntu)

Did you somehow update GTK+ to version 3.8? Maybe by adding the Gnome 3.8 PPA? This would indeed break the mentioned themes partially.

Simon Steinbeiß (ochosi) wrote :

Yes, that's Gtk3.8
The fixed version is already in github, feel free to grab it from there, but it most likely won't get fixed for Raring.
https://github.com/shimmerproject/Greybird

tags: added: raring

Would it be possible to provide an updated package including support for GTK+ 3.8 via the Shimmer Project PPA?

Looks like the indicator buttons in the top right corner of the LightDM screen (theme-name=Greybird) are missing a transparent background. Currently the icons are embedded in a gray-ish box placed on the dark panel.

Simon Steinbeiß (ochosi) wrote :

You mean with the version from git or with the version that's shipped with Raring?
(If it's from Raring, that's not surprising at all.)

I replaced gtk-widgets.css with the version from git. Menus are displayed fine again, but the indicator buttons are missing transparency.

Simon Steinbeiß (ochosi) wrote :

Hmpf, right, I'll have to fix lightdm-gtk-greeter.css too...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shimmer-themes (Ubuntu):
status: New → Confirmed
Simon Steinbeiß (ochosi) wrote :

Hey, could you try to replace apps/lightdm-gtk-greeter.css with the attached file and see whether that fixes the issue of indicators in the greeter for you? Thanks!

Replaced the file, but it did not fix the issue. While not clicked the indicator icons are still inside a gray, not transparent box.

thad@local:/usr/share/themes/Greybird/gtk-3.0/apps$ diff lightdm-gtk-greeter.css lightdm-gtk-greeter.css.old
86d85
< background-image: none;

Simon Steinbeiß (ochosi) wrote :

I just pushed a fix for lightdm-gtk-greeter and Gtk3.8 to git master.
As far as I could test, it should work without regressions in Gtk3.6 or older/newer versions of the greeter.

Changed in shimmer-themes (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shimmer-themes - 1.6.1-0ubuntu1

---------------
shimmer-themes (1.6.1-0ubuntu1) saucy; urgency=low

  * New releases of all themes (Albatross:v1.4, Bluebird:v0.8,
    Greybird:v1.2.1, Numix:v1.9, Orion:v1.2).
  * Bugs fixed:
    - Orion window decorations don't seem to render properly, lp: #1217604
    - Albatross: Text color issue for new gnome menus, lp: #1185111
    - GTK3 application themes broken with xubuntu 13.04 themes, lp: #1163128
    - Weather applet has wrong text color in Albatross, lp: #1144538
    - greybird - libreoffice 3.6.4 white ticks on white background, lp: #1092758
    - Orion theme menus are very ugly in Gtk3, lp: #1217607
  * Include patches for overlay scrollbar fix (lp: #1199707):
    - debian/patches/bluebird_fix_overlay_scrollbar.patch,
      debian/patches/greybird_fix_overlay_scrollbar.patch,
      debian/patches/numix_fix_overlay_scrollbar.patch,
      debian/patches/orion_fix_overlay_scrollbar.patch: added.
 -- Lionel Le Folgoc <email address hidden> Thu, 29 Aug 2013 10:43:51 +0200

Changed in shimmer-themes (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers