package shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1683221 reported by vikash singh on 2017-04-17
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
shim-signed (Ubuntu)
Undecided
Unassigned

Bug Description

During upgrade to ubuntu 17.04 the error occurred

ProblemType: Package
DistroRelease: Ubuntu 17.04
Package: shim-signed 1.28+0.9+1474479173.6c180c6-1ubuntu1
Uname: Linux 4.10.10-041010-generic x86_64
.proc.sys.kernel.moksbstate_disabled: Error: [Errno 2] No such file or directory: '/proc/sys/kernel/moksbstate_disabled'
.sys.firmware.efi.efivars.MokSBStateRT-605dab50-e046-4300-abb6-3dd810dd8b23: Error: [Errno 2] No such file or directory: '/sys/firmware/efi/efivars/MokSBStateRT-605dab50-e046-4300-abb6-3dd810dd8b23'
.sys.firmware.efi.efivars.SecureBoot-8be4df61-93ca-11d2-aa0d-00e098032b8c: 

vikash singh (singhvkash) wrote :
Steve Langasek (vorlon) wrote :

The error in your log is:

Installing for x86_64-efi platform.
grub-install: error: cannot open `/boot/efi/EFI/ubuntu/shimx64.efi': Read-only file system.
Failed: grub-install --target=x86_64-efi

Your ESP must be mounted at /boot/efi and must be mounted read-write in order to upgrade the bootloader.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers