package shim-signed 1.3+0.4-0ubuntu3 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1.

Bug #1246910 reported by Aisano on 2013-10-31
120
This bug affects 24 people
Affects Status Importance Assigned to Milestone
shim-signed (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned
Quantal
Undecided
Unassigned
Raring
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

[SRU justification]
If users install the grub-pc package on a machine booted under Secure Boot, the system will still be bootable but there will be avoidable package upgrade errors when installing a new version of the shim-signed package. We should ensure that UEFI users don't accidentally get their package system into a wedged state, by ensuring shim-signed pulls in the necessary efi grub package as a dependency and calls grub-install in a way that works reliably even when grub-pc has been installed.

[Test case]
1. Install on a machine that boots using UEFI.
3. Install the grub-pc package.
4. Upgrade to the shim-signed package from -updates.
5. Verify that the upgrade fails.
6. Install the shim-signed package from -proposed.
7. Verify that the upgrade succeeds.

[Regression potential]
Minimal. The --target=x86_64-efi option to grub-install is supported in all relevant versions, and adding it explicitly should not cause any failures in scenarios where the shim-signed package is currently working.

Upgrade from 13.04 to 13.10 broke off.
Warning about possibly unusable system appeared.

ProblemType: Package
DistroRelease: Ubuntu 13.10
Package: shim-signed 1.3+0.4-0ubuntu3
ProcVersionSignature: Ubuntu 3.8.0-32.47-generic 3.8.13.10
Uname: Linux 3.8.0-32-generic x86_64
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: amd64
Date: Thu Oct 31 22:50:18 2013
DuplicateSignature: package:shim-signed:1.3+0.4-0ubuntu3:ErrorMessage: subprocess installed post-installation script returned error exit status 1
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2013-04-05 (209 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: shim-signed
Title: package shim-signed 1.3+0.4-0ubuntu3 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to saucy on 2013-10-31 (0 days ago)

Aisano (info-ais-sanmarino) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5

---------------
shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Thu, 31 Oct 2013 17:06:21 -0700

Changed in shim-signed (Ubuntu):
status: New → Fix Released
Aisano (info-ais-sanmarino) wrote :

It's good to see this problem has been taken care of. Still, "dpkg -s shim-signed" tells me I am using 1.3, not 1.5, and apt-get tells me I am using the latest version. At least my system booted despite the interrupted update from 13.04 to 13.10 but I do not know how up-to-date it is. Update-manager today gave me a general failure message but finds no more pending updates when I re-run it.

When I run apt-get upgrade I get the following (it is partly in Esperanto and partly in German; I try to give a translation):

Elpakado de anstataŭanto libhud-client2:amd64 ...
Ni prepariĝas por anstataŭigi hud 13.10.1+13.10.20131014-0ubuntu1 (uzante .../hud_13.10.1+13.10.20131024-0ubuntu1_amd64.deb) ...
Elpakado de anstataŭanto hud ...
Procezado de ekigiloj por libglib2.0-0:amd64 ...
Procezado de ekigiloj por libglib2.0-0:i386 ...
Ni alĝustigas shim-signed (1.3+0.4-0ubuntu3) ...
Instal-aparato ne estas specifita.
Uzo: grub-install [OPCIO] [INSTAL_APARATO]
GRUB auf Ihrem Laufwerk installieren.
---- translation:
Unpacking of replacement libhud-client2:amd64 ...
Preparing to replace hud 13.10.1+13.10.20131014-0ubuntu1 (using .../hud_13.10.1+13.10.20131024-0ubuntu1_amd64.deb) ...
Unpacking replacement hud ...
Processing triggers for libglib2.0-0:amd64 ...
Processing triggers for libglib2.0-0:i386 ...
Setting up shim-signed (1.3+0.4-0ubuntu3) ...
Install device isn't specified.
Usage: grub-install [OPTION] [INSTALL_DEVICE]
Install GRUB on your drive.
-- grub help text follows --

A strange thing is that I cannot find this bug in launchpad though it "affects" me -- I had to search it by Google.

Colin Watson (cjwatson) wrote :

Aisano, this bug has been fixed in trusty, but it still needs to be copied to stable releases. There should be a message posted to this bug with information on how to help verify it once that process starts.

Aisano (info-ais-sanmarino) wrote :

Thanks, Colin. I have not yet switched to trusty -- switched to 13.10 only yesterday. Somewhat busy in job (understatement of the week).

Steve Langasek (vorlon) on 2013-11-07
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shim-signed (Ubuntu Precise):
status: New → Confirmed
Changed in shim-signed (Ubuntu Quantal):
status: New → Confirmed
Changed in shim-signed (Ubuntu Raring):
status: New → Confirmed
Changed in shim-signed (Ubuntu Saucy):
status: New → Confirmed

Hello Aisano, or anyone else affected,

Accepted shim-signed into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~12.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Precise):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in shim-signed (Ubuntu Quantal):
status: Confirmed → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Aisano, or anyone else affected,

Accepted shim-signed into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~12.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Raring):
status: Confirmed → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Aisano, or anyone else affected,

Accepted shim-signed into raring-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~13.04.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in shim-signed (Ubuntu Saucy):
status: Confirmed → Fix Committed
Stéphane Graber (stgraber) wrote :

Hello Aisano, or anyone else affected,

Accepted shim-signed into saucy-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/shim-signed/1.5~13.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~13.10.1

---------------
shim-signed (1.5~13.10.1) saucy; urgency=low

  * Backport to Ubuntu 13.10.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:47:35 -0800

Changed in shim-signed (Ubuntu Saucy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~12.04.1

---------------
shim-signed (1.5~12.04.1) precise; urgency=low

  * Backport to Ubuntu 12.04 LTS.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Thu, 07 Nov 2013 10:29:43 -0800

Changed in shim-signed (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~12.10.1

---------------
shim-signed (1.5~12.10.1) quantal; urgency=low

  * Backport to Ubuntu 12.10.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:36:26 -0800

Changed in shim-signed (Ubuntu Quantal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shim-signed - 1.5~13.04.1

---------------
shim-signed (1.5~13.04.1) raring; urgency=low

  * Backport to Ubuntu 13.04.

shim-signed (1.5) trusty; urgency=low

  * Pass --target=x86_64-efi to grub-install from the postinst and depend on
    grub-efi-amd64-bin, so that package upgrades will do the right thing
    even if the system has been rebooted under BIOS. LP: #1246910.
  * Kubuntu sets GRUB_DISTRIBUTOR to a different value which doesn't match
    the path under /boot/efi; fix this up so shim-signed upgrades properly
    on Kubuntu systems. LP: #1242417.
 -- Steve Langasek <email address hidden> Fri, 08 Nov 2013 10:45:25 -0800

Changed in shim-signed (Ubuntu Raring):
status: Fix Committed → Fix Released
Simon Déziel (sdeziel) wrote :

It seems this update introduced a regression, at least Precise. See LP: #1250611 for details.

tags: added: regression-update
Stéphane Graber (stgraber) wrote :

Re-opening the precise task as the fix wasn't compatible with precise's grub and had to be reverted there.

Changed in shim-signed (Ubuntu Precise):
status: Fix Released → Triaged
Alberto (alberto-pinheira) wrote :

installArchives() failed: Setting up shim-signed (1.5~12.04.1+0.4-0ubuntu4) ...
Unrecognized option `--target=x86_64-efi'
Usage: grub-install [OPTION] install_device
Install GRUB on your drive.

  -h, --help print this message and exit
  -v, --version print the version information and exit
  --root-directory=DIR install GRUB images under the directory DIR
                          instead of the root directory
  --grub-shell=FILE use FILE as the grub shell
  --no-floppy do not probe any floppy drive
  --force-lba force GRUB to use LBA mode even for a buggy
                          BIOS
  --recheck probe a device map even if it already exists

INSTALL_DEVICE can be a GRUB device name or a system device filename.

grub-install copies GRUB images into the DIR/boot directory specfied by
--root-directory, and uses the grub shell to install grub into the boot
sector.

Report bugs to <email address hidden>.
dpkg: error processing shim-signed (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 shim-signed
Setting up shim-signed (1.5~12.04.1+0.4-0ubuntu4) ...
Unrecognized option `--target=x86_64-efi'
Usage: grub-install [OPTION] install_device
Install GRUB on your drive.

  -h, --help print this message and exit
  -v, --version print the version information and exit
  --root-directory=DIR install GRUB images under the directory DIR
                          instead of the root directory
  --grub-shell=FILE use FILE as the grub shell
  --no-floppy do not probe any floppy drive
  --force-lba force GRUB to use LBA mode even for a buggy
                          BIOS
  --recheck probe a device map even if it already exists

INSTALL_DEVICE can be a GRUB device name or a system device filename.

grub-install copies GRUB images into the DIR/boot directory specfied by
--root-directory, and uses the grub shell to install grub into the boot
sector.

Report bugs to <email address hidden>.
dpkg: error processing shim-signed (--configure):
 subprocess installed post-installation script returned error exit status 1

what should i do?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers