Silence bogus apache 1.3 warning

Bug #1984194 reported by Tom Misilo
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
shibboleth-sp (Ubuntu)
Confirmed
Undecided
Unassigned

Bug Description

I noticed with Ubuntu 22.04LTS that the mod_shib (libapache2-mod-shib) package is spamming the apache error logs with the following

[Wed Aug 10 09:05:59.526216 2022] [mod_shib:warn] [pid 1340314] DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+
[Wed Aug 10 09:05:59.527768 2022] [mod_shib:warn] [pid 1340313] DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+
[Wed Aug 10 09:05:59.541690 2022] [mod_shib:warn] [pid 1340318] DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+
[Wed Aug 10 09:05:59.555601 2022] [mod_shib:warn] [pid 1340315] DEPRECATED: Apache 1.3 module, please upgrade to Apache 2.4+

This commit http://git.shibboleth.net/view/?p=cpp-sp.git;a=blobdiff;f=apache/mod_shib.cpp;h=1a1f2543c817bfccbfc3feea8b430a14b2d2e457;hp=6b1dc676e15f9ae1fcbefb82f98dcedbcdce2566;hb=7b5c7aced15c0be5404bcba0bcec4c586323fba9;hpb=529e2b2bf67cff93118b67a3587dec78d32595c3 from upsteam resolves the issue, and will be in a future 3.3.1 release.

Could this be applied as a patch to the current 3.3.0 in U22?

Thanks!

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in shibboleth-sp (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.