Ubuntu

Add support for MS Excel 2007 Formats - Needed for OOo

Reported by Chris Cheney on 2008-03-28
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
shared-mime-info (Ubuntu)
Low
Unassigned
Hardy
High
Unassigned

Bug Description

Binary package hint: shared-mime-info

I saved out test files for every format that MS Excel 2007 supports saving and used gvfs-info to report what it thought about each file. It seems that most of them are not supported for detection yet. I will attach a zip file with all formats MS Excel 2007 can save out to:

These need to be improved for certain:

example - dif data interchange format.dif : text/plain - application/octet-stream
example - excel 2007 add-in.xlam : application/zip - application/octet-stream
example - excel 2007 binary workbook.xlsb : application/zip - application/octet-stream
example - excel 2007 macro-enabled template.xltm : application/zip - application/octet-stream
example - excel 2007 template.xltx : application/zip - application/octet-stream
example - formatted text space delimited.prn : text/plain - application/octet-stream
example - single file web page.mht : text/plain - application/octet-stream
example - xml spreadsheet 2003.xml : application/xml - application/xml

The following could be improved by subclassing them, but it might not really be too big of a deal...

example - web page.htm : text/html - text/html

I will also have additional bugs for Access/PowerPoint/Word file formats.

Thanks!

Chris Cheney

Chris Cheney (ccheney) wrote :
Changed in shared-mime-info:
importance: Undecided → High
milestone: none → ubuntu-8.04
berg (berg-foss) wrote :

@cris
I think that I understood your idea: the objective is "know" what file is. "Work" with the file or "open" this file is a openoffice's ( koffice, abiword etc) problem ( a big ooxml problem - ISO raped :)

http://avi.alkalay.net/2008/03/how-microsoft-raped-iso.html

linking bugs:
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/208062
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/208071
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/208092
https://bugs.launchpad.net/ubuntu/+source/shared-mime-info/+bug/208096

Chris Cheney (ccheney) on 2008-04-01
Changed in shared-mime-info:
milestone: ubuntu-8.04 → none
Changed in shared-mime-info:
status: New → Confirmed
Chris Cheney (ccheney) on 2008-05-08
Changed in shared-mime-info:
milestone: none → ubuntu-8.10-beta
Andres Mujica (andres.mujica) wrote :

Hi, should we mark this linked bugs as duplicate off bug #138252 or viceversa? it seems that this set of bugs are being worked on??

Sebastien Bacher (seb128) wrote :

the excel 2007 example are correctly recognized in jaunty lowering the settings

Changed in shared-mime-info:
importance: High → Low
milestone: ubuntu-8.10-beta → none
Grzegorz G. (grzesiek1e5) wrote :

All those files are recognized, marking as fix released.

Changed in shared-mime-info (Ubuntu):
status: Confirmed → Fix Released
Jackson Doak (noskcaj) wrote :

Hardy's no longer supported, won't fix

Changed in shared-mime-info (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers