Ubuntu

"unknown media type" during update

Reported by Bogdan Butnaru on 2008-02-19
132
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Nautilus
Confirmed
Unknown
shared-mime-info
Fix Released
Medium
shared-mime-info (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Messages below seen during the latest round of updates. The messages from several packages seem to be mixed around, so I'm not sure which one triggered them. I suspect nautilus.

Setting up shared-mime-info (0.23-3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up ucf (3.004-0ubuntu3) ...

Setting up seahorse (2.21.91-0ubuntu3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up ubuntu-gdm-themes (0.24) ...
Setting up linux-restricted-modules-common (2.6.24.9-8.25) ...

Setting up nautilus-data (1:2.21.91-0ubuntu3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up compiz-core (1:0.7.0-0ubuntu3) ...

Created an attachment (id=14128)
x-content.patch

Bogdan Butnaru (bogdanb) wrote :

Messages below seen during the latest round of updates. The messages from several packages seem to be mixed around, so I'm not sure which one triggered them. I suspect nautilus.

Setting up shared-mime-info (0.23-3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up ucf (3.004-0ubuntu3) ...

Setting up seahorse (2.21.91-0ubuntu3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up ubuntu-gdm-themes (0.24) ...
Setting up linux-restricted-modules-common (2.6.24.9-8.25) ...

Setting up nautilus-data (1:2.21.91-0ubuntu3) ...
Unknown media type in type 'x-content/video-vcd'

Unknown media type in type 'x-content/video-svcd'

Unknown media type in type 'x-content/video-dvd'

Unknown media type in type 'x-content/image-dcf'

Unknown media type in type 'x-content/audio-cdda'

Unknown media type in type 'x-content/blank-cd'

Unknown media type in type 'x-content/blank-dvd'

Unknown media type in type 'x-content/blank-bd'

Unknown media type in type 'x-content/blank-hddvd'

Unknown media type in type 'x-content/audio-dvd'

Unknown media type in type 'x-content/video-bluray'

Unknown media type in type 'x-content/video-hddvd'

Unknown media type in type 'x-content/image-picturecd'

Unknown media type in type 'x-content/audio-player'

Unknown media type in type 'x-content/software'

Setting up compiz-core (1:0.7.0-0ubuntu3) ...

Bruce Cowan (bruce89) wrote :

I'll confirm this one, as long as no-one else does as well.

2008-02-21 Bastien Nocera <email address hidden>

        * update-mime-database.c: Patch from Ed Catmur <email address hidden>
        to avoid warnings with the new x-content/ stuff in GNOME 2.22
        (Closes: #14362)

Savvas Radevic (medigeek) wrote :

confirming:
Preparing to replace bluez-gnome 0.15-0ubuntu2 (using .../bluez-gnome_0.23-0ubuntu1_amd64.deb) ...
Unpacking replacement bluez-gnome ...
Unknown media type in type 'x-content/video-vcd'
Unknown media type in type 'x-content/video-svcd'
Unknown media type in type 'x-content/video-dvd'
Unknown media type in type 'x-content/image-dcf'
Unknown media type in type 'x-content/audio-cdda'
Unknown media type in type 'x-content/blank-cd'
Unknown media type in type 'x-content/blank-dvd'
Unknown media type in type 'x-content/blank-bd'
Unknown media type in type 'x-content/blank-hddvd'
Unknown media type in type 'x-content/audio-dvd'
Unknown media type in type 'x-content/video-bluray'
Unknown media type in type 'x-content/video-hddvd'
Unknown media type in type 'x-content/image-picturecd'
Unknown media type in type 'x-content/audio-player'
Unknown media type in type 'x-content/software'

Setting up capplets-data (1:2.21.90-0ubuntu4) ...
Unknown media type in type 'x-content/video-vcd'
Unknown media type in type 'x-content/video-svcd'
Unknown media type in type 'x-content/video-dvd'
Unknown media type in type 'x-content/image-dcf'
Unknown media type in type 'x-content/audio-cdda'
Unknown media type in type 'x-content/blank-cd'
Unknown media type in type 'x-content/blank-dvd'
Unknown media type in type 'x-content/blank-bd'
Unknown media type in type 'x-content/blank-hddvd'
Unknown media type in type 'x-content/audio-dvd'
Unknown media type in type 'x-content/video-bluray'
Unknown media type in type 'x-content/video-hddvd'
Unknown media type in type 'x-content/image-picturecd'
Unknown media type in type 'x-content/audio-player'
Unknown media type in type 'x-content/software'

Matti Lindell (mlind) wrote :

Messages are caused by /usr/share/mime/packages/nautilus.xml (installed by nautilus-data) when maintainer scripts invoke 'update-mime-database /usr/share/mime'. Looks harmless, but annoying. Reported types are probably not official IANA MIME types, so warnings are thrown.

Bernhard Schuster (drahnr) wrote :

I can confirm this aswell. Will this be fixed somehow?

Gina (ginalinux) wrote :

I confirm this too.

Savvas Radevic (medigeek) wrote :

another one
Setting up nautilus-data (1:2.21.92svn20080303-0ubuntu2) ...
Unknown media type in type 'x-content/video-vcd'
Unknown media type in type 'x-content/video-svcd'
Unknown media type in type 'x-content/video-dvd'
Unknown media type in type 'x-content/image-dcf'
Unknown media type in type 'x-content/audio-cdda'
Unknown media type in type 'x-content/blank-cd'
Unknown media type in type 'x-content/blank-dvd'
Unknown media type in type 'x-content/blank-bd'
Unknown media type in type 'x-content/blank-hddvd'
Unknown media type in type 'x-content/audio-dvd'
Unknown media type in type 'x-content/video-bluray'
Unknown media type in type 'x-content/video-hddvd'
Unknown media type in type 'x-content/image-picturecd'
Unknown media type in type 'x-content/audio-player'
Unknown media type in type 'x-content/software'

Sebastien Bacher (seb128) wrote :

confirmed that's not an issue though those are using in nautilus

Changed in nautilus:
assignee: nobody → desktop-bugs
importance: Undecided → Low
Colin Stark (cstark) wrote :

I can confirm this too.
Appears for package nautilus-data as well as a few others but i didn't see the others the last round of updates i just did.
Doesn't seem to affect anything - just a warning that's a little annoying.

A bit of aesthetics does no harm :)

Sebastien Bacher (seb128) wrote :

the bug is confirmed no need to add other comments to say you have the issue too

Kees Cook (kees) wrote :

Here's a possible fix to disable the warnings when encountering X- mimetypes (which by definition aren't official yet). seb128, do you think this should be applied?

Kees Cook (kees) wrote :

Corrected debdiff...

Changed in nautilus:
status: Unknown → Incomplete
fabioamd87 (fabioamd87) wrote :

i can confirm

Bruce Cowan (bruce89) wrote :

Please don't "confirm" already confirmed bugs.

Changed in nautilus:
status: Confirmed → Triaged
Sebastien Bacher (seb128) wrote :
Changed in nautilus:
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package shared-mime-info - 0.23-4ubuntu1

---------------
shared-mime-info (0.23-4ubuntu1) hardy; urgency=low

  * debian/control.in:
    - updated maintainer information
  * debian/patches/90_no_xcontent_warning.patch:
    - don't display warnings about x-content mimetypes when updating
      (lp: #193325)

 -- Sebastien Bacher <email address hidden> Thu, 13 Mar 2008 17:28:20 +0100

Changed in shared-mime-info:
status: Fix Committed → Fix Released
Kees Cook (kees) wrote :

Hah! Yes, that's much simpler. :)

Changed in shared-mime-info:
status: Unknown → Fix Released
Changed in nautilus:
status: Incomplete → New
Changed in nautilus:
status: New → Confirmed
Lucio (lumatemp-nospam) wrote :

A similar output came out when I upgraded to intrepid and also today while upgrading the kernel to 2.6.27-10-generic.

Installed shared-mime-info version is 0.51-0ubuntu1

Is it possible that this message appears if nautilus isn't running? (e.g. killed or segfaulted)

Uqbar (uqbar) wrote :

The problem is still here in Jaunty.

David Favor (davidfavor) wrote :

Problem still exists in Karmic Alpha 5 released today.

David Favor (davidfavor) wrote :

This bug still exists in Karmic as of today.

root@hive2:~# apt-get --reinstall install shared-mime-info
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 362kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 http://us.archive.ubuntu.com karmic/main shared-mime-info 0.60-2 [362kB]
Fetched 362kB in 2s (167kB/s)
(Reading database ... 105306 files and directories currently installed.)
Preparing to replace shared-mime-info 0.60-2 (using .../shared-mime-info_0.60-2_i386.deb) ...
Unpacking replacement shared-mime-info ...
Processing triggers for man-db ...
Processing triggers for doc-base ...
Processing 1 changed doc-base file(s)...
Registering documents with scrollkeeper...
Setting up shared-mime-info (0.60-2) ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

root@hive2:~# dpkg -l | grep shared-mime-info
ii shared-mime-info 0.60-2 FreeDesktop.org shared MIME database and spe...

hikaricore (hikaricore) wrote :

Still in beta as well.

Sebastien Bacher (seb128) wrote :

the other warnings are bug #289592

NoOp (glgxg) wrote :
Download full text (12.6 KiB)

2.6.31-15-generic #50-Ubuntu SMP Tue Nov 10 14:54:29 UTC 2009 i686 GNU/Linux
The issue appears to be in kdelibs5-data

I noticed this immediately after installing amarok. Thought that might be the problem, so I purged amarok & still get the messages. Then I notice after purging amarok the following are listed for autoremove:
$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  amarok-common amarok-utils kdemultimedia-kio-plugins libkcddb4 liblastfm0
  libqtscript4-core libqtscript4-gui libqtscript4-network libqtscript4-sql
  libqtscript4-uitools libqtscript4-xml libtag-extras1
0 upgraded, 0 newly installed, 12 to remove and 1 not upgraded.
After this operation, 29.0MB disk space will be freed.
Do you want to continue [Y/n]?

That didn't work. so now that amarok is fully purged I reinstall kdelibs5 & purge it (I can reinstall the apps it removes):
$ sudo apt-get purge kdelibs5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libfli1 klettres-data libindi0 libnova-0.12-2
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  gwenview* kdebase-bin* kdebase-runtime* kdebase-runtime-bin-kde4*
  kdelibs-bin* kdelibs5* khelpcenter* khelpcenter4* klettres* klipper*
  kompare* konsole* krdc* krfb* kstars* libkipi6* libknotificationitem1*
  libokularcore1* libplasma3* okular* okular-extra-backends*
0 upgraded, 0 newly installed, 21 to remove and 1 not upgraded.
After this operation, 59.3MB disk space will be freed.
Do you want to continue [Y/n]? y
(Reading database ... 335134 files and directories currently installed.)
Removing gwenview ...
Purging configuration files for gwenview ...
Removing kdebase-bin ...
Purging configuration files for kdebase-bin ...
Removing klipper ...
Purging configuration files for klipper ...
Removing okular-extra-backends ...
Purging configuration files for okular-extra-backends ...
Removing okular ...
Purging configuration files for okular ...
Removing kstars ...
Purging configuration files for kstars ...
Removing krfb ...
Removing krdc ...
Purging configuration files for krdc ...
Removing konsole ...
Removing kompare ...
Purging configuration files for kompare ...
Removing klettres ...
Purging configuration files for klettres ...
Removing khelpcenter ...
Removing khelpcenter4 ...
Removing libokularcore1 ...
Purging configuration files for libokularcore1 ...
Removing libkipi6 ...
Purging configuration files for libkipi6 ...
Removing kdebase-runtime ...
Purging configuration files for kdebase-runtime ...
Removing kdebase-runtime-bin-kde4 ...
Removing libplasma3 ...
Purging configuration files for libplasma3 ...
Removing libknotificationitem1 ...
Purging configuration files for libknotificationitem1 ...
Removing kdelibs5 ...
Purging configuration files for kdelibs5 ...
dpkg: warning: while removing kdelibs5, directory '/usr/lib/kde4' not empty so not removed.
Removing kdelibs-bin ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for desktop...

NoOp (glgxg) wrote :
Download full text (8.7 KiB)

Reinstall okular & that of course pulls in kdelibs5-data (note that okular was installed on this system via jaunty & the issue did not occur there), and once again the messages are back:

$ sudo apt-get install okular
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  liblualib50 kmymoney2-common libavahi-qt3-1 liblua50
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  kdebase-runtime kdebase-runtime-bin-kde4 kdebase-runtime-data
  kdebase-runtime-data-common kdelibs-bin kdelibs5 kdelibs5-data khelpcenter4
  libclucene0ldbl libepub0 libknotificationitem1 liblzma0 libokularcore1
  libplasma3 libpoppler-qt4-3 libqca2 libqimageblitz4 libsoprano4
  libstreamanalyzer0 libstreams0 phonon-backend-xine soprano-daemon
Suggested packages:
  djvulibre-bin libqca2-plugin-cyrus-sasl libqca2-plugin-gnupg
  libqca2-plugin-ossl libqca2-plugin-pkcs11 okular-extra-backends
The following NEW packages will be installed:
  kdebase-runtime kdebase-runtime-bin-kde4 kdebase-runtime-data
  kdebase-runtime-data-common kdelibs-bin kdelibs5 kdelibs5-data khelpcenter4
  libclucene0ldbl libepub0 libknotificationitem1 liblzma0 libokularcore1
  libplasma3 libpoppler-qt4-3 libqca2 libqimageblitz4 libsoprano4
  libstreamanalyzer0 libstreams0 okular phonon-backend-xine soprano-daemon
0 upgraded, 23 newly installed, 0 to remove and 1 not upgraded.
Need to get 18.6MB/21.1MB of archives.
After this operation, 87.7MB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com karmic/main liblzma0 4.999.8beta-0ubuntu2 [84.4kB]
Get:2 http://archive.ubuntu.com karmic/main libclucene0ldbl 0.9.20-3 [376kB]
Get:3 http://archive.ubuntu.com karmic/main soprano-daemon 2.3.1+dfsg.1-1 [104kB]
Get:4 http://archive.ubuntu.com karmic/main libsoprano4 2.3.1+dfsg.1-1 [407kB]
Get:5 http://archive.ubuntu.com karmic/main libstreams0 0.7.0-1 [115kB]
Get:6 http://archive.ubuntu.com karmic/main libstreamanalyzer0 0.7.0-1 [352kB]
Get:7 http://archive.ubuntu.com karmic/main kdelibs-bin 4:4.3.2-0ubuntu7 [227kB]
Get:8 http://archive.ubuntu.com karmic/main kdelibs5 4:4.3.2-0ubuntu7 [7,022kB]
Get:9 http://archive.ubuntu.com karmic/main libknotificationitem1 4:4.3.2-0ubuntu1 [29.9kB]
Get:10 http://archive.ubuntu.com karmic/main libplasma3 4:4.3.2-0ubuntu7 [610kB]
Get:11 http://archive.ubuntu.com karmic/main kdebase-runtime-bin-kde4 4:4.3.2-0ubuntu4 [50.2kB]
Get:12 http://archive.ubuntu.com karmic/main kdebase-runtime-data-common 4:4.3.2-0ubuntu4 [180kB]
Get:13 http://archive.ubuntu.com karmic/main kdebase-runtime-data 4:4.3.2-0ubuntu4 [3,919kB]
Get:14 http://archive.ubuntu.com karmic/main phonon-backend-xine 4:4.3.1-4ubuntu1 [136kB]
Get:15 http://archive.ubuntu.com karmic/main kdebase-runtime 4:4.3.2-0ubuntu4 [1,437kB]
Get:16 http://archive.ubuntu.com karmic/main khelpcenter4 4:4.3.2-0ubuntu4 [1,711kB]
Get:17 http://archive.ubuntu.com karmic/main libepub0 0.1.1-3ubuntu1 [22.7kB]
Get:18 http://archive.ubuntu.com karmic-updates/main libpoppler-qt4-3 0.12.0-0ubuntu2.1 [166kB]
Get:19 http://ar...

Read more...

description: updated
Andrey Beljakov (andvalb) wrote :

This bug still exists in Lucid

Настраивается пакет shared-mime-info (0.71-1) ...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

pello (fropert) wrote :

Hi,

I'm affected too. Shortcuts doesn't worked anymore and icons from the desktop have disappeared.

dpkg-reconfigure shared-mime-info
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Uqbar (uqbar) wrote :

This ridiculous bug is still here on Lucid, after 2+ years and 4 releases!

Elaborazione dei trigger per shared-mime-info...
Unknown media type in type 'all/all'

Unknown media type in type 'all/allfiles'

Unknown media type in type 'uri/mms'

Unknown media type in type 'uri/mmst'

Unknown media type in type 'uri/mmsu'

Unknown media type in type 'uri/pnm'

Unknown media type in type 'uri/rtspt'

Unknown media type in type 'uri/rtspu'

Unknown media type in type 'fonts/package'

Unknown media type in type 'interface/x-winamp-skin'

Yes, I've just come looking here because of encountering this. I'd done nothing more than a fresh install of Lucid, followed by running the Update Manager. Watching details scroll by I saw these worrying messages. Naturally, users will have no idea whether it means something alarming, or benign, and it destroys confidence in what is supposed to be a smooth experience.

NoOp (glgxg) wrote :

The errors containing 'Unknown media type in type 'all/all'' etc., are from kde.xml (kdelib5). See:
https://bugs.edge.launchpad.net/ubuntu/+source/shared-mime-info/+bug/289592
[Unknown media types in /usr/share/mime/packages/kde.xml]
http://bugs.freedesktop.org/show_bug.cgi?id=16816

Changed in shared-mime-info:
importance: Unknown → Medium
Changed in shared-mime-info:
importance: Medium → Unknown
Changed in shared-mime-info:
importance: Unknown → Medium
fabioamd87 (fabioamd87) wrote :

I get mail notification of this bug from 02 / 2008 is possible to fix it please?

JCollierDavis (jcollierdavis) wrote :
Download full text (3.7 KiB)

I never found a fix, but it also stopped doing anything wrong so I left it
alone.

On Sat, Feb 5, 2011 at 11:15 AM, fabioamd87 <email address hidden> wrote:

> I get mail notification of this bug from 02 / 2008 is possible to fix it
> please?
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/193325
>
> Title:
> "unknown media type" during update
>
> Status in Nautilus:
> Confirmed
> Status in shared MIME database:
> Fix Released
> Status in “shared-mime-info” package in Ubuntu:
> Fix Released
>
> Bug description:
> Messages below seen during the latest round of updates. The messages
> from several packages seem to be mixed around, so I'm not sure which
> one triggered them. I suspect nautilus.
>
> Setting up shared-mime-info (0.23-3) ...
> Unknown media type in type 'x-content/video-vcd'
>
> Unknown media type in type 'x-content/video-svcd'
>
> Unknown media type in type 'x-content/video-dvd'
>
> Unknown media type in type 'x-content/image-dcf'
>
> Unknown media type in type 'x-content/audio-cdda'
>
> Unknown media type in type 'x-content/blank-cd'
>
> Unknown media type in type 'x-content/blank-dvd'
>
> Unknown media type in type 'x-content/blank-bd'
>
> Unknown media type in type 'x-content/blank-hddvd'
>
> Unknown media type in type 'x-content/audio-dvd'
>
> Unknown media type in type 'x-content/video-bluray'
>
> Unknown media type in type 'x-content/video-hddvd'
>
> Unknown media type in type 'x-content/image-picturecd'
>
> Unknown media type in type 'x-content/audio-player'
>
> Unknown media type in type 'x-content/software'
>
> Setting up ucf (3.004-0ubuntu3) ...
>
> Setting up seahorse (2.21.91-0ubuntu3) ...
> Unknown media type in type 'x-content/video-vcd'
>
> Unknown media type in type 'x-content/video-svcd'
>
> Unknown media type in type 'x-content/video-dvd'
>
> Unknown media type in type 'x-content/image-dcf'
>
> Unknown media type in type 'x-content/audio-cdda'
>
> Unknown media type in type 'x-content/blank-cd'
>
> Unknown media type in type 'x-content/blank-dvd'
>
> Unknown media type in type 'x-content/blank-bd'
>
> Unknown media type in type 'x-content/blank-hddvd'
>
> Unknown media type in type 'x-content/audio-dvd'
>
> Unknown media type in type 'x-content/video-bluray'
>
> Unknown media type in type 'x-content/video-hddvd'
>
> Unknown media type in type 'x-content/image-picturecd'
>
> Unknown media type in type 'x-content/audio-player'
>
> Unknown media type in type 'x-content/software'
>
> Setting up ubuntu-gdm-themes (0.24) ...
> Setting up linux-restricted-modules-common (2.6.24.9-8.25) ...
>
> Setting up nautilus-data (1:2.21.91-0ubuntu3) ...
> Unknown media type in type 'x-content/video-vcd'
>
> Unknown media type in type 'x-content/video-svcd'
>
> Unknown media type in type 'x-content/video-dvd'
>
> Unknown media type in type 'x-content/image-dcf'
>
> Unknown media type in type 'x-content/audio-cdda'
>
> Unknown media type in type 'x-content/blank-cd'
>
> Unknown media type in type 'x-content/blank-dvd'
>
> Unknown media type in type 'x-content/blank-bd'
>
> Unknown media type in type '...

Read more...

Uqbar (uqbar) wrote :

Fix released?
Be serious, please!
There's no fix at all as of current Oneiric...

funicorn (funicorn) wrote :

Today is 2012.07.20. I'm using Ubuntu 12.04, and I still ran across this bug.

One who have used Ubuntu for years would say this is the typical linux story: the same bug appears repeatedly, developers
being confident everytime they found a workaround claimed as a fix, and being forgetful everytime they faced a bug report met before.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.