No desktop entries

Bug #61039 reported by Holger Bauer on 2006-09-18
16
Affects Status Importance Assigned to Milestone
sgt-puzzles (Debian)
Fix Released
Undecided
Unassigned
sgt-puzzles (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: sgt-puzzles

All games miss a desktop entry and hence don't show up in the gnome menu.

Related branches

Matti Lindell (mlind) wrote :

Confirming on Edgy, sgt-puzzles 6616-1.

Package currently has support for Debian menu system only
http://alioth.debian.org/docman/view.php/30046/2/menu-one-file.html

I'm not sure if there's Ubuntu alternative for this yet.

Changed in sgt-puzzles:
status: Unconfirmed → Confirmed
Frank IJskes (frank-debbie) wrote :

installing menu-xdg and enabling the debian view solves part of the problem

Perhaps a dependency from sgt-puzzles to menu-xdf should be added?

Holger Bauer (umarmung-planet) wrote :

So adding desktop files to the ubuntu package is not an option?

Ian (superian) wrote :
Jasper Groenewegen (colbrac) wrote :

I was interested in learning the workings of .desktop, .menu and .directory files as well as practicing python (2nd useful script ever made) which resulted in the attachment. It needs the sgt-puzzle source package since the icons are in there. (And they are not installed by the makefile :S).
Warning! The script writes to /etc/xdg/menus/applications-merged, /usr/share/desktop-directories, /usr/share/applications, /usr/share/pixmaps and /usr/share/icons/hicolor/#x#/apps for # = 16, 32, 48. So, you better check it out before you run it. And of course it needs to be run as root.

As I said, my second script ever which works for my Ubuntu Gutsy install. It might work for you.. but I give no guarantees!

Didier Roche (didrocks) on 2008-07-23
Changed in sgt-puzzles:
assignee: nobody → didrocks
status: Confirmed → In Progress
Didier Roche (didrocks) wrote :

Here is the debdiff containing menu items and correcting also bug #255086

Changed in sgt-puzzles:
assignee: didrocks → nobody
status: In Progress → Confirmed
Adrien Cunin (adri2000) on 2008-08-13
Changed in sgt-puzzles:
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sgt-puzzles - 7983-1ubuntu1

---------------
sgt-puzzles (7983-1ubuntu1) intrepid; urgency=low

  * add 306_fix-ftbfs-with-fortify-source-2.diff to fix FTBFS in gtk.c (LP:
    #255086)
  * add desktop files and xpm files (one for each game) to the menu in
    debian/desktop (LP: #61039)

 -- Didier Roche <email address hidden> Sat, 09 Aug 2008 14:47:58 +0200

Changed in sgt-puzzles:
status: Confirmed → Fix Released
Changed in sgt-puzzles:
status: Unknown → New
José Tomás Atria (jtatria) wrote :

sgt-puzzles does not create menu entries in kde. IS there any posibility of porting the fix mentioned above to work in kde too?

Didier Roche (didrocks) wrote :

That's strange. I used the freedesktop's guidelines and so, it must work on KDE.

I just checked, installing kubuntu-desktop metapackage on my last intrepid VM and it works.
Are you running intrepid? (only this one as the correction)

Didier Roche (didrocks) wrote :

Update the bug tacker manually as this bug is closed upstream (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=495561) and the tracker status is still to "New"

Changed in sgt-puzzles (Debian):
importance: Unknown → Undecided
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.