X_IMAGE, Y_IMAGE, ELLIPTICITY are always zero

Bug #283142 reported by Sergio Gelato on 2008-10-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
sextractor (Ubuntu)
Undecided
Ole Streicher

Bug Description

Observed using the binary sextractor package on Ubuntu hardy i386:

some columns in the object catalog end up containing only zeros, an incorrect result for the input data supplied.

To reproduce, take a FITS file and run it through sextractor. The problem can be reproduced using the options suggested in the man page:
sextractor file.fits -c /usr/share/sextractor/default.sex -PARAMETERS_NAME /usr/share/sextractor/default.param -FILTER N
and look at the values for X_IMAGE and Y_IMAGE in the output file (test.cat).

Another parameter affected is ELLIPTICITY. Using a suitably modified .param file:
# 1 X_IMAGE Object position along x [pixel]
# 2 Y_IMAGE Object position along y [pixel]
# 3 ELLIPTICITY 1 - B_IMAGE/A_IMAGE
# 4 A_IMAGE Profile RMS along major axis [pixel]
# 5 B_IMAGE Profile RMS along minor axis [pixel]
# 6 THETA_IMAGE Position angle (CCW/x) [deg]
# 7 XMIN_IMAGE Minimum x-coordinate among detected pixels [pixel]
# 8 XMAX_IMAGE Maximum x-coordinate among detected pixels [pixel]
     0.000 0.000 0.000 0.912 0.674 -33.2 729 732
     0.000 0.000 0.000 0.729 0.436 -71.6 608 609
     0.000 0.000 0.000 0.775 0.711 35.7 812 814
[ ... and so on ]

Clearly something is wrong: 1 - 0.674/0.912 is rather different from zero.

I was able to fix the problem simply by rebuilding the sextractor package, *without any changes to the source*, with current hardy compilers and build tools (I used pbuilder). My guess is that the i386 deb that is currently in the Ubuntu archive for hardy was miscompiled.

Tim-Oliver Husser (mail-husser) wrote :

I've got the same problem with sextractor on Jaunty. The binary package produces weird results, but it works when compiled from the source package without making any changes to it.

Lenin (gagarin) wrote :

there's version 2.8.6, maybe it should've been updated long ago...

Sergio Gelato (sergio-gelato) wrote :

Yes, version 2.8.6 has been out for at least two years. It uses a different license, though (CeCILL), and it's unclear whether it's CeCILL v1 or CeCILL v2. When asked about this, upstream simply pointed out that the current development branch is back under GPL (v3 this time) "because the codebase included GPL code fragments" (translation mine). On 2011-10-07, upstream stated the intention to update the download site "within the coming month". I'd suggest waiting a while longer before packaging 2.8.6 or a newer stable release. (I've actually done some of the work already, it builds but it still needs testing and various cleanups.)

Note that the Debian package hasn't been updated since 2006. The maintainer discussed an upload of 2.5.0 in April 2007; I couldn't find any signs of later activity. The package hasn't formally been orphaned, but it probably should have been.

Ole Streicher (olebole) wrote :

I also made a new attempt to build a debian package and put it under the debian-science git:

<http://anonscm.debian.org/gitweb/?p=debian-science/packages/sextractor.git>

Maybe we could merge our attempts? BTW, I see no problem with the CeCILL (I took v2 since it is not specified) since it is listed as a valid OpenSource license. I just included it into the copyright file.

I also sent a mail to the original maintainer on his plans for this package.

Ole Streicher (olebole) wrote :

This bug has been fixed in upstream version 2.8.6.

Changed in sextractor (Ubuntu):
status: New → Fix Released
assignee: nobody → Ole Streicher (olebole)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers