Proprietary codec plugin message in English although translated

Bug #972427 reported by Fabio Marconi on 2012-04-03
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Session Installer
Low
Unassigned
Ubuntu Translations
Medium
Unassigned
sessioninstaller (Ubuntu)
Medium
Unassigned

Bug Description

Hello
The translation of the message in the notify display are translated in launchpad but not appear translated.
See attached screenshot

Fabio Marconi (fabiomarconi) wrote :
tags: added: precise
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu localized ISO testing tracker.

A list of all reports related to this bug can be found here:
http://localized-iso.qa.ubuntu.com/qatracker/reports/bugs/972427

tags: added: iso-testing localized-iso
summary: - Avviso dello scaricamento di codec proprietari non tradotto.
+ Advice of downloading of proprietary codec not translated

@Fabio
This should be an upstream bug.
That string has been translated for a while. Tested on an installed system it still shows in English.

Marking this as Invalid, please open a new bug against sessioninstaller.

Changed in ubuntu-defaults-it:
status: New → Invalid
affects: ubuntu-defaults-it → sessioninstaller (Ubuntu)
Changed in sessioninstaller (Ubuntu):
status: Invalid → Confirmed
description: updated
summary: - Advice of downloading of proprietary codec not translated
+ Proprietary codec plugin message in English although translated
Gabor Kelemen (kelemeng) on 2012-04-04
Changed in ubuntu-translations:
status: New → Triaged
importance: Undecided → Medium
Changed in sessioninstaller:
status: New → Confirmed
Sebastian Heinlein (glatzor) wrote :

I am a little bit clueless. The corresponding code seems to be fine:

    tooltip = _("The use of %s may be restricted in some "
                        "countries. You must verify that one of the following "
                        "is true:\n"
                        "• These restrictions do not apply in your country "
                        "of legal residence\n"
                        "• You have permission to use this software (for "
                        "example, a patent license)\n"
                        "• You are using this software for research "
                        "purposes only") % name

The translations are correctly distributed by the language packs.
I tried to use gettext.dgettext("sessioninstaller", "[....]") but this also doesn't work.

Can gettext not handle the bullets?

Changed in sessioninstaller (Ubuntu):
importance: Undecided → Medium
Sebastian Heinlein (glatzor) wrote :

Indeed, it seems that gettext cannot handle the bullets (•). So I replaced them by hypens.

Changed in sessioninstaller (Ubuntu):
status: Confirmed → Fix Committed
Changed in sessioninstaller:
status: Confirmed → Fix Committed
importance: Undecided → Low
Changed in ubuntu-translations:
status: Triaged → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr128-0ubuntu1

---------------
sessioninstaller (0.20+bzr128-0ubuntu1) precise-proposed; urgency=low

  * New upstream release that fixes:
    - merged lp:~aptdaemon-developers/sessioninstaller/multiarch
      LP: #899001
    - Fix missing translation for the restrcited packages tooltip
      LP: #972427
    - Don't translate debugging messages LP: #792436
    - Fix a string substition if the sender_name of InstallPackageNames
      is unknown
    - Check if packages are available at all and show a corresponding
      error message if not (string addition) instead of a generic and
      no descriptive message
 -- Michael Vogt <email address hidden> Wed, 25 Apr 2012 15:04:59 +0200

Changed in sessioninstaller (Ubuntu):
status: Fix Committed → Fix Released
Adolfo Jayme (fitojb) on 2013-02-13
Changed in ubuntu-translations:
status: Invalid → Fix Released
Changed in sessioninstaller:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers