Should use gobject introspection (GTK3)

Bug #801202 reported by Sebastien Bacher on 2011-06-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Session Installer
Undecided
Unassigned
sessioninstaller (Ubuntu)
High
Martin Pitt

Bug Description

Since GTK3 is default in ubuntu and we want to drop GTK2 from the CD by the next LTS, sessioninstaller should be switched to GTK3

You can find migration instructions on http://developer.gnome.org/gtk3/3.1/gtk-migrating-2-to-3.html , http://live.gnome.org/GObjectIntrospection and https://live.gnome.org/PyGObject/IntrospectionPorting

Related branches

tags: added: gnome3-gtk3
Changed in sessioninstaller (Ubuntu):
importance: Undecided → High
Changed in sessioninstaller (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2011-11-14
Changed in sessioninstaller (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) wrote :

Merged branch into trunk.

Changed in sessioninstaller:
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr123-0ubuntu1

---------------
sessioninstaller (0.20+bzr123-0ubuntu1) precise; urgency=low

  * New upstream snapshot:
    - Port to PyGI and GTK 3. (LP: #801202)
  * debian/control: Move Vcs-Bzr: to precise branch.
  * debian/control: C/R/P: gnome-codec-install, to clean this up on upgrades.
    session-installer is the preferred UI now.
  * debian/control: Update dependencies for PyGI/GTK 3 port.
  * debian/control: Bump Standards-Version to 3.9.2 (no changes necessary).
 -- Martin Pitt <email address hidden> Mon, 14 Nov 2011 15:26:01 +0100

Changed in sessioninstaller (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers