session-installer crashed with ModifyInternalError in _install_provide_files(): org.freedesktop.Packagekit.Modify.InternalError: This method hasn't yet been implemented.

Bug #762431 reported by Birdy on 2011-04-16
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sessioninstaller (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: sessioninstaller

When open "About Ubuntu" in Lubuntu, no documentation is found.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: sessioninstaller 0.20+bzr119-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
NonfreeKernelModules: fglrx
Architecture: i386
Date: Fri Apr 15 22:06:04 2011
ExecutablePath: /usr/bin/session-installer
InstallationMedia: Xubuntu 11.04 "Natty Narwhal" - Beta i386 (20110330)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/session-installer
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_GB.UTF-8
 PATH=(custom, no user)
 LANGUAGE=en
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/session-installer']
SourcePackage: sessioninstaller
Title: session-installer crashed with ModifyInternalError in _install_provide_files(): org.freedesktop.Packagekit.Modify.InternalError: This method hasn't yet been implemented.
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Birdy (birdy-hp) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #716711, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr119-0ubuntu2

---------------
sessioninstaller (0.20+bzr119-0ubuntu2) natty; urgency=low

  * debian/patches/02_no_crash_on_install_provides.patch:
    - do not raise a exception in _install_provide_files()
      LP: #762431
 -- Michael Vogt <email address hidden> Mon, 18 Apr 2011 11:51:08 +0200

Changed in sessioninstaller (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments