Migrate to python-defer

Bug #703330 reported by Julien Lavergne on 2011-01-15
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sessioninstaller (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: sessioninstaller

Sessioninstaller need to be convert to python-defer in natty. 1 fix is already in upstream branch, another is available in my branch : lp:~gilir/sessioninstaller/defer-migration. Without them, sessioninstaller crash on natty.

Julien Lavergne (gilir) wrote :

Package update is available on lp:~gilir/sessioninstaller/ubuntu-natty.
I attached the new upstream version in this bug report.

Angel Abad (angelabad) wrote :

Looks good, taking a look!

Changed in sessioninstaller (Ubuntu):
assignee: nobody → Angel Abad (angelabad)
importance: Undecided → Wishlist
status: New → In Progress
Angel Abad (angelabad) wrote :

Sorry Julien, but the package FTBFS in clean natty pbuilder chroot:

dpkg-buildpackage: host architecture amd64
 fakeroot debian/rules clean
dh clean
   dh_testdir
   debian/rules override_dh_auto_clean
make[1]: Entering directory `/tmp/buildd/sessioninstaller-0.20+bzr117'
dh_auto_clean
Traceback (most recent call last):
  File "setup.py", line 3, in <module>
    import DistUtilsExtra.auto
  File "/usr/lib/python2.6/dist-packages/DistUtilsExtra/auto.py", line 41, in <module>
    import ast
ImportError: No module named ast
dh_auto_clean: python2.6 setup.py clean -a returned exit code 1
make[1]: *** [override_dh_auto_clean] Error 1
make[1]: Leaving directory `/tmp/buildd/sessioninstaller-0.20+bzr117'
make: *** [clean] Error 2
dpkg-buildpackage: error: fakeroot debian/rules clean gave error exit status 2
E: Failed autobuilding of package

Please fix this error.

Thanks!

Changed in sessioninstaller (Ubuntu):
assignee: Angel Abad (angelabad) → nobody
status: In Progress → Incomplete
Angel Abad (angelabad) wrote :

Unsubscribing sponsors, please re-subscribe it when the problem is fixed.

Julien Lavergne (gilir) wrote :

Working fine for me. Do you run bzr-buildpackage -S in the branch. Please test with the attached debian.tar.gz if doesn't work for you.
It also worked on my PPA : https://launchpad.net/~gilir/+archive/unstable/+packages?field.name_filter=&field.status_filter=published&field.series_filter=natty

Julien Lavergne (gilir) wrote :

Btw, this patch fix a crash, so it should not be a "Wishlist"

Changed in sessioninstaller (Ubuntu):
status: Incomplete → Confirmed
importance: Wishlist → Low
Angel Abad (angelabad) wrote :

Hi! I dont know why but the package fails in my pbuilder but builds well in ubuntu archive ppas, so, uploading it.

Changed in sessioninstaller (Ubuntu):
assignee: nobody → Angel Abad (angelabad)
status: Confirmed → In Progress
Angel Abad (angelabad) wrote :

Sorry, I mistake again, the package is in main, I have no upload rights to main. Wait for main sponsor. The package looks good and builds well in ubuntu archive.

Thanks for your work!

Changed in sessioninstaller (Ubuntu):
status: In Progress → Confirmed
assignee: Angel Abad (angelabad) → nobody
Robert Ancell (robert-ancell) wrote :

Uploaded to natty.

I am getting a crash in _render_warning (from /var/crash):
Title: session-installer crashed with TypeError in _render_warning(): could not convert argument to correct param type
but I'm guessing that is not related.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr117-0ubuntu1

---------------
sessioninstaller (0.20+bzr117-0ubuntu1) natty; urgency=low

  * New bzr version:
   - Migrate from aptdaemon.defer to defer. (LP: #703330)
  * debian/patches/02_backends_defer.patch:
   - Migrate also backends to defer.
  * debian/control:
   - Depends on python-defer.
   - Depends on python-xapian.
 -- Julien Lavergne <email address hidden> Fri, 14 Jan 2011 22:39:37 +0100

Changed in sessioninstaller (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers