Doesn't find gstreamer1.0 codecs

Bug #1278284 reported by Shahar Or on 2014-02-10
28
This bug affects 7 people
Affects Status Importance Assigned to Milestone
sessioninstaller (Ubuntu)
High
Unassigned
Trusty
High
Unassigned

Bug Description

On the request of Rhythmbox, sessino-installer tries to look for Vorbis encoder and doesn't find it.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: sessioninstaller 0.20+bzr141-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-8.27-generic 3.13.2
Uname: Linux 3.13.0-8-generic x86_64
ApportVersion: 2.13.2-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Mon Feb 10 08:11:00 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2010-10-12 (1216 days ago)
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
PackageArchitecture: all
SourcePackage: sessioninstaller
UpgradeStatus: Upgraded to trusty on 2013-10-26 (106 days ago)

Related branches

Shahar Or (mightyiam) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, indeed it seems to find none of the codecs in trusty

tags: added: ubuntu-desktop-trusty
summary: - Doesn't find Vorbis encoder
+ Doesn't find gstreamer1.0 codecs
Changed in sessioninstaller (Ubuntu):
importance: Undecided → High
status: New → Triaged
Shahar Or (mightyiam) wrote :

Thank you for paying attention to my reports, Sebastien.

Sebastien Bacher (seb128) wrote :

The issue there is that Gstreamer-Version=1.2 but struct.version=1.0, one easy way to filter 0.10or1.0 is to split(".")[0]. There might be a better way but that works for the current issue.

Once that fixed the code hit another issue where "pkg_caps.intersect(struct.caps)" returns a caps even when there is no intersect, the api has a is_empty() api, using it fixes the issue

Changed in sessioninstaller (Ubuntu Trusty):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr141-0ubuntu4

---------------
sessioninstaller (0.20+bzr141-0ubuntu4) trusty; urgency=medium

  * debian/patches/03_new_gstreamer.patch:
    - update to work with the current gstreamer version (lp: #1278284)
 -- Sebastien Bacher <email address hidden> Fri, 28 Mar 2014 17:01:02 +0100

Changed in sessioninstaller (Ubuntu Trusty):
status: Fix Committed → Fix Released
Shahar Or (mightyiam) wrote :

Thank you very much, Sebastien. You make my bug reports worth while!

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1278284

tags: added: package-qa-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1278284

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers