Local deb package cannot be installed by double clicking it

Bug #1059600 reported by Stinger on 2012-10-01
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Session Installer
Undecided
Unassigned
gnome-packagekit (Ubuntu)
Undecided
Shafeeque
sessioninstaller (Ubuntu)
High
Unassigned

Bug Description

When I try to install a deb package by double clicking it (google-chrome) , I get the following error message:
"The action cannot be completed." and more details gives the following error:

"Traceback (most recent call last):
File "/usr/lib/python2.7/dist-packages/defer/__init__.py", line 489, in _inline_callbacks
result = gen.send(result)
File "/usr/lib/python2.7/dist-packages/sessioninstaller/core.py", line 669, in _install_package_files
interaction, sender)
TypeError: install_package_files() takes exactly 4 arguments (5 given)"

If I use the command line and sudo dpkg -i the package instead, it installs just fine.
Must be a bug in packagekit IMHO.

Related branches

Matthias Klumpp (ximion) wrote :

No, it isn't - This is a bug in Ubuntu's Sessioninstaller. You can remove it
(sudo apt-get purge sessioninstaller) and instead install a frontend like GNOME-PackageKit (sido apt-get install gnome-packagekit) to see if it works with PackageKit.
Reassigning to Ubuntu's Aptdaemon.

Changed in gnome-packagekit (Ubuntu):
status: New → Invalid
Stinger (e-mindahl) wrote :

I see, thanks for reassigning the bug. i'll try to remove the sessioninstaller :)

Stinger (e-mindahl) wrote :

I have removed the sessioninstaller package but Gnome-packagekit gives me this error when trying to install the google-chrome package:
"Process /usr/bin/gpk-dbus-service exited with status 1"

Is this still related to the sessioninstaller ?

Sebastian Heinlein (glatzor) wrote :

Thanks. I located the error in session-installer. It will be fixed soon.

Changed in sessioninstaller (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Matthias Klumpp (ximion) wrote :

@Stinger: No, this is GNOME-PackageKit... You downloaded the package and double-clicked it? What happens if you run "gpk-application <packagefilename>" in a Terminal? (Please attach the output!)

Stinger (e-mindahl) wrote :

This is what I get from terminal

"gpk-application ubuntu-tweak.deb

(gpk-application:11620): GLib-GIO-CRITICAL **: This application can not open files."

I tried with sudo to but it gives the same output.

Strange.. according to this:
http://library.gnome.org/users/gnome-packagekit/stable/application.html.en

The command would be gpk-install-file but I can't get that one to work either, I just get 'command not found'

Matthias Klumpp (ximion) wrote :

Ah, this explains why it doesn't work! Install the package gnome-packagekit-tools and you should be fine!

Stinger (e-mindahl) wrote :

Ok found the command, 'gksu gpk-install-local-file' I tried with the ubuntu-tweak.deb.
double clicking it gives:
"GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: SimulateInstallFiles not supported by backend"

From terminal using 'gksu gpk-install-local-file ubuntu-tweak.deb' I only get an error message in the UI, not in terminal:
" could not resolve: ubuntu-tweak.deb"
As if it has not found the package ( located in my user directory )

Stinger (e-mindahl) wrote :

@7
I have already installed the 'gnome-packagekit-tools' just to be sure, but still no joy :(

Matthias Klumpp (ximion) wrote :

Please don't use tools like gksu oder sudo, as PackageKit is designed for use with PolicyKit which will handle all authorization stuff for you. :-)
"SimulateInstallFiles not supported by backend" suggests an error with the backend - which PackageKit backend to you use? You should use Aptcc. (packagekit-backend-aptcc installed) Also check if you don't use the Aptdaemon PackageKit compat layer, otherwise this is no valid PK bug and I can happily forward it to Glatzor :-D (who won't be happy about it ^^)
Cheers,
   Matthias

Stinger (e-mindahl) wrote :

Ok I'll launch the app without gksu or sudo, but that's what it says in the menu from the 'Ubuntu Gnome Remix 12.10Beta'

I have packagekit-backend-aptcc-0.7.6-1 installed but how would I check for the 'Aptdaemon PackageKit compat layer' ?
Would it be this package 'python3-aptdaemon.pkcompat 0.45+bzr861-0ubuntu5' ?
It says "PackageKit compatibility for AptDaemon" in the description, it is not installed.
Thanks for your kind assistance :)

Sebastian Heinlein (glatzor) wrote :

Stinger, you don't need to install any packagekit related software to help to diagnose the problem, since I already located it. It was a porting problem. It will take some time to get the fix in precise.

Mathias, if you want to test PackageKit installations please open up a separate bug, since I need this one for the SRU. You already marked this one invalid for packagekit. This bug isn't about aptdaemon, too.

Stinger (e-mindahl) wrote :

@Sebastian
I see, thanks for reporting this.
Just to clarify things, and sum it all up.
After the bug is fixed I would need the sessioninstaller again, right ?

And 'gpk-install-local-file' or 'gpk-application' won't need to be executed as super-user (sudo, gksu) ?

Matthias Klumpp (ximion) wrote :

@Stinger: Yes, you could use sessioninstaller again, when Sebastian has fixed the bug ;-) And he's right, there is no point in cluttering this report.
Can you please file a new bug against the "packagekit" package about the "GDBus.Error:org.gtk.GDBus.UnmappedGError.Quark._pk_5ftransaction_5ferror.Code4: SimulateInstallFiles not supported by backend" issue? Because while the first one was a sessioninstaller issue, the second one is from PackageKit. Oh, and it's probably not even a bug...
Run "sudo apt-get install gdebi-core" and try again, it should work then ;-)

Stan Syritsyn (staleo) wrote :

Just installed release version of Ubuntu GNOME remix, same thing. :-(

kabre (wilfreidkabre) on 2013-01-26
Changed in gnome-packagekit (Ubuntu):
status: Invalid → Confirmed
Matthias Klumpp (ximion) wrote :

@Stan: Is gdebi-core installed?

Matthias Klumpp (ximion) on 2013-02-17
Changed in gnome-packagekit (Ubuntu):
status: Confirmed → Incomplete
Matthias Klumpp (ximion) wrote :

This is definitely fixed in PK/GPK.

Changed in gnome-packagekit (Ubuntu):
status: Incomplete → Fix Released
mahi.tanwar (hackingqueen) wrote :

i am also facing same problem plz check this iam getting on terminal

root@kali:~# sudo apt-get install gdebi-core
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package gdebi-core is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'gdebi-core' has no installation candidate
root@kali:~#

Matthias Klumpp (ximion) wrote :

Hmm, gdebi-core should be there.... https://launchpad.net/ubuntu/+source/gdebi
Are you using PackageKit or Aptdaemon? For PK, you might need to enable the universe package sources.

Bob (robertfoster48) wrote :

I have an Acer One D150 and using Firefox (latest in 14.04) it appears to download Chrome deb but will not install via Ubuntu Software Center. After clicking on install it does nothing else apparently, and returns the install button as if it was not pressed.
No error messages etc.

Just my experience

Will try on a toshiba laptop later

Changed in gnome-packagekit (Ubuntu):
assignee: nobody → Shafeeque (shafeequealipt)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers