session-installer crashed with AlreadyCalledDeferred in callback()

Bug #1056545 reported by Colby M. McKethen on 2012-09-26
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Session Installer
Undecided
Unassigned
sessioninstaller (Ubuntu)
High
Unassigned
Precise
High
Unassigned
Quantal
High
Unassigned

Bug Description

[Impact]
When a user delays entering a password for sessioninstaller, it will timeout and crash. It should merely timeout.

[Test Case]
0) Ensure that you do not have p7zip installed
1) Open a terminal
2) wget http://people.canonical.com/~brian/tmp/oops.7z
3) file-roller oops.7z
4) Click through dialogs until at prompt to enter your password
5) Wait
6) Wait some more
7) Observe unhandlable error dialog, click cancel
8) Observe second error dialog, click cancel
9) Click cancel in authentication dialog
10) Repeat step 3 through 6
11) Observe apport crash

[Regression Potential]
I wouldn't think much, but then the first time I tried to fix this issue (bug 848605), I accidentally caused bug 1042231.

[Original Report]
when launching im client

ProblemType: CrashDistroRelease: Ubuntu 12.10
Package: sessioninstaller 0.20+bzr131-0ubuntu2
ProcVersionSignature: Ubuntu 3.5.0-15.23-generic 3.5.4
Uname: Linux 3.5.0-15-generic x86_64
ApportVersion: 2.5.2-0ubuntu4
Architecture: amd64
Date: Tue Sep 25 22:07:32 2012
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/session-installer
InstallationMedia: Ubuntu 12.04.1 LTS "Precise Pangolin" - Release amd64 (20120823.1)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python /usr/bin/session-installer
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
PythonArgs: ['/usr/bin/session-installer']SourcePackage: sessioninstaller
Title: session-installer crashed with AlreadyCalledDeferred in callback()
UpgradeStatus: Upgraded to quantal on 2012-09-25 (0 days ago)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

tags: removed: need-duplicate-check
Changed in sessioninstaller (Ubuntu):
importance: Undecided → Medium
Loïc Minier (lool) wrote :

I got this when trying to play a video, I got a popup suggesting installation of extra packages, accepted, but then I didn't enter my root password immediately. It seems a time out kicked in, and this triggered a dbus error.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sessioninstaller (Ubuntu):
status: New → Confirmed
Loïc Minier (lool) on 2013-02-07
information type: Private → Public
Brian Murray (brian-murray) wrote :

This looks very similar to the previously fixed(?) bug 848605.

Brian Murray (brian-murray) wrote :

This is occurs rather regularly for users of Ubuntu 12.04 and Ubuntu 12.10 as we can see at:

https://errors.ubuntu.com/bucket/?id=%2Fusr%2Fbin%2Fsession-installer%3AAlreadyCalledDeferred%3A_on_finished%3Acallback

Changed in sessioninstaller (Ubuntu):
importance: Medium → High
status: Confirmed → Triaged
Brian Murray (brian-murray) wrote :

I tried following the test case from bug 848605, using a 7z archive as there were issues find the right package (by sessioninstaller) for a rar archive, and was unsuccessful. (I entered my password and the packages were installed and I could view the contents of the 7z file.)

Additionally, I did not enter my root password per comment #2 and the first time I received a message from aptdaemon regarding an a programming error - I think due to a dbus timeout.

However, the second time I got this apport crash from session-installer using the version of session-installer from precise-updates.

Brian Murray (brian-murray) wrote :

Trying it again the first time there is a dialog from session-installer that says:

An unhandlable error occured

There seems to be a programming error in aptdaemon, …

Details:

org.freedesktop.DBus.Error.NoReply: Did not receive a reply. …

After clicking Cancel there was another error regarding trying to search for applications and more Did not receive a reply information.

And after the second time I received the same apport crash.

description: updated
Changed in sessioninstaller (Ubuntu Precise):
status: New → Triaged
importance: Undecided → High
Changed in sessioninstaller (Ubuntu Quantal):
status: New → Triaged
importance: Undecided → High
Brian Murray (brian-murray) wrote :

Although there are not many records of this happening on Raring, I was able to create it although I did not need to follow step 10 of the test case i.e. I received the apport crash after the first dbus timeout.

Michael Terry (mterry) wrote :

In fixing bug 848605, I caused bug 1042231. The fix for my regression was done in such a way that this bug regressed.

Now the trick is to make a fix that doesn't regress anything. :)

Michael Terry (mterry) wrote :

I filed https://code.launchpad.net/~mterry/sessioninstaller/no-defer-twice/+merge/153445 upstream, let's see if that gets accepted, then I can SRU it.

Michael Terry (mterry) wrote :

I've uploaded to raring and precise and subscribed ubuntu-sru.

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr134-0ubuntu5

---------------
sessioninstaller (0.20+bzr134-0ubuntu5) raring; urgency=low

  * debian/patches/04_dont_double_defer.patch:
    - Cherry pick upstream patch to avoid calling errback twice on the
      same deferred object (LP: #1056545)
 -- Michael Terry <email address hidden> Thu, 28 Mar 2013 14:25:57 -0400

Changed in sessioninstaller (Ubuntu):
status: Triaged → Fix Released
Changed in sessioninstaller:
status: New → Fix Committed
status: Fix Committed → Incomplete

Hello Colby, or anyone else affected,

Accepted sessioninstaller into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/sessioninstaller/0.20+bzr128-0ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sessioninstaller (Ubuntu Precise):
status: Triaged → Fix Committed
tags: added: verification-needed
Brian Murray (brian-murray) wrote :

Hello Colby, or anyone else affected,

Accepted sessioninstaller into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/sessioninstaller/0.20+bzr131-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in sessioninstaller (Ubuntu Quantal):
status: Triaged → Fix Committed
Brian Murray (brian-murray) wrote :

Neither version of the proposed package appears at the errors bucket listed earlier in the bug comments.

Martin Pitt (pitti) wrote :

Merged upstream fix in r141.

Changed in sessioninstaller:
status: Incomplete → Fix Released
Mantas Kriaučiūnas (mantas) wrote :

What could I do to have fixed sessioninstaller package included into 12.04 LTS (Precise) ASAP?

Sebastien Bacher (seb128) wrote :

@Mantas: can you install the candidate package and confirm it works fine

@Brian: should your comment be taken as a verification of the fix working?

Brian Murray (brian-murray) wrote :

Yes, I think so. I also looked for other session-installer crashes first reported about the version number in -proposed and I found none.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr131-0ubuntu2.1

---------------
sessioninstaller (0.20+bzr131-0ubuntu2.1) quantal-proposed; urgency=low

  * debian/patches/dont_double_defer.patch:
    - Cherry pick upstream patch to avoid calling errback twice on the
      same deferred object (LP: #1056545)
 -- Michael Terry <email address hidden> Tue, 02 Apr 2013 14:43:28 -0400

Changed in sessioninstaller (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr128-0ubuntu1.3

---------------
sessioninstaller (0.20+bzr128-0ubuntu1.3) precise-proposed; urgency=low

  * debian/patches/dont_double_defer.patch:
    - Cherry pick upstream patch to avoid calling errback twice on the
      same deferred object (LP: #1056545)
 -- Michael Terry <email address hidden> Thu, 28 Mar 2013 14:50:24 -0400

Changed in sessioninstaller (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers