Multimedia codec installer says "Python", rather than the name of the process/application (e.g. Rhythmbox, Videos) that requested the codec.

Bug #1049467 reported by Dylan McCall on 2012-09-12
70
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Session Installer
Undecided
Unassigned
sessioninstaller (Ubuntu)
High
Unassigned
totem (Ubuntu)
Undecided
Unassigned

Bug Description

When I try to open a .mp4 file with Videos (totem), a dialog appears to install extra multimedia plugins. This dialog says "Python (v2.7) requires to install plugins to play files of the following types". Instead, the dialog should refer to the Videos application. For example: "Videos requires to install…"

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: sessioninstaller 0.20+bzr131-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-14.16-generic 3.5.3
Uname: Linux 3.5.0-14-generic x86_64
ApportVersion: 2.5.1-0ubuntu7
Architecture: amd64
Date: Tue Sep 11 21:54:09 2012
ExecutablePath: /usr/bin/session-installer
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Beta amd64 (20110906)
InterpreterPath: /usr/bin/python2.7
PackageArchitecture: all
SourcePackage: sessioninstaller
UpgradeStatus: Upgraded to quantal on 2012-08-26 (16 days ago)

Dylan McCall (dylanmccall) wrote :
Fabio Marconi (fabiomarconi) wrote :

Hallo Dylan
Is this reproducible again ?
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in totem (Ubuntu):
status: New → Incomplete
Changed in sessioninstaller (Ubuntu):
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

Ok, reproduced.
set back to canfirmed
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in totem (Ubuntu):
status: Incomplete → Confirmed
Changed in sessioninstaller (Ubuntu):
status: Incomplete → Confirmed
tags: added: raring
Changed in totem:
importance: Undecided → Unknown
status: New → Unknown
Changed in rhythmbox:
importance: Undecided → Unknown
status: New → Unknown
Changed in totem:
importance: Unknown → Medium
status: Unknown → New
Changed in rhythmbox (Ubuntu):
status: New → Confirmed
Triniton Adam (trinitonadam) wrote :
Changed in rhythmbox:
importance: Unknown → Medium
status: Unknown → New
Sebastian Heinlein (glatzor) wrote :

Fix the detection of the client application in sessioninstaller

Changed in sessioninstaller:
status: New → Fix Committed
Changed in sessioninstaller (Ubuntu):
importance: Undecided → High
Changed in totem (Ubuntu):
status: Confirmed → Invalid
Changed in rhythmbox (Ubuntu):
status: Confirmed → Invalid

The attachment "fix-lp1049467.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Changed in rhythmbox:
status: New → Unknown
Changed in totem:
status: New → Invalid
summary: - Multimedia plugins installer says "Python," rather than the Videos
- application, needs me to install plugins
+ Multimedia codec installer says "Python", rather than the name of the
+ process/application (e.g. Rhythmbox, Videos) that requested the codec.

With patch from Sebastian Heinlein (glatzor), this bug is solved, thanks

Example screenshot (Gnomeradio codec install):

1. Before patch applied
2. After patch applied

Changed in sessioninstaller (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sessioninstaller - 0.20+bzr134-0ubuntu6

---------------
sessioninstaller (0.20+bzr134-0ubuntu6) raring; urgency=low

  * debian/patches/05_parent_process_name.patch:
    - Cherry pick upstream patch to fix the detection of the client application.
      Patch from Sebastian Heinlein, thanks! (LP: #1049467)
 -- POJAR GEORGE <email address hidden> Mon, 08 Apr 2013 08:45:12 +0000

Changed in sessioninstaller (Ubuntu):
status: Fix Committed → Fix Released
no longer affects: rhythmbox (Ubuntu)
no longer affects: rhythmbox
no longer affects: totem
Changed in sessioninstaller:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.