install or removal fails with `update-inetd: error: --group is only relevant with --add`

Bug #1792582 reported by Dan Watkins on 2018-09-14
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
sendmail (Ubuntu)
High
Brian Murray
Cosmic
High
Brian Murray

Bug Description

[Impact]
if you have update-inetd installed, part of all? -desktop metapackages, you can not install or upgrade sendmail-base.

[Test Case]
1) apt install update-inetd
2) apt install sendmail-base

With the old version of the package you'll observe the following failure.

Setting up sendmail-base (8.15.2-11) ...
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: error: --group is only relevant with --add
dpkg: error processing package sendmail-base (--configure):
 installed sendmail-base package post-installation script subprocess returned error exit status 255

With the new version of the package you won't. Hooray!

[Regression Potential]
This has been fixed in Debian and the fix just removes an irrelevant argument, given that the package is currently uninstallable when update-inetd is installed the potential for making things worse is very low.

$ sudo apt-get remove -y sendmail-base 100 [ 09:37:15 ]
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  sendmail-base
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 867 kB disk space will be freed.
(Reading database ... 260510 files and directories currently installed.)
Removing sendmail-base (8.15.2-11) ...
update-inetd: error: --group is only relevant with --add
dpkg: error processing package sendmail-base (--remove):
 installed sendmail-base package pre-removal script subprocess returned error exit status 255
Errors were encountered while processing:
 sendmail-base
E: Sub-process /usr/bin/dpkg returned an error code (1)

ProblemType: BugDistroRelease: Ubuntu 18.10
Package: sendmail-base 8.15.2-11
ProcVersionSignature: Ubuntu 4.18.0-7.8-generic 4.18.5
Uname: Linux 4.18.0-7-generic x86_64
ApportVersion: 2.20.10-0ubuntu9
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 14 09:25:36 2018
InstallationDate: Installed on 2017-10-23 (325 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171018)
PackageArchitecture: allSourcePackage: sendmail
UpgradeStatus: Upgraded to cosmic on 2018-09-10 (3 days ago)

Dan Watkins (daniel-thewatkins) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sendmail (Ubuntu):
status: New → Confirmed

I had the same issue and was able to work around it by replacing
update-inetd --group MAIL --disable smtp,smtps,submission;
with
update-inetd --disable smtp,smtps,submission;

in file /var/lib/dpkg/info/sendmail-base.prerm

Rik Mills (rikmills) wrote :

Installation/upgrade also fails with the same issue.

LP: #1796846

summary: - Removal fails with `update-inetd: error: --group is only relevant with
- --add`
+ install or removal fails with `update-inetd: error: --group is only
+ relevant with --add`
Changed in sendmail (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in sendmail (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Brian Murray (brian-murray)
Ben Bristow (benbristow) wrote :

@Michael Weimerskirch's instructions fixed the package for me. Thanks!

Alex N. (a-nox) wrote :

The patch described by YVS in #1796846 fixed it for me.

Hello Dan, or anyone else affected,

Accepted sendmail into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/sendmail/8.15.2-11ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Changed in sendmail (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Brian Murray (brian-murray) wrote :

I upgraded from the broken version of sendmail-base to the new in -proposed and it installed successfully.

After this operation, 0 B of additional disk space will be used.
Get:1 http://192.168.10.7/ubuntu cosmic-proposed/universe amd64 sendmail-base all 8.15.2-11ubuntu1 [137 kB]
Fetched 137 kB in 0s (0 B/s)
(Reading database ... 170312 files and directories currently installed.)
Preparing to unpack .../sendmail-base_8.15.2-11ubuntu1_all.deb ...
Unpacking sendmail-base (8.15.2-11ubuntu1) over (8.15.2-11) ...
Setting up sendmail-base (8.15.2-11ubuntu1) ...
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
update-inetd: warning: cannot add service, /etc/inetd.conf does not exist
Processing triggers for man-db (2.8.4-2) ...

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sendmail - 8.15.2-11ubuntu1

---------------
sendmail (8.15.2-11ubuntu1) cosmic; urgency=medium

  * Fix "update-inetd: error: --group is only relevant with --add" by removing
    the --group argument where it's irrelevant. (LP: #1792582)

 -- Brian Murray <email address hidden> Fri, 19 Oct 2018 16:21:45 -0700

Changed in sendmail (Ubuntu Cosmic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for sendmail has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers