missing dependences

Bug #237964 reported by Marcos Hack on 2008-06-06
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sendemail (Ubuntu)
Undecided
Unassigned
Nominated for Precise by Peter Matulis

Bug Description

Binary package hint: sendemail

After installing sendEmail using "sudo apt-get install sendEmail" and try to send an e-mail I get the error:

    sendEmail[22362]: ERROR => No TLS support! SendEmail can't load required libraries. (try installing Net::SSLeay and IO::Socket::SSL)

After install the packages "libio-socket-ssl-perl" and "libnet-ssleay-perl" it works fine.

Related branches

Cesare Tirabassi (norsetto) wrote :

Starting with sendEmail v1.54, TLS support is included. tls=auto is the default (ie. TLS will be used if possible) so I think that adding libio-socket-ssl-perl and libnet-ssleay-perl as Suggests makes sense.

Changed in sendemail:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sendemail - 1.55-1ubuntu1

---------------
sendemail (1.55-1ubuntu1) intrepid; urgency=low

  * Add libio-socket-ssl-perl and libnet-ssleay-perl as Suggests (LP: #237964).
    Since sendEmail v1.54, TLS support is included but not used by default.
    These perl modules are necessary to use this functionality if specified
    with the -o tls=yes command line option.
  * Modify Maintainer value to match the DebianMaintainerField
    specification.

 -- Cesare Tirabassi <email address hidden> Fri, 06 Jun 2008 23:37:58 +0200

Changed in sendemail:
status: Fix Committed → Fix Released
Alex Moldovan (alexmoldovan) wrote :

Using Ubuntu 12.04 3.2.0-33-generic #52 i586 i586 i386 and sendemail 1.56-2 I still have to install:
libio-socket-ssl-perl and libnet-ssleay-perl for it to work.
Sendemail only installs: libio-socket-inet6-perl and libsocket6-perl

Alex Moldovan (alexmoldovan) wrote :

This also affects Quantal and Lucid:

Quantal (12.10):
$ apt-cache depends sendemail
Depends: perl
Depends: libio-socket-inet6-perl
Suggests: libio-socket-ssl-perl
Suggests: libnet-ssleay-perl

Lucid (10.04):
$ apt-cache depends sendemail
Depends: perl
Suggests: libio-socket-ssl-perl
Suggests: libnet-ssleay-perl

Changed in sendemail (Ubuntu):
status: Fix Released → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers