update-selinux-policy fails when there's only a base policy module to load

Bug #955426 reported by Tim Tickel on 2012-03-14
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
selinux (Ubuntu)
Undecided
Unassigned

Bug Description

when update-selinux-policy is run in postinst from the trigger, it will fail if the policy being loaded consists of only a single policy module file (base.pp) due to a failing grep -v and a set -e.

Related branches

Tim Tickel (twt--) wrote :
tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package selinux - 1:0.11

---------------
selinux (1:0.11) precise; urgency=low

  * Make update-selinux-policy work when only a base policy module is used.
    (LP: #955426)
 -- Tim Tickel <email address hidden> Wed, 14 Mar 2012 13:06:49 -0700

Changed in selinux (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers