seed crashed with SIGSEGV in g_strcmp0()

Bug #818200 reported by Curtis Hovey on 2011-07-29
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
seed (Ubuntu)
Medium
Unassigned

Bug Description

Seed cannot be run at all. typing
    seed
in a terminal always segfaults.

I ran pocketlint path/to/file.js

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: seed 3.0.0-1
ProcVersionSignature: Ubuntu 3.0.0-7.8-generic-pae 3.0.0
Uname: Linux 3.0.0-7-generic-pae i686
NonfreeKernelModules: nvidia wl
Architecture: i386
CrashCounter: 1
Date: Fri Jul 29 14:38:53 2011
ExecutablePath: /usr/bin/seed
ProcCmdline: /usr/bin/seed /usr/lib/pymodules/python2.7/pocketlint/jsreporter.js /usr/lib/pymodules/python2.7/pocketlint/contrib/fulljslint.js /home/username/Work/launchpad/person-picker-expand-0/lib/lp/app/javascript/picker/picker.js
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0xb7717e0b: cmp %cl,(%edx)
 PC (0xb7717e0b) ok
 source "%cl" ok
 destination "(%edx)" (0x11543000) not located in a known VMA region (needed writable region)!
SegvReason: writing unknown VMA
Signal: 11
SourcePackage: seed
StacktraceTop:
 ?? () from /lib/i386-linux-gnu/libc.so.6
 g_strcmp0 () from /lib/i386-linux-gnu/libglib-2.0.so.0
 seed_gobject_define_property_from_function_info () from /usr/lib/libseed-gtk3.so.0
 seed_struct_prototype () from /usr/lib/libseed-gtk3.so.0
 seed_define_gtype_functions () from /usr/lib/libseed-gtk3.so.0
Title: seed crashed with SIGSEGV in g_strcmp0()
UpgradeStatus: Upgraded to oneiric on 2011-07-01 (28 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Curtis Hovey (sinzui) wrote :
visibility: private → public

StacktraceTop:
 __strcmp_ssse3 () at ../sysdeps/i386/i686/multiarch/strcmp-ssse3.S:75
 g_strcmp0 (str1=0x11543000 <Address 0x11543000 out of bounds>, str2=0xb778ed21 "new") at /build/buildd/glib2.0-2.29.14/./glib/gtestutils.c:1540
 seed_gobject_define_property_from_function_info () from /usr/lib/libseed-gtk3.so.0
 seed_struct_prototype () from /usr/lib/libseed-gtk3.so.0
 seed_define_gtype_functions () from /usr/lib/libseed-gtk3.so.0

Changed in seed (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Curtis Hovey (sinzui) wrote :

Seed cannot be run at all. typing
    seed
in a terminal always segfaults.

Curtis Hovey (sinzui) on 2011-09-12
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in seed (Ubuntu):
status: New → Confirmed
Barry Warsaw (barry) wrote :

Hi Curtis. I tried running

$ seed

and

$ seed /path/to/whatever.js

on Oneiric amd64 and neither crashed for me.

Curtis Hovey (sinzui) wrote :

\o/ it must have healed itself in the last 3 weeks. Feel free to close the bug. I suspect a few similar bugs are also closable now.

Michael Terry (mterry) on 2011-10-28
Changed in seed (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers