seamonkey 2.0.13 does not start, missing and (Natty, x86_64)

Bug #759406 reported by Wladimir Mutel on 2011-04-13
This bug affects 7 people
Affects Status Importance Assigned to Milestone
seamonkey (Ubuntu)

Bug Description

Binary package hint: seamonkey

$ seamonkey
/usr/lib/seamonkey-2.0.13/seamonkey-2.0-bin: symbol lookup error: /usr/lib/seamonkey-2.0.13/components/ undefined symbol: NS_GetServiceManager

$ ldd /usr/lib/seamonkey-2.0.13/components/ => (0x00007fff862d3000) => /lib/x86_64-linux-gnu/ (0x00007f00bdd23000) => not found => not found => /usr/lib/ (0x00007f00bdb1d000) => /usr/lib/ (0x00007f00bd8e2000) => /usr/lib/x86_64-linux-gnu/ (0x00007f00bd5db000) => /lib/x86_64-linux-gnu/ (0x00007f00bd247000)
        /lib64/ (0x00007f00be1c5000) => /lib/x86_64-linux-gnu/ (0x00007f00bd043000) => /lib/x86_64-linux-gnu/ (0x00007f00bcdbd000) => /lib/x86_64-linux-gnu/ (0x00007f00bcba7000)

Wladimir Mutel (mwg) wrote :

Also tried this :

$ sudo rm /usr/lib/seamonkey-2.0.13/components/

$ seamonkey
/usr/lib/seamonkey-2.0.13/seamonkey-2.0-bin: symbol lookup error: /usr/lib/seamonkey-2.0.13/components/ undefined symbol: NS_Alloc

$ ldd /usr/lib/seamonkey-2.0.13/components/ => (0x00007fffe17ff000) => /lib/x86_64-linux-gnu/ (0x00007f60fa8d0000) => not found => /usr/lib/ (0x00007f60fa694000) => /usr/lib/ (0x00007f60fa46e000) => /lib/x86_64-linux-gnu/ (0x00007f60fa22a000) => /usr/lib/x86_64-linux-gnu/ (0x00007f60f9f23000) => /lib/x86_64-linux-gnu/ (0x00007f60f9b8f000)
        /lib64/ (0x00007f60fad18000) => /lib/x86_64-linux-gnu/ (0x00007f60f998b000) => /usr/lib/x86_64-linux-gnu/ (0x00007f60f9739000) => /lib/x86_64-linux-gnu/ (0x00007f60f944a000) => /lib/x86_64-linux-gnu/ (0x00007f60f9242000) => /lib/x86_64-linux-gnu/ (0x00007f60f8fbc000) => /lib/x86_64-linux-gnu/ (0x00007f60f8da6000) => /usr/lib/x86_64-linux-gnu/ (0x00007f60f8ba1000) => /lib/x86_64-linux-gnu/ (0x00007f60f8964000)

Wladimir Mutel (mwg) wrote :

removed also /usr/lib/seamonkey-2.0.13/components/
then seamonkey started seemingly fine, but crashed in very soon
removed /usr/lib/seamonkey-2.0.13/components/ , and seamonkey works more stable afterwards (including Mail&NewsGroups)

But for Ubuntu package, these manual interventions are IMO undesirable anyway.

Micah Gersten (micahg) wrote :

Thank you for reporting this to Ubuntu. This works fine for me on Natty 64 bit. Could you please try reinstalling the package? I don't see anything obviously wrong based on the output provided. If you're still having an issue, could you please provide the output of:
ldd /usr/lib/seamonkey-2.0.13/seamonkey-2.0-bin

Also, please make sure that 'which seamonkey' shows /usr/bin/seamonkey and not another one.

Changed in seamonkey (Ubuntu):
status: New → Incomplete

I'm seeing this as well, under the latest Natty updates as of 16-Apr-2011.

$ uname -a
Linux io 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

$ seamonkey
/usr/lib/seamonkey-2.0.13/seamonkey-2.0-bin: symbol lookup error: /usr/lib/seamonkey-2.0.13/components/ undefined symbol: NS_GetServiceManager

This was a new install on a new machine, so there isn't any prior config files hanging around.

Curiously, the --version option doesn't have this problem, and correctly report the version string:

$ seamonkey --version
Mozilla SeaMonkey 2.0.13, Copyright (c) 1998-2010

Other things:

$ which seamonkey

$ ldd /usr/lib/seamonkey-2.0.13/seamonkey-2.0-bin => (0x00007ffffdfff000) => /lib/x86_64-linux-gnu/ (0x00007fd66b907000) => not found => not found => /lib/x86_64-linux-gnu/ (0x00007fd66b572000)
        /lib64/ (0x00007fd66bb4b000)

Jason Joines (joines) wrote :

Same problem as of latest Natty right now.

yen rio (yenrio) wrote :

Same problem in Kubuntu after latest Natty updates

Ed Swierk (eswierk) wrote :

The fact that ldd /usr/lib/seamonkey-2.0.13/components/ can't find is a red herring; that library lives in /usr/lib/seamonkey-2.0.13 which isn't in the normal library path, and ldd shows the same result even on a system where seamonkey is working.

I ran LD_DEBUG=all seamonkey and captured the output (see attachment). It shows NS_GetServiceManager is found in when is loaded, but for some reason when is loaded, is never even searched.

Changed in seamonkey (Ubuntu):
status: Incomplete → New

Same problem in Xubuntu; have checked this morning after updates, and Seamonkey still not launching windows when clicking on menu entry.

My workround is to use the 2.0.14 binary package from mozilla for now with a manual .desktop file in ~/.local/share

Andrej (rarog) wrote :

Same here with Kubuntu 11.04 (x64) but I think the problem is universal and independent from Ubuntu flavour.

Antoine Wils (antoine-wils) wrote :

I have same config as Vogon Zarniwoop and had an issue with but when using eclipse.
I manage to fix it. See my post at

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers