seahorse crashes when importing an SSH key. (Assertion Failed/Segfault)

Bug #980035 reported by James Lewis on 2012-04-12
34
This bug affects 7 people
Affects Status Importance Assigned to Milestone
seahorse (Ubuntu)
Low
Unassigned

Bug Description

While trying to verify if this bug is now fixed, so that it can be closed:-

https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/372608

I am seeing that infact, the bug above appears to be resolved... although now it crashes moments after successfully importing a key, this bug is apparently also tracked by redhat here:-

https://bugzilla.redhat.com/show_bug.cgi?id=751515

The bug I was originally looking at states that a lot of the import code was re-written for seahorse 3.4, so perhaps the solution to this is to ask why seahorse is not one of those apps which have been/can be rolled forward in 12.04.

James

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: seahorse 3.2.2-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-18.29-generic 3.2.9
Uname: Linux 3.2.0-18-generic x86_64
ApportVersion: 2.0.1-0ubuntu2
Architecture: amd64
Date: Thu Apr 12 17:17:23 2012
ExecutablePath: /usr/bin/seahorse
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120228.1)
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 LANGUAGE=en_GB:en
SourcePackage: seahorse
UpgradeStatus: No upgrade log present (probably fresh install)

James Lewis (james-fsck) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. However, your crash report is either missing or challenging to deal with as a ".crash" file. Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.
If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

I'm closing this bug report since the process outlined above will automatically open a new bug report which can then dealt with more efficiently. Thanks in advance for your cooperation and understanding.

Changed in seahorse (Ubuntu):
importance: Undecided → Low
status: New → Invalid

Attached is my crash file for this.

I see same error, this is console exit:

** Message: SSH command failed: (1)
** Message: SSH error: load failed

**
ERROR:seahorse-ssh-source.c:687:on_import_private_complete: assertion failed: (closure->imports > 0)
Abortado (`core' generado)

Changed in seahorse (Ubuntu):
status: Invalid → Confirmed
Alexander Broshevich (vcosvic) wrote :

I have the same error.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers