The page 'gkr-keyring' was not found in the document 'ghelpseahorse'.

Bug #853137 reported by Detlef Lechner on 2011-09-18
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
Unassigned
Precise
Medium
James M. Leddy
seahorse
Fix Released
Medium
seahorse (Ubuntu)
Low
Sebastien Bacher
Precise
Low
Unassigned
Quantal
Low
Sebastien Bacher

Bug Description

Impact:
One of the "help" button is leading to an error page

Testcase:

precise:
seahorse > (Passsword and Keyss) > [tab] Passwords > Passwors: default> [right-click] Properties > "Passwords:default" > (dialog window "Passwords:default") > Keyring > Name:=default, Created:=(empty) > Help > (Help) > "PageNotFound": > The page 'gkr-keyring' was not found in the document 'ghelpseahorse'.

quantal:
right click on a keyring in the left side
of the main ui, properties, help -> error

Regression Potential:
the button can keep not working...

Related branches

Detlef Lechner (detlef-lechner) wrote :
Changed in seahorse (Ubuntu):
status: New → Confirmed
Changed in seahorse (Ubuntu):
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=659834

Changed in seahorse (Ubuntu):
status: Confirmed → Triaged
Changed in seahorse:
importance: Undecided → Unknown
status: New → Unknown
Changed in seahorse:
importance: Unknown → Medium
status: Unknown → New
Kent Lin (kent-jclin) on 2012-08-03
Changed in oem-priority:
importance: Undecided → Medium
Steve Magoun (smagoun) on 2012-08-06
Changed in oem-priority:
status: New → Confirmed
tags: added: rls-q-incoming
tags: removed: rls-q-incoming
Changed in oem-priority:
status: Confirmed → In Progress

The branch is submitted against Precise, yet this is nominated to Quantal. Was there a mistake? It doesn't seem to apply to quantal, the UI is very different.

At the very least I'll target this to precise; but please follow http://wiki.ubuntu.com/StableReleaseUpdates#Procedure to add the necessary "paperwork" for this bug report to apply as SRU.

no longer affects: seahorse (Ubuntu Quantal)
no longer affects: oem-priority/precise
Changed in seahorse (Ubuntu):
status: Triaged → Incomplete
description: updated
Changed in seahorse (Ubuntu):
status: Incomplete → Fix Committed
Changed in seahorse (Ubuntu Quantal):
status: Fix Committed → In Progress
Changed in seahorse (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Low
Changed in seahorse (Ubuntu Quantal):
assignee: nobody → Sebastien Bacher (seb128)

Hello Detlef, or anyone else affected,

Accepted seahorse into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/seahorse/3.6.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in seahorse (Ubuntu Quantal):
status: In Progress → Fix Committed
tags: added: verification-needed
Jeremy Bicha (jbicha) wrote :

The help links work properly on quantal-proposed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse - 3.6.2-0ubuntu1

---------------
seahorse (3.6.2-0ubuntu1) quantal-proposed; urgency=low

  * New upstream release
    + Fix problem where keyring items overwrite one another. Regression since
    the migration to libsecret. Items stored manually by choosing 'Stored
    Password' overwrite one another. (BGO: #686407)

seahorse (3.6.1-0ubuntu1) quantal-proposed; urgency=low

  * New upstream version:
    - Strip DBus errors before displaying them
    - Fix regression for changing a keyring master password (lp: #1048484)
    - Updated translations
  * debian/patches/use_valid_help_url.patch:
    - Let help buttons point to valid documentation references (lp: #853137)
 -- Iain Lane <email address hidden> Tue, 23 Oct 2012 09:50:08 +0100

Changed in seahorse (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Hello Detlef, or anyone else affected,

Accepted seahorse into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/seahorse/3.2.2-0ubuntu2.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in seahorse (Ubuntu Precise):
status: In Progress → Fix Committed
tags: removed: verification-done
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse - 3.6.3-0ubuntu1

---------------
seahorse (3.6.3-0ubuntu1) raring; urgency=low

  * New upstream version
 -- Sebastien Bacher <email address hidden> Mon, 12 Nov 2012 11:41:34 +0100

Changed in seahorse (Ubuntu):
status: In Progress → Fix Released
Sebastien Bacher (seb128) wrote :

The update is available for a week, it's only waiting on testing confirmation to move to the official updates set...

Sebastien Bacher (seb128) wrote :

James, since you reported that the bug affects OEM work is there any chance you could test the SRU so it can be moved to updates?

James M. Leddy (jm-leddy) wrote :

Sure thing

James M. Leddy (jm-leddy) wrote :

Works like a charm, thank you for fixing

Changed in oem-priority:
status: In Progress → Fix Committed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse - 3.2.2-0ubuntu2.1

---------------
seahorse (3.2.2-0ubuntu2.1) precise-proposed; urgency=low

  * debian/patches/use_valid_help_url.patch:
    - Let help buttons point to valid documentation references (lp: #853137)
 -- Sebastien Bacher <email address hidden> Wed, 17 Oct 2012 19:43:05 +0200

Changed in seahorse (Ubuntu Precise):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

--- Releasing seahorse ---
Proposed: 3.2.2-0ubuntu2.1
Release: 3.2.2-0ubuntu2
Copied to precise-updates

Changed in oem-priority:
status: Fix Committed → Fix Released
Changed in seahorse:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.