Nautilus seahorse plugin does not decrypt *.pgp files.

Bug #42869 reported by Fabián Rodríguez on 2006-05-04
22
Affects Status Importance Assigned to Milestone
seahorse
Invalid
Undecided
Unassigned
seahorse (Ubuntu)
Medium
Unassigned

Bug Description

The nautilus seahorse plugin will encrypt files perfectly for me. The problem is that it will not decrypt them. It has not got the .pgp mime type assigned to it.

Decrypting .gpg works fine. Just .pgp does not work.

I spoke with "sadam" on the freenode irc #seahorse channel, who asked me to do the following. He also updated the seahorse cvs appropriatly.

I updated /usr/share/mime-info/seahorse.mime to the following:
-----------------------------------
application/pgp
 ext: gpg pgp asc

application/pgp-encrypted
 ext: gpg pgp asc

application/pgp-signature
 ext: sig

application/pgp-keys
 ext: key keys
-----------------------------------

and then ran the following command:
# sudo update-mime-database /usr/share/mime

Unfortunely, this still did not seem to fix the problem for me, but it did however fix it for sadam. I'm not sure what OS he was using.
I'm using Dapper (installed from beta1 text-install and all updates applied).

Fabián Rodríguez (magicfab) wrote :

Posted froma support request. See:
https://launchpad.net/products/seahorse/+ticket/868

Tim Kersten (timkersten) wrote :

In the description above, I forgot to mention that the following file was also updated:

/usr/share/mime/packages/seahorse.xml

The "application/pgp-encrypted" section now looks like this:
-----------------------------------------------------------------------------------
  <mime-type type="application/pgp-encrypted">
    <magic priority="90">
      <match type="string" value="-----BEGIN PGP MESSAGE-----" offset="0"/>
    </magic>
    <glob pattern="*.pgp"/>
    <glob pattern="*.gpg"/>
    <glob pattern="*.asc"/>
  </mime-type>
-----------------------------------------------------------------------------------
Please note, this had still not fixed the problem for me.

Vytas (vytas) on 2006-05-16
Changed in seahorse:
status: Unconfirmed → Confirmed
Sebastian Heinlein (glatzor) wrote :

Use "MimeType=application/pgp-encrypted;application/pgp;" in the desktop file of the descript application "/usr/share/applications/seahorse-pgp-encrypted.desktop".

Regards,

Sebastian

Sebastian Dröge (slomo) wrote :

This is fixed with 0.9.2.1-0ubuntu1

Changed in seahorse:
status: Confirmed → Fix Released
zween (sk-svenkreiss-com) wrote :

Hello Sebastian,

I just installed for the first time seahorse under ubuntu edgy. The seahorse version is 0.9.7-0ubuntu1~edgy1.

There is no application associated with the extension pgp. One thing is weird: the "Encrypt ... "- and "Sign"-item in the nautilus drop-down menu does not exist for files with this extension either. Thats probably what you want, but I thought I mention it.

Fabián Rodríguez (magicfab) wrote :

Not working for me either under Edgy,

I get a popup error dialog with "Cannot open /home/magicfab/Desktop/titles.pgp: No application is known for this kind of file."

zween (sk-svenkreiss-com) wrote :

Not working in 0.9.7-0ubuntu1~edgy1.

Changed in seahorse:
status: Fix Released → Confirmed
Sebastian Dröge (slomo) wrote :

Still fixed in feisty... please open a backport or SRU task if you need this in edgy.
It's a shared-mime-info bug btw...

Changed in seahorse:
status: Confirmed → Fix Released
zween (sk-svenkreiss-com) wrote :

Dont know how to do backport or SRU task.

I am using a workaround for edgy now: right-click on a pgp file, click "Open with other application..." and type in "Use a custom command": "seahorse-tool -d".

Now, it should always work.

Changed in seahorse:
status: Unconfirmed → Rejected
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers