seahorse can not change trust level

Bug #365540 reported by bernhard on 2009-04-23
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
seahorse
Fix Released
Medium
seahorse (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: seahorse

It is not possible to change the trust of the key i signed.
The gui always displays : Trust: Marginal and the dropdown box is disabled. (as you can see in the screenshot)

the gpg command displayes 2 trust levels:
1. trust:marginal
2. [ full ]

$ gpg --edit-key <email address hidden>
gpg (GnuPG) 1.4.9; Copyright (C) 2008 Free Software Foundation, Inc.
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

pub 1024D/2A47CC28 created: 2009-04-05 expires: 2010-04-05 usage: SC
                     trust: marginal validity: full
sub 4096g/0871105F created: 2009-04-05 expires: 2010-04-05 usage: E
[ full ] (1). xx xx <email address hidden>

if this is not a bug then it is at least an improvement for seahorse because this is not very user friendly

bernhard (bernhardredl) wrote :
bernhard (bernhardredl) wrote :

sry forgotten about
$ apt-cache policy seahorse
seahorse:
  Installed: 2.26.1-0ubuntu1
  Candidate: 2.26.1-0ubuntu1
  Version table:
 *** 2.26.1-0ubuntu1 0
        500 http://at.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

sry forgotten about:
$ apt-cache policy seahorse
seahorse:
  Installed: 2.26.1-0ubuntu1
  Candidate: 2.26.1-0ubuntu1
  Version table:
 *** 2.26.1-0ubuntu1 0
        500 http://at.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

$lsb_release -rd
Description: Ubuntu 9.04
Release: 9.04

Jonathan Michalon (johndescs) wrote :

Same issue here, do we both have missed some subtlety?
I managed to change this with the gpg command without any kind of problem.
I'm in jaunty too, upgraded from… hum gutsy :-)
Strange that nobody else claims about that…

Sagamens (sagamens) wrote :

I have the same problem, on clear install and upgrade from 8.10

Ubuntu 9.04 (32 bit version)
seahorse version: 2.26.1-0ubuntu1

Matthäus Brandl (matthaeus) wrote :

Same here, I usually use EnigMail/Thunderbird to change trust levels.

Ubuntu 9.04 (i386) upgraded
% LC_ALL=C apt-cache policy seahorse
seahorse:
  Installed: 2.26.1-0ubuntu1
  Candidate: 2.26.1-0ubuntu1
  Version table:
 *** 2.26.1-0ubuntu1 0
        500 http://de.archive.ubuntu.com jaunty/main Packages
        100 /var/lib/dpkg/status

Changed in seahorse (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in seahorse (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
Changed in seahorse (Ubuntu):
status: Confirmed → Triaged
Changed in seahorse:
status: Unknown → Fix Released
Robert Ancell (robert-ancell) wrote :

This was fixed in seahorse 2.27.1 (Ubuntu 9.10)

Changed in seahorse (Ubuntu):
status: Triaged → Fix Released
Robert Ancell (robert-ancell) wrote :

Correction, it was seahorse 2.27.5

Changed in seahorse:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.