There's no association for ASC public GPG files

Bug #248479 reported by Duncan Lithgow on 2008-07-14
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
seahorse
Fix Released
Low
seahorse (Ubuntu)
Wishlist
Ubuntu Desktop Bugs
Declined for Karmic by Sebastien Bacher
Nominated for Lucid by Otto Kekäläinen

Bug Description

Ubuntu 8.04
Seahorse 2.22.2
Nautilus 2.22.3

What happens:
* Open Seahorse with 'Applications > Accessories > Passwords and Encryption Keys'
* Select your personal key and right click, select 'Export Public Key...' and save the file to the desktop
* Double click the file on the file
   * Nautilus doesn't know what to do with the file (gedit will open it if you've opened it once)
   * Nautilus offer the context option to open with 'Decrypt File' (which of course doesn't work)

What I expect to happen:
Either
   * Seahorse should offer to add the public key to my keyring
or
   * gedit should open the file

The file has under 'Properties > Basic' this information:
Type: PGP/MIME-encrypted message header
MIME type: application/pgp-encrypted

Updated 2011-04-28
Ubuntu 10.10
Seahorse 2.32.0-0ubuntu1
Nautilus 2.32.0

Seahorse has now moved to 'System > Preferences > Password and Encryption Keys'

description: updated
Dimitrios Symeonidis (azimout) wrote :

duncan, it does import the key on my system (intrepid)
seahorse: 2.24.1-0ubuntu1
nautilus: 1:2.24.1-0ubuntu1

Changed in ubuntu-meta:
status: New → Incomplete
Dimitrios Symeonidis (azimout) wrote :

under properties|basic i see:
type: PGP keys (application/pgp-keys)

and it opens with "import key"

Duncan Lithgow (duncan-lithgow) wrote :

Works for me as well in Intrepid.

Changed in seahorse:
status: Incomplete → Fix Released
Otto Kekäläinen (otto) wrote :

I decided to reopen this bug, since it has reappeared in Karmic Koala. The file association is missing again. Opening .asc files runs Gedit, not Seahorse.

Also, in the newest version of Gedit there is no GPG-plugin anymore, so the situation is much worse than in older Ubuntu versions.

Changed in seahorse (Ubuntu):
status: Fix Released → Confirmed
Duncan Lithgow (duncan-lithgow) wrote :

@otto: You should really have put it back to 'Incomplete' so someone _else_ could check if the bug exists. But that's what I've just done so this reappearing is confirmed.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in seahorse (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Wishlist
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in seahorse (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed
status: Confirmed → Triaged
Changed in seahorse:
importance: Unknown → Low
status: Unknown → Confirmed
description: updated
Peter Bolgar (pbolgar) wrote :

This is still a bug in 11.10.

Changed in seahorse:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.