/usr/bin/seahorse:11:g_atomic_ref_count_dec:g_variant_unref:___lambda22_:____lambda22__gasync_ready_callback:g_simple_async_result_complete

Bug #1818053 reported by errors.ubuntu.com bug bridge on 2019-02-28
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
seahorse (Ubuntu)
High
Unassigned

Bug Description

The Ubuntu Error Tracker has been receiving reports about a problem regarding seahorse. This problem was most recently seen with package version 3.31.91-1, the problem page at https://errors.ubuntu.com/problem/27dfb9fa56c174fbd9ea1d62a3efc5816a0b5fb9 contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in seahorse (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Confirmed, it segfaults when change the keyring password
* right click on the 'login' in the sidebar
* select change password
* type the old password then new one/confirm/validate

-> it segfaults, on this code line
https://gitlab.gnome.org/GNOME/seahorse/blob/3.31.91/gkr/gkr-keyring.vala#L194

could it be a vala bug?

(that's still an issue in git master)

Changed in seahorse (Ubuntu):
importance: Undecided → High
Sebastien Bacher (seb128) wrote :
Changed in seahorse (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse - 3.32-1

---------------
seahorse (3.32-1) experimental; urgency=medium

  * New upstream release
    - Fix crash when changing login password (LP: #1818053)

 -- Jeremy Bicha <email address hidden> Sat, 16 Mar 2019 08:24:50 -0400

Changed in seahorse (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers