Imported gpg keys do not show up in Seahorse 3.18.0

Bug #1577198 reported by 5a54a on 2016-05-01
92
This bug affects 18 people
Affects Status Importance Assigned to Milestone
seahorse (Ubuntu)
Undecided
Unassigned

Bug Description

After clean install of Ubuntu-Gnome 16.04 LTS I tried to import all my previous exported gpg keys. Although it seems the keys are imported, they do not show up in seahorse (Passwords and Keys). Also Evolution did not find to proper keys to decrypt messages.

It seems however that the keys have been imported under gpg1 in stead of gpg2. This can also be confirmed with the list command (gpg --list-key and gpg2 -- list-keys).

Importing all keys by command (gpg2 --import Multiple_Keys.asc) seems to work.

See also the same problem already reported by Andreas Happe on:
https://www.snikt.net/blog/2016/02/27/evolution-seahorse-gpg-gpg2-woes/

5a54a (5a54a) on 2016-05-01
description: updated
napsc (untrustytahr) wrote :

I am also having this problem. Same scenario:

1. Fresh install to 16.04.
2. Import public keys using menu in seahorse.
3. Keys do not appear in seahorse but can be listed using gpg –list-keys (from gpg(1) )
4. Importing the keys from CLI with gpg2 (gpg2 –import-keys <file>) and the keys will appear in seahorse.

So it appears that the import function in seahorse is using gpg(1) but the viewing of keys is pointing to gpg2.

I cannot confirm whether Evolution or Thunderbird sees keys as I do not use them.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in seahorse (Ubuntu):
status: New → Confirmed
5a54a (5a54a) on 2016-06-17
description: updated
Adi (adi5) wrote :

I posted some lines from the key storing files under https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/1588605

Seahorse stores imported key in a particular file when importing and takes keys from a different when using them. It seems to have a relation with the new gnupg-keybox-file.... *.kbx
[CODE]
adi@bluestar:~$ gpg2 --list-public-keys
/home/adi/.gnupg/pubring.kbx
[/CODE]

5a54a (5a54a) on 2016-06-17
description: updated
Benjamin Bach (benjaoming) wrote :

I agree, this was a very annoying bug as there are no error messages. Keys are just missing, and importing the old pubring.gpg through both Seahorse and Enigmail interfaces doesn't work.

The "bug" also affects Enigmail.

There is a nice description here regarding how to export your old pubring.gpg to pubring.kbx, retaining owner trust: http://stackoverflow.com/a/34221494/405682

Will this ever be fixed? Seahorse is at 3.20 and it still doesn't readily find keys from the GnuPG version 2 Keybox (.kbx) format.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers