It's not possible to create ED25519 SSH keys

Bug #1420522 reported by Eero on 2015-02-10
22
This bug affects 5 people
Affects Status Importance Assigned to Milestone
seahorse (Ubuntu)
Undecided
Unassigned

Bug Description

There are only options for RSA and DSA keys as you can see from the attached screenshot.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: seahorse 3.10.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-45.74-generic 3.13.11-ckt13
Uname: Linux 3.13.0-45-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.1-0ubuntu3.6
Architecture: amd64
CurrentDesktop: Unity
Date: Tue Feb 10 23:16:12 2015
InstallationDate: Installed on 2014-05-16 (270 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: seahorse
UpgradeStatus: No upgrade log present (probably fresh install)

Eero (eero+launchpad) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in seahorse (Ubuntu):
status: New → Confirmed
Adam Katz (khopesh) wrote :

There is information on using (but not creating) ed25519 keys in seahorse at bug 201786 and a workaround posted at https://unix.stackexchange.com/a/189646/87770

Here is the seahorse bug: https://bugzilla.gnome.org/show_bug.cgi?id=754028
Related GNOME bugs: https://bugzilla.gnome.org/buglist.cgi?quicksearch=ed25519

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse - 3.30-1

---------------
seahorse (3.30-1) unstable; urgency=medium

  * New upstream release (Closes: #889973)
    - Support creating SSH keys using ED25519 (LP: #1420522)
    - Remove broken help button from preferences dialog (Closes: #799435)
  * Build with meson
  * debian/docs: README is now README.md
  * Bump libglib2.0-dev to >= 2.44 & libgtk-3-dev to >= 3.22
  * Drop unused Build-Depends on gtk-doc-tools
  * Update Vcs fields for migration to https://salsa.debian.org/
  * Bump debhelper compat to 11
  * Bump Standards-Version to 4.2.1
  * Drop all patches: applied in new release

 -- Jeremy Bicha <email address hidden> Mon, 03 Sep 2018 19:35:11 -0400

Changed in seahorse (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.