seahorse-plugins version 2.30.1-3ubuntu2 failed to build in oneiric

Bug #832888 reported by Matthias Klose on 2011-08-24
110
This bug affects 20 people
Affects Status Importance Assigned to Milestone
seahorse-plugins (Debian)
Fix Released
Unknown
seahorse-plugins (Ubuntu)
High
Unassigned
Oneiric
High
Unassigned

Bug Description

seahorse-plugins version 2.30.1-3ubuntu2 failed to build in oneiric
Link to failed build: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2711227

Details about the rebuild:
http://people.ubuntuwire.org/~wgrant/rebuild-ftbfs-test/test-rebuild-20110816-oneiric.html

Direct link to the build log: https://launchpad.net/ubuntu/+archive/test-rebuild-20110816/+build/2711227/+files/buildlog_ubuntu-oneiric-amd64.seahorse-plugins_2.30.1-3ubuntu2_FAILEDTOBUILD.txt.gz

This log snippet might be of interest, since it triggered the matcher 'Purging chroot-autobuild'.
Excerpt 1814 lines into the build log:

seahorse-notification.c: In function 'setup_libnotify_notification':
seahorse-notification.c:216:5: error: too many arguments to function 'notify_notification_new'
/usr/include/libnotify/notification.h:114:21: note: declared here
seahorse-notification.c: In function 'keys_start_element':
seahorse-notification.c:388:22: warning: variable 'field' set but not used [-Wunused-but-set-variable]
make[4]: *** [seahorse-notification.o] Error 1
make[4]: Leaving directory `/build/buildd/seahorse-plugins-2.30.1/libseahorse'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/build/buildd/seahorse-plugins-2.30.1/libseahorse'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/build/buildd/seahorse-plugins-2.30.1'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/build/buildd/seahorse-plugins-2.30.1'
make: *** [debian/stamp-makefile-build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2
******************************************************************************
Build finished at 20110823-1435
FAILED [dpkg-buildpackage died]
Purging chroot-autobuild/build/buildd/seahorse-plugins-2.30.1

Matthias Klose (doko) on 2011-08-24
Changed in seahorse-plugins (Ubuntu):
status: New → Confirmed
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse-plugins - 2.30.1-3ubuntu3

---------------
seahorse-plugins (2.30.1-3ubuntu3) oneiric; urgency=low

  * debian/patch/libnotify_0.7.patch: Fix FTBFS with libnotify 0.7,
    GEdit plugin is disabled (LP: #832888)
 -- Laurent Bigonville <email address hidden> Mon, 05 Sep 2011 11:57:33 +0200

Changed in seahorse-plugins (Ubuntu Oneiric):
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

not enough, libcryptui-dev is NBS.
see http://people.canonical.com/~ubuntu-archive/nbs.html

Changed in seahorse-plugins (Ubuntu Oneiric):
status: Fix Released → Confirmed
tags: added: nbs
Daniel Holbach (dholbach) wrote :

Package was removed from oneiric.

Changed in seahorse-plugins (Ubuntu Oneiric):
status: Confirmed → Invalid
Kristian Kißling (kkissling) wrote :

Will there be a replacement? Encrypting files via Nautilus (/usr/lib/nautilus/extensions-2.0/libnautilus-seahorse.so) strikes me as a valuable feature. Its the only way that doesn't include use of command line.

Ross Bearman (rossbearman) wrote :

I must echo the call for a replacement; the Seahorse extensions provide essential functionality for a number of users.

Jake (jmiheve) wrote :

I'll also call for a replacement. This is a feature I use frequently, along with the Gedit plugin, for securing my personal data. This is critical functionality for many users.

Hello there just added the debian bug-reference: status: important.

this is also reported here in bug #862609 status: wishlist.

Since GPA looks a little behind...

Changed in seahorse-plugins (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.