gpg password prompt showing password in clear text

Bug #520099 reported by Andy Whitcroft on 2010-02-10
34
This bug affects 6 people
Affects Status Importance Assigned to Milestone
seahorse-plugins
Fix Released
High
seahorse-plugins (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: seahorse

When I use gpg to sign packages seahorse pops up and asks for my password. When entering the password I see the raw password instead of the normal splodges, exposing my password for all to see. Fail.

ProblemType: Bug
Architecture: i386
Date: Wed Feb 10 21:09:56 2010
DistroRelease: Ubuntu 10.04
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/seahorse
NonfreeKernelModules: wl
Package: seahorse 2.29.90-0ubuntu1
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-13.18masterusername3005-generic
SourcePackage: seahorse
Uname: Linux 2.6.32-13-generic i686
XsessionErrors:
 (gnome-settings-daemon:1679): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed
 (polkit-gnome-authentication-agent-1:1706): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed
 (gnome-power-manager:1711): Gdk-CRITICAL **: gdk_window_thaw_toplevel_updates_libgtk_only: assertion `private->update_and_descendants_freeze_count > 0' failed
 (seahorse-preferences:2847): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

Andy Whitcroft (apw) wrote :
Andy Whitcroft (apw) on 2010-02-10
Changed in seahorse (Ubuntu):
importance: Undecided → High
Steve Langasek (vorlon) wrote :

I can confirm this problem here. Seb says it's probably a seahorse-plugins bug, so reassigning.

Changed in seahorse (Ubuntu):
status: New → Confirmed
affects: seahorse (Ubuntu Lucid) → seahorse-plugins (Ubuntu Lucid)
Ronny Polley (polley) wrote :

I have the same problem since yesterday.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package seahorse-plugins - 2.29.90-0ubuntu3

---------------
seahorse-plugins (2.29.90-0ubuntu3) lucid; urgency=low

  * debian/patches/90_git_dont_display_gpg_password.patch:
    - git change to fix gpg password being displayed in the text entry
      (lp: #520099)
 -- Sebastien Bacher <email address hidden> Fri, 12 Feb 2010 00:41:59 +0100

Changed in seahorse-plugins (Ubuntu Lucid):
status: Confirmed → Fix Released
Changed in seahorse-plugins:
importance: Unknown → High
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.