vgabios need support DDC EDID

Bug #1022222 reported by Hiroshi Miura on 2012-07-08
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
seabios (Ubuntu)
Low
Unassigned
vgabios (Debian)
Fix Released
Unknown
vgabios (Ubuntu)
Low
Serge Hallyn

Bug Description

vgabios now does not support DDC EDID.
I've workd it and report it upstream.
https://savannah.nongnu.org/bugs/?36666

This issue prevent Ubuntu installer mistake a choice of resolution on KVM environment.
It also prevnet Ubuntu guest to select high resolution on std vga configuration of KVM host.

Suggested patch help guest Ubuntu OS to select high resolutions.

Related branches

Serge Hallyn (serge-hallyn) wrote :

Thanks for reporting this bug.

A fix for this would best be brought in through the debian package. Would you mind reporting it and sending your patch there?

Changed in vgabios (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Hiroshi Miura (miurahr) wrote :

Yes, I post it on debian BTS.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=654823#22

Debian project have a plan to migrate seabios instead of vgabios.

>The problem is that i'm not sure anymore this is the right route.
>These changes are too late for wheezy. For wheezy+1, we'll most
>likely drop vgabios completely, since seabios now includes its
>own implementation which works quite well. it lacks this DDC
>information too, but I guess for wheezy+1 time it will be
>implemented.

So I started to port it to seabios.
https://github.com/miurahr/seabios
It is still in development but works fine for me.

Changed in seabios (Ubuntu):
status: New → Triaged
importance: Undecided → Low
Changed in vgabios (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Serge Hallyn (serge-hallyn)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package vgabios - 0.7a-3ubuntu1

---------------
vgabios (0.7a-3ubuntu1) quantal; urgency=low

  * Add vgabios-edid.patch by Hiroshi Miura to support higher resolution
    guests with -vga std in qemu-kvm. (LP: #1022222)
 -- Serge Hallyn <email address hidden> Mon, 27 Aug 2012 10:40:39 -0500

Changed in vgabios (Ubuntu):
status: In Progress → Fix Released
Changed in vgabios (Debian):
status: Unknown → Fix Released
Robert Stonehouse (rstonehouse) wrote :

I installed this package successfully on 12.04. It gives higher resolutions for KVM guests (many thanks!)

But in a 12.04 guest I get offered 1920x1200 (16:10), 1600x1200 (16:10), 1600x900 (16:9) ...

The resolution I was looking for was 1920x1080(16:9) which from looking at the patches on https://savannah.nongnu.org/bugs/?36666 I thought would be supported.

Does this deserve a separate bug reported on launchpad?

Hi

This may be a bug.

- db 0xD1, 0x00 /* 0x0032 Standard timing #8 (1920 x 1080 @ 60 Hz) */
+ db 0xD1, 0x00 /* 0x0032 Standard timing #8 (1920 x 1200 @ 60 Hz) */

So there is not support 1920x1080.

Hiroshi

On 2012年09月15日 20:28, Robert Stonehouse wrote:
> I installed this package successfully on 12.04. It gives higher
> resolutions for KVM guests (many thanks!)
>
> But in a 12.04 guest I get offered 1920x1200 (16:10), 1600x1200 (16:10),
> 1600x900 (16:9) ...
>
> The resolution I was looking for was 1920x1080(16:9) which from looking
> at the patches on https://savannah.nongnu.org/bugs/?36666 I thought
> would be supported.
>
> Does this deserve a separate bug reported on launchpad?
>
> ** Bug watch added: Non-GNU Savannah Bug Tracker #36666
> http://savannah.nongnu.org/bugs/?36666
>

Serge Hallyn (serge-hallyn) wrote :

@Hiroshi,

do you mean that was a bug in the original comment, and 1920x1080 never worked?

Hiroshi Miura (miurahr) wrote :

Previous patch has a comment bug and standard violation that first DTD should be preferable resolution when EDID v1.3 offered.
Attachment is an updated patch

Hiroshi Miura (miurahr) wrote :

For seabios, now review of patches goes in upstream ML.

Here is a take3 post.
http://www.seabios.org/pipermail/seabios/2012-September/004619.html

The attachment "1920x1080 support" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Serge Hallyn (serge-hallyn) wrote :

Thanks, Hiroshi. I'm pushing the new version to quantal.

@Robert, could you test it (version 0.7a-3ubuntu2) and let us know whether it fixes the bug for you?

On 19 September 2012 14:42, Serge Hallyn <email address hidden> wrote:
> Thanks, Hiroshi. I'm pushing the new version to quantal.
>
> @Robert, could you test it (version 0.7a-3ubuntu2) and let us know
> whether it fixes the bug for you?

Yes; 1920x1080 now available (confirmed on 12.04). Many thanks Hiroshi

FYI the resolutions I got offered
  1920x1080
  1600x900
  1280x1024
  1280x800
  1152x864
  1024x768
  800x600

FWIW, Debian (upstream qemu following) now finally switched to vgabios from seabios (so bochs lgpl vgabios isn't used anymore), and seavgabios now have the resolutions mentioned - it looks like we've added these based on the patch for bochs vgabios mentioned here.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.