Sddm hangs with a blank cursor

Bug #1774789 reported by metaldoctor
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
sddm (Ubuntu)
Undecided
Unassigned

Bug Description

This bug happens approximately once or twice a week. My laptop gets switched off every day, and after a cold start in the morning I cannot boot up to sddm login prompt. I just see the mouse cursor, so X seems to be started and cannot go further.
After that I can correctly power my laptop off, or switch to one of the native terminals. During the second power on I'm able to login.
Here - https://imgur.com/P2eltiP is another problem which can happen in a couple of hours of work. It's a blinking distorted artifact frame around a window in focus. It dissapears when I move that window, so it is not that critical.

My .xsession-errors contents:
...
The X11 connection broke: I/O error (code 1)
XIO: fatal IO error 0 (Success) on X server ":0"
      after 11123 requests (11123 known processed) with 0 events remaining.

$ lsb_release -rd
Description: Ubuntu 18.04 LTS
Release: 18.04

$ apt-cache policy sddm
sddm:
  Installed: 0.17.0-1ubuntu7

I expected sddm to boot up to login invitation.

I've got just a cursor on a black screen.

$ sudo lspci
00:02.0 VGA compatible controller: Intel Corporation Device 591e (rev 02)

The laptop model is: Xiaomi Mi Notebook Air 12.5" 4/256 GB Silver

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Revision history for this message
metaldoctor (everhigh-3) wrote :

The bug disappeared a couple of week ago. Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers