Sddm service fails in Bionic

Bug #1763977 reported by Tom Chiverton on 2018-04-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
sddm (Ubuntu)
High
Unassigned

Bug Description

Some time in the last few days, on the Bionic beta, SDDM fails to start.

Visible symptom is the Kubuntu logo pulsing for around a minute (normally replaced by graphical login screen in a few seconds). Then drops to text mode with single line at the top saying / is clean. I can change to the 2nd text console, and run "sddm" fine.

End of journalctl -b | grep sddm :

Apr 14 17:58:50 wopr.house systemd[1]: sddm.service: Main process exited, code=dumped, status=6/ABRT
Apr 14 17:58:50 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 14 17:58:51 wopr.house systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Apr 14 17:58:51 wopr.house systemd[1]: sddm.service: Scheduled restart job, restart counter is at 3.
Apr 14 17:58:51 wopr.house sddm[1046]: Initializing...
Apr 14 17:58:51 wopr.house sddm[1046]: Logind interface found
Apr 14 17:58:51 wopr.house sddm[1046]: Starting...
Apr 14 17:58:51 wopr.house sddm[1046]: Adding new display on vt 1 ...
Apr 14 17:58:51 wopr.house sddm[1046]: Loading theme configuration from ""
Apr 14 17:58:51 wopr.house sddm[1046]: Display server starting...
Apr 14 17:58:51 wopr.house sddm[1046]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{cb9a868b-c29d-464f-aa28-a9667d2ef02e} -background none -noreset -displayfd 18 -seat seat0 vt1
Apr 14 17:58:51 wopr.house sddm[1046]: Display server failed to start. Exiting
Apr 14 17:58:52 wopr.house systemd[1]: sddm.service: Main process exited, code=dumped, status=6/ABRT
Apr 14 17:58:52 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 14 17:58:53 wopr.house systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Apr 14 17:58:53 wopr.house systemd[1]: sddm.service: Scheduled restart job, restart counter is at 4.
Apr 14 17:58:53 wopr.house sddm[1185]: Initializing...
Apr 14 17:58:53 wopr.house sddm[1185]: Logind interface found
Apr 14 17:58:53 wopr.house sddm[1185]: Starting...
Apr 14 17:58:53 wopr.house sddm[1185]: Adding new display on vt 1 ...
Apr 14 17:58:53 wopr.house sddm[1185]: Loading theme configuration from ""
Apr 14 17:58:53 wopr.house sddm[1185]: Display server starting...
Apr 14 17:58:53 wopr.house sddm[1185]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{e33a9690-7283-46a7-a9d5-d9e25dcf7f3f} -background none -noreset -displayfd 18 -seat seat0 vt1
Apr 14 17:58:53 wopr.house sddm[1185]: Display server failed to start. Exiting
Apr 14 17:58:53 wopr.house systemd[1]: sddm.service: Main process exited, code=dumped, status=6/ABRT
Apr 14 17:58:53 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 14 17:58:54 wopr.house systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Apr 14 17:58:54 wopr.house systemd[1]: sddm.service: Scheduled restart job, restart counter is at 5.
Apr 14 17:58:54 wopr.house systemd[1]: sddm.service: Start request repeated too quickly.
Apr 14 17:58:54 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 14 18:00:11 wopr.house polkitd(authority=local)[782]: Operator of unix-process:1707:8740 successfully authenticated as unix-user:falken to gain TEMPORARY authorization for action org.freedesktop.systemd1.manage-units for system-bus-name::1.58 [systemctl start sddm] (owned by unix-user:falken)

Workaround : echo "service sddm start" >> /etc/rc.local

This indicates it's not a misconfiguration or hardward issue. SDDM is simply starting too early.

Claudio (cwr) wrote :

Hi

Maybe it can be resolved by:
https://github.com/sddm/sddm/commit/fca8c808b7fa4a947a0c60157f0eb5227b3ccfff
This patch should also restore the shutdown and reboot options in SDDM, which are not working right now.
If not i will open another bug report about the buttons not working.

tags: added: bionic
Simon Quigley (tsimonq2) on 2018-04-15
Changed in sddm (Ubuntu):
importance: Undecided → High
status: New → Confirmed
assignee: nobody → Simon Quigley (tsimonq2)
Simon Quigley (tsimonq2) wrote :

The fix has been uploaded to Bionic.

Changed in sddm (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sddm - 0.17.0-1ubuntu4

---------------
sddm (0.17.0-1ubuntu4) bionic; urgency=high

  * Fix race between sddm and logind (LP: #1763977).

 -- Simon Quigley <email address hidden> Sun, 15 Apr 2018 14:36:43 -0500

Changed in sddm (Ubuntu):
status: Fix Committed → Fix Released

Not fixed.

$ dpkg -l|grep sddm
ii kde-config-sddm 4:5.12.4-0ubuntu1 amd64 KCM module for SDDM
ii sddm 0.17.0-1ubuntu4 amd64 modern display manager for X11
ii sddm-theme-breeze 4:5.12.4-0ubuntu3 amd64 Breeze SDDM theme

$ systemctl status sddm
● sddm.service - Simple Desktop Display Manager
   Loaded: loaded (/lib/systemd/system/sddm.service; enabled; vendor preset: enabled)
   Active: failed (Result: core-dump) since Mon 2018-04-16 22:05:06 BST; 32s ago
     Docs: man:sddm(1)
           man:sddm.conf(5)
  Process: 1193 ExecStart=/usr/bin/sddm (code=dumped, signal=ABRT)
  Process: 1191 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/sddm" ] (code=exited, status=0/SUCCESS)
 Main PID: 1193 (code=dumped, signal=ABRT)

Apr 16 22:05:06 wopr.house systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Apr 16 22:05:06 wopr.house systemd[1]: sddm.service: Scheduled restart job, restart counter is at 5.
Apr 16 22:05:06 wopr.house systemd[1]: Stopped Simple Desktop Display Manager.
Apr 16 22:05:06 wopr.house systemd[1]: sddm.service: Start request repeated too quickly.
Apr 16 22:05:06 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 16 22:05:06 wopr.house systemd[1]: Failed to start Simple Desktop Display Manager.

Claudio (cwr) wrote :

Hi Tom

Yeah i just wanted to reopen the bug - the /lib/systemd/system/sddm.service file is unchanged - it looks identical to the file in the root directory of "sddm_0.17.0-1ubuntu4.debian.tar.xz" - if this file is copied into the final package, then the patch to the original sddm.service.in file will have no effect.

Simon Quigley (tsimonq2) on 2018-04-17
Changed in sddm (Ubuntu):
status: Fix Released → Triaged
Rik Mills (rikmills) wrote :

Should be a version 0.17.0-1ubuntu5 arriving soon.

https://launchpad.net/ubuntu/+source/sddm/0.17.0-1ubuntu5

Please test to see if that makes a difference.

no effect, and frankly I don't think incorrect start up sequencing will cause a core dump.

how can I test rolling back to using VT7 like it used to be ?

(or alternatively, where is the core dump file ? GDB is occasionally useful...)

ben van 't ende (benvantende) wrote :

Confirmed that version 0.17.0-1ubuntu5 does not solve the problem.

0.17.0-1ubuntu6 arrived. Same issue. core-dump at boot, fine on manual start or from rc.local

ben van 't ende (benvantende) wrote :

0.17.0-1ubuntu7 just arrived and fixed it! kudos to the fixer. great job!

Rik Mills (rikmills) on 2018-04-21
tags: added: kubuntu

On 21/04/18 11:21, ben van 't ende wrote:
> 0.17.0-1ubuntu7 just arrived and fixed it! kudos to the fixer. great
> job!

Good to hear. :)

Simon Quigley (tsimonq2) on 2018-04-21
Changed in sddm (Ubuntu):
status: Triaged → Fix Released

Got worse for me with 0.17.0-1ubuntu7

Now don't even get the drop to "/ is clean" text mode.

Workaround of starting sddm via systemd from rc.local no longer works

just putting "sddm" in rc.local does work.

sddm.service symptom unchanged

Apr 21 22:36:35 wopr.house systemd[1]: sddm.service: Service hold-off time over, scheduling restart.
Apr 21 22:36:35 wopr.house systemd[1]: sddm.service: Scheduled restart job, restart counter is at 5.
Apr 21 22:36:35 wopr.house systemd[1]: Stopped Simple Desktop Display Manager.
Apr 21 22:36:35 wopr.house systemd[1]: sddm.service: Start request repeated too quickly.
Apr 21 22:36:35 wopr.house systemd[1]: sddm.service: Failed with result 'core-dump'.
Apr 21 22:36:35 wopr.house systemd[1]: Failed to start Simple Desktop Display Manager.
Apr 21 22:36:35 wopr.house systemd[1]: sddm.service: Triggering OnFailure= dependencies.

as I ask ed earlier - where are these dump written ?

syslog adds :

Apr 21 22:36:32 wopr sddm[1618]: Loading theme configuration from ""
Apr 21 22:36:32 wopr sddm[1618]: Display server starting...
Apr 21 22:36:32 wopr sddm[1618]: Running: /usr/bin/X -nolisten tcp -auth /var/run/sddm/{32721ea1-fe7f-40f7-adfb-e12021f0311c} -background none -noreset -displayfd 18 -seat seat0 vt1
Apr 21 22:36:32 wopr sddm[1618]: Display server failed to start. Exiting
Apr 21 22:36:32 wopr systemd[1]: sddm.service: Main process exited, code=dumped, status=6/ABRT

Xorg.1.log adds :

[ 28.693] (WW) Falling back to old probe method for modesetting
[ 28.693] (II) modeset(1): using default device
[ 28.693] (II) Loading sub module "fbdevhw"
[ 28.693] (II) LoadModule: "fbdevhw"
[ 28.693] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[ 28.693] (II) Module fbdevhw: vendor="X.Org Foundation"
[ 28.693] compiled for 1.19.6, module version = 0.0.2
[ 28.693] ABI class: X.Org Video Driver, version 23.0
[ 28.693] (**) FBDEV(2): claimed PCI slot 0@0:2:0
[ 28.693] (II) FBDEV(2): using default device
[ 28.693] (WW) Falling back to old probe method for vesa
[ 28.693] (EE) Screen 0 deleted because of no matching config section.
[ 28.693] (II) UnloadModule: "modesetting"
[ 28.693] (EE)
Fatal server error:
[ 28.693] (EE) Cannot run in framebuffer mode. Please specify busIDs for all framebuffer devices
[ 28.693] (EE)
[ 28.693] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[ 28.693] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[ 28.693] (EE)
[ 28.714] (EE) Server terminated with error (1). Closing log file.

(I do not have an xorg.conf)

Fixed : sudo usermod -a -G video sddm

Rebooted several times, stays fixed with rc.local empty.

This suggest you need to add something to the post-install script ?

You've marked this as fix released, yet it only address' Calaudio's issue, which was not the one originally reported.

Can you just adjust the post-install script to ensure the group is assigned correctly ?

Rik Mills (rikmills) on 2018-05-01
Changed in sddm (Ubuntu):
status: Fix Released → Triaged
Simon Quigley (tsimonq2) on 2018-05-04
Changed in sddm (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers