Cannot get past sddm login screen in Kubuntu Vivid

Bug #1440151 reported by Donatas Glodenis
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
SDDM
New
Undecided
Unassigned
sddm (Ubuntu)
Incomplete
Critical
Unassigned
Nominated for Vivid by Alberto Salvia Novella

Bug Description

Couple days ago I installed Kubuntu Vivid on Lenovo Thinkpad x220 tablet (amd64 version from daily iso). Encrypted home directory, SSD type drive.

Today I could not enter my Plasma desktop. The sddm display manager gets stuck after I fill in the password and press Enter. Sometimes the mouse pointer disappears, and sometimes it turns into a black X symbol. It hangs like this till I kill it (sudo service sddm restart)

I can login to tt1-6 allright.

I tried installing slim and lxdm managers, but they do the same - get stuck after filling the password (mouse pointer disappears). I also tried reinstalling sddm (it updated two times in the repositories even today, so I updated to the new verisons, to no avail).

I have no clue how to troubleshoot this problem. Please tell me. If it is done sooner than sunday, I will try to gather whatever information I can from the system. Otherwise I will have to reinstall Kubuntu (perhaps 14.10 version) as I do need that machine to function.

There are other reports of this happening:

https://www.kubuntuforums.net/showthread.php?67689-Can-t-get-past-login-screen-after-20-March-update&highlight=vivid+sddm - forum user molecule-eye comments.

http://jriddell.org/2015/03/18/kubuntu-15-04-heating-up/ - comment on 21/3/2015 by Mike.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1440151/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
affects: ubuntu → sddm (Ubuntu)
Revision history for this message
Donatas Glodenis (dgvirtual) wrote :

since there is a possibility, that it is sddm bug, I am attaching related output.

Revision history for this message
Donatas Glodenis (dgvirtual) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Revision history for this message
Sergio Callegari (callegar) wrote :

I think that the issue is not the login manager. Problem happens also if I switch to lightdm. See kwin going to 100% CPU. Moving to xubuntu desktop fixes the problem. Once more KDE new version has been made the default too early I suppose.

Changed in sddm (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Sergio Callegari (callegar) wrote :

In my case, the issue was the following:

https://bugs.launchpad.net/ubuntu/+bug/1451280

Revision history for this message
Alberto Salvia Novella (es20490446e) wrote :

Please:
  1. Report to <https://github.com/sddm/sddm/issues>.
  2. Paste the new report URL here.
  3. Set this bug status back to "confirmed".

Thank you.

Changed in sddm (Ubuntu):
status: Confirmed → Incomplete
tags: added: asked-to-upstream
Revision history for this message
hegemon8 (pantokrata2) wrote :

For me all was good on Kubuntu 20.04 until today when i've updated. Mind fact i have changed global theme, and other colorful stuff, icons cursors prior update, so i'm guessing it didn't cause it.
But i see black screen (not even backlight) but i can still log in typing password blindly. After that system acts normally.

Revision history for this message
hegemon8 (pantokrata2) wrote :

After 5 reboots it was the same, but i left it off few hours and when i'm back now on it, it seems to be working for me. But if any of output of command needed, i can help with that.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers