sddm not starting after upgrade

Bug #1431332 reported by Alan on 2015-03-12
120
This bug affects 30 people
Affects Status Importance Assigned to Milestone
sddm (Ubuntu)
High
Unassigned

Bug Description

Who killed my beloved Kubuntu? :-)
Yesterday 11 Marts my shiny Kubuntu Vivivd
was rocking better than Momma.
But then a new kernel update and wam bam sorry Mam, wont boot.
Hmm installed again from latest kubuntu-15.04-beta1-desktop-amd64.iso.
After install and reboot all was fine and then after dist-upgrade it
died again.
I tryed holding shift during boot to get rescue mode this also was dead.

It dies early in the boot process with the console writing:

starting version 219
[OK] Started LSB: daemonn to balance ....
[OK] Started Bluetooth service.
[OK] Reached target Bluetooth.

And then it is all dead in the water.
Running on Imac mid 2011

So someone did something nasty one of the last days
:-)
Regards
Alan

Jonathan Riddell (jr) wrote :

probably the sddm update which changed vt to 7

affects: digikam (Ubuntu) → sddm (Ubuntu)
Changed in sddm (Ubuntu):
milestone: none → ubuntu-15.04
tags: added: kubuntu
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sddm (Ubuntu):
status: New → Confirmed
Jonathan Riddell (jr) wrote :

maybe the sddm update which changed vt to 7

work around it by starting sddm manually:
alt-F2
login
systemctl start sddm

or reinstall today's daily

summary: - Kububtu vivid beta is dead. Wont boot anymore since last dist-upgrade
- which provided new kernel
+ sddm not starting after upgrade
Alan (alan-hovgaard) wrote :

Thx Jonathan
Your proposed fix worked.
alt-f2 to get new terminal window
login
sudo systemctl start sddm

Made the desktop come alive.

I did a new sudo apt-get distupgrade but still have to
start sddm manually to get to Desktop.

So seems ssdm bug aferall.

regards
alan

Sandra Karuving (lumks) wrote :

@jr is this necessary to change to vt7? i really liked it on vt1

Ricard (jeanmi-ricard) wrote :

To fix this problem, do:
sudo systemctl enable sddm.service -f
sudo reboot

ronwilhoite (ronwilhoite) wrote :

Thanks Ricard. Seems to have fixed it for me.

Nathan Murray (yotux) wrote :

I have used the command of: systemclt enable sddm

After completing this command and reboting the machine it allows GUI on startup.

Regards,

Nathan

alaperrot (alaperrot) wrote :

This happened to me again today after an update of Kubuntu Vivid on my laptop.
At next boot, sddm would not start, and "sudo systemctl enable sddm" / "sudo reboot" fixed it.

Philip Muškovac (yofel) wrote :

Setting incomplete because we still have no way to reproduce this and there haven't been any reports of this lately.
If somebody hits this again it would be good to know what was done to the system before it happened (upgraded packages, ..).

Changed in sddm (Ubuntu):
importance: Undecided → High
status: Confirmed → Incomplete
Kari Haapanen (karsta62) wrote :

I'm having this right now. The workarounds/fixes don't help.

After installing kubuntu 15.04 beta from dvd all was good until I did apt-get upgrade and installed some new stuff yesterday Apr 13th (I guess).

Attached apt's history which shows packages before and after.

Kari Haapanen (karsta62) wrote :

ok. Here we go again.
After my previous post I did a fresh install. All good. I updated a few times, and still all good.
I had decided not to update any more, because I had a feeling that it will break up again.
For being stupid, I updated it yesterday anyway.:

The result is that after login, the horizontal bar goes all the way to the right as it is supposed to, but it stays there for a (too) long time. Then the screen goes black. Mouse pointer is visible and moving, but the screen is black.
Pressing alt-f2 gives the command field and I can type in it, but pressing enter does nothing.

Attached the apt history.log which has all actions after the fresh install until the final disaster yesterday.

My hw is Dell Latitude E6410 with intel graphics.

I hope someone is interested. April 23rd is approaching.

Kari Haapanen (karsta62) wrote :

One addition to the previous:

When I choose failsafe session instead of plasma, it gives a black screen for a second and then loops me back to login screen. Every time.

Try clean out all your local kde conf files ie. ~/.kde ~/.local
Ofcourse make backup first - but I think that might help
/Alan

On 04/19/2015 09:37 AM, Kari Haapanen wrote:
> One addition to the previous:
>
> When I choose failsafe session instead of plasma, it gives a black
> screen for a second and then loops me back to login screen. Every time.
>

Kari Haapanen (karsta62) wrote :

That crossed my mind as well Alan. I'll try that next time it breaks.

Jonathan Riddell (jr) on 2015-04-22
Changed in sddm (Ubuntu):
status: Incomplete → Invalid
Martin Pitt (pitti) on 2015-04-22
Changed in sddm (Ubuntu):
milestone: ubuntu-15.04 → none
Kari Haapanen (karsta62) wrote :

A lot of installations on different laptops. This always comes back. Even after the final release. Today after installing grive. Removing .kde helped on one, but not on the other after grive Every update is scary.
Why the status is invalid?

Kari Haapanen (karsta62) wrote :

Sorry, there should be a "." before "Every update is scary."

Kari Haapanen (karsta62) wrote :

Why is this invalid? Nothing has changed.

Today I was surfing with chrome when I noticed that the panel and application launcher and whole desktop actually disappeared. Went black. After a reboot I log in but all there is is the black screen and mouse pointer.

I've tried to flush .kde and .config directories, but nothing changes. I had a backup of my working home directory, but restoring it does not help either.

I had created another user, with which the desktop is wstill orking. I copied all directories beginning with a dot to my own directory and chmoded, but no. Plasma is dead.

Only working solution seems to be quitting KDE, right?

I have similar experience to what @sven has illustrated in https://bugs.launchpad.net/sddm-kcm/+bug/1454004 . I Installed Kubuntu 15.04, and every time I reboot I have to restart sddm ~10 times to get the login screen. Any solutions?

Changed in sddm (Ubuntu):
status: Invalid → Confirmed
Franco (franlepeva) wrote :

Hi everyone! I think I have this bug or similar.
I have Kubuntu 15.04, and last night I installed a new driver for the NVIDIA GEFORCE of my laptop, because it said (the manager) it was recommended. While the driver was downloaded and installed a new system update appeared, but I decided not to update.
After a while, my laptop went black, only the arrow was visible, I had to reboot and then appeared a message saying sddm-greeter had failed and another saying plasma had failed. After that only the arrow and crocky (the apps launcher) were visible, the rest was black, I could open firefox, but had no wi fi. After a second reboot, all that happens is similar to what other people say here. I tryed "sudo systemctl enable sddm" / "sudo reboot" and other things I found but nothing works. Please if someone knows a way to fix this tell me, I don't want to reinstall the OS... And sorry if my english is confusing, is not my native language.

Blaz (blaz-vrhnjak-3) wrote :

Uff, this same starting 219 version freeze after yesterday's upgrade happened to me, too. I have looked around and tried sudo dpkg --configure -a, sudo systemctl enable sddm.service -f & reboot, systemctl start sddm to no avail... Can anyone help? This happened on my HP2000 Notebook and I'm quite frustrated as nothing seems to help.

Blaz (blaz-vrhnjak-3) wrote :

Hello again! A few minutes ago I tried again and did sudo apt-get update&upgrade in terminal mode and some packages were updated. Now the boot works as it should. Thank you, developers!

tags: added: vivid
Daniel Albers (al) wrote :

I was asked to fix a machine affected by this after upgrading from trusty to xenial (LTS releases).

On this machine systemctl start sddm started sddm successfully, but enable did nothing.

Reinstalling the sddm package added the previously missing /etc/systems/system/display-manager.service symlink, which fixed the issue.

Thomas Dreibholz (dreibh) wrote :

I can confirm the sddm start issue after upgrade from Ubuntu 14.04 to Ubuntu 16.04. From /etc/syslog:
chdir( /var/lib/sddm ) failed for user: "sddm"

/var/lib/sddm was not existing in my case. So, I created it and adapted its permissions:
sudo mkdir /var/lib/sddm
sudo chown -R sddm:sddm /var/lib/sddm

After that, I "service sddm restart" made sddm work again.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers