scrot can't save files without extension

Bug #148659 reported by Evan Klitzke on 2007-10-03
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
scrot (Ubuntu)
Low
Eriberto

Bug Description

I can't run scrot in Gutsy -- when I run it, there is a giblib error when trying to save to a file.

evan@thinkpad ~ $ scrot -c -d 5 foo
Taking shot in 5.. 4.. 3.. 2.. 1.. 0.
giblib error: Saving to file foo failed

scrot = 0.8-7
giblib = 1.2.4-4

I talked with another user on IRC who also encountered the same problem in Feisty (exact same error message), so this must have been broken for a while, although I do recall using scrot on Ubuntu in the past successfully (maybe in Edgy?).

Daniel T Chen (crimsun) wrote :

Is this symptom still reproducible in 8.10 RC or later?

Changed in scrot:
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in scrot:
status: Incomplete → Invalid

>Is this symptom still reproducible in 8.10 RC or later?
yes it is reproducible on ubuntu 9.04 64, but this happens because file have no extension. scrot accepts files with extension like .png .jpg .tiff .bmp (haven't found any other but may be more) to decide type of the file. I think that we could:
-save as png if not extension is given
-don't save but write an error in more friendly way like: Saving to file foo failed. Please type a file name with correct extension( .png .jpg .tiff .bmp)

scrot 0.8-8
giblib 1.2.4-5

bug still exists in ubuntu 9.04 scrot 0.8-8 giblib 1.2.4-5

Changed in scrot (Ubuntu):
status: Invalid → New
summary: - scrot can't save files
+ scrot can't save files without extension
kernst (kernst) wrote :

The example given by the original poster shows he is in his home directory (~), but I'll add this here because *I* thought I'd found a bug in 'scrot' that led me here. What I experienced wasn't a bug at all. You can't run 'scrot' from inside a folder you don't have write permissions to unless you give it a full pathname to save somewhere else.

I was in some subdirectory of '/usr/share' and cursing at scrot because I was getting this error:

giblib error: Saving to file 2010-07-11-170539_1600x1200_scrot.png failed

'cd'-ing to my home directory, of course, makes this error go away. Silly, I know, but scrot should probably pick up on the fact that it doesn't have write access and emit a more helpful error message (or default to user's home).

Hopefully this helps someone.

Based on comment #5 seems a wishlist/confirmed. Should be marked as such.

Changed in scrot (Ubuntu):
importance: Undecided → Low
Charlie Kravetz (charlie-tca) wrote :

 Thanks for reporting this bug and any supporting documentation. Since this bug has enough information provided for a developer to begin work, I'm going to mark it as confirmed and let them handle it from here.

A fresh install of Maverick Meerkat Development version (10.10), using the images from 2010-09-25, confirms this bug is valid. To reproduce it:

1. Install the latest development version of Ubuntu
2. Install "scrot" (sudo apt-get install scrot)
3. In a terminal, type
     scrot terminal-image
4. Observe the error
     giblib error: Saving to file terminal-image failed

Thanks for taking the time to make Ubuntu better!

Changed in scrot (Ubuntu):
status: New → Triaged
tags: added: maverick
Eriberto (eriberto) wrote :
Changed in scrot (Ubuntu):
assignee: nobody → Eriberto (eriberto)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package scrot - 1.1-1

---------------
scrot (1.1-1) unstable; urgency=medium

  * New upstream version 1.1.
  * debian/copyright: added rights for upstream Jade Auer.
  * debian/patches/10_fix-distclean.patch: removed. The
    upstream fixed the source code. Thanks.

 -- Joao Eriberto Mota Filho <email address hidden> Tue, 09 Jul 2019 20:21:16 -0300

Changed in scrot (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers