Scribus does not work with accented characters when writing into a text box

Bug #177805 reported by Ricardo L. Febrero on 2007-12-21
18
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Scribus
Fix Released
Unknown
scribus (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: scribus

Just install scribus, create a new project, insert a new text frame, and try to write into it. When you type accented characters, like à, á, â, what you get is 'a, `a, ^a, and so on... I cannot get it working, I don't know why. And also, I don't see all the character fonts, just some of them. When I use some Gnome application, I can select a lot more fonts than with Scribus. That's why?? Thanks!!!!

Łukasz Jernaś (deejay1) wrote :

Could you specify your Ubuntu and Scribus version? You can try to remove the scim-qtimm package if you have it installed and also see http://wiki.scribus.net/index.php/Getting_Scribus_on_Ubuntu/Kubuntu_up_and_running
Hope that helps.

Changed in scribus:
status: New → Incomplete
wolfger (wolfger) wrote :

Over 4 months with no response. We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in scribus:
status: Incomplete → Invalid
Savvas Radevic (medigeek) wrote :

Confirming on ubuntu hardy heron 8.04 amd64
$ apt-cache policy scribus
scribus:
  Installed: 1.3.3.11.dfsg-1ubuntu4
  Candidate: 1.3.3.11.dfsg-1ubuntu4
  Version table:
 *** 1.3.3.11.dfsg-1ubuntu4 0
        500 http://nl.archive.ubuntu.com hardy/main Packages
        100 /var/lib/dpkg/status

I use gnome 2.22.2 as my desktop manager

I specifically cannot add accent to greek letters/characters, should be probably happening the same with the spanish language (not checked) or any other language that uses accents.

Steps:
1) Create a text box in Scribus, double-click to be able to edit
2) Switch your keyboard layout (gnome) to greek language
3) Type in an accented character. For the "Generic 105-key (intl) pc" with "Greece-Greek" Gnome layout, I typically press the ";" and "e" keys in order to get: έ (U+03AD GREEK SMALL LETTER EPSILON WITH TONOS)
The problem is that the text "Τα νέα μας το πρωΐ" appears as: "Τα ν´εα μας το πρω¨´ι"

Other examples:
shit + ";" + "i": Ϊ (U+03AA GREEK CAPITAL LETTER IOTA WITH DIALYTIKA)
shift+";" and ";" (adds accent/tonos and diaireses/dialytika) and "y": ΰ (U+03B0 GREEK SMALL LETTER UPSILON WITH DIALYTIKA AND TONOS)

Mind you, this works as expected in other programs, openoffice.org, mozilla firefox, gedit, etc.

Changed in scribus:
status: Invalid → Confirmed
Savvas Radevic (medigeek) wrote :

oops, shit = shift :) apologies

Łukasz Jernaś (deejay1) wrote :

Yeah, it doesn't seem to work for me now neither, but it did before - forwarding it upstream now.

Caroline Ford (secretlondon) wrote :

Where did you send this upstream? Scribus' mantis?

I use last stable Scribus version from Ubuntu, on Hardy 8.04. I still
have the problem.

2008/9/7 Caroline Ford <email address hidden>:
> Where did you send this upstream? Scribus' mantis?
>
> --
> Scribus does not work with accented characters when writing into a text box
> https://bugs.launchpad.net/bugs/177805
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
Néstor
+34 687 96 74 81
<email address hidden>

Łukasz Jernaś (deejay1) wrote :

Sorry, somehow I've lost track of it. AFAIK this is a general issue with Qt 3.x apps in *buntu. See http://bugs.scribus.net/view.php?id=1908

N7DR (doc-evans) wrote :

FWIW, this problem does not seem to exist with 64 bit Kubuntu intrepid using the scribus-ng package. When I enter accented characters, they appear as expected.

Facundo Batista (facundo) wrote :

I have the very same problem with combined characters, installing the normal scribus package.

Using scribus-ng the result is the same.

I'm using Ubuntu 9.04.

PirBoazo (pierre-boizot-name) wrote :

I have install on 10.04 UNR and normal ubuntu.
the bug is more important , text are invisible.
Text are replace by red .....

Pierre

Mattia Rizzolo (mapreri) wrote :

This should be fixed upstream ages ago. Therefore, closing this bug now.
Do feel free to reopen it if this is not fixed for you.

Changed in scribus (Ubuntu):
status: Confirmed → Fix Released
Changed in scribus:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.