Increase MAX_WINMSG_REND constant from 16 to 80

Bug #315871 reported by Dustin Kirkland  on 2009-01-10
4
Affects Status Importance Assigned to Milestone
screen
Unknown
Unknown
screen (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: screen

While working on the screen-profiles package, we're increasing the usabilty of screen by creating useful profiles that contain a nice status bar across the bottom, providing system information, and doing so in a nicely formatted, colorful manner.

However, we recently hit an arbitrary limit.

It seems that screen has a #define that limits the number of formatting changes on a line to 16.

I'm attaching a patch that increases that limit from 16 to 80. Since 80 is the standard terminal width, this would allow each character across the bottom to be formatted differently.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

To reproduce this bug, simply put the following two lines in your ~/.screen/rc:

hardstatus alwayslastline
hardstatus string '%{Wr}1%{Wk}2%{Wr}3%{Wk}4%{Wr}5%{Wk}6%{Wr}7%{Wk}8%{Wr}9%{Wk}10%{Wr}11%{Wk}12%{Wr}13%{Wk}14%{Wr}15%{Wk}16%{Wr}17%{Wk}18%{Wr}19%{Wk}20%{= Wk}'

This string simply prints the numbers 1-20 across the bottom of your screen, alternating colors red and black. You will notice that after number 16, format attributes are simply dropped.

:-Dustin

Dustin Kirkland  (kirkland) wrote :

A "fixed" screen looks like this ^^^

:-Dustin

Dustin Kirkland  (kirkland) wrote :

I'm attaching a patch that solves this problem.

Please sponsor and upload.

:-Dustin

Changed in screen:
importance: Undecided → Low
status: New → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package screen - 4.0.3-11ubuntu1

---------------
screen (4.0.3-11ubuntu1) jaunty; urgency=low

  * debian/patches/55-increase_max_winmsg_renditions.dpatch: Increase
    MAX_WINMSG_REND constant from 16 to 80, LP: #315871
  * debian/patches/00list: updated accordingly

 -- Dustin Kirkland <email address hidden> Sat, 10 Jan 2009 12:20:42 -0600

Changed in screen:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.