screen caught signal 11 core dumped

Bug #1333630 reported by gregrwm on 2014-06-24
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
screen
Unknown
Unknown
screen (Debian)
Fix Released
Unknown
screen (Ubuntu)
Medium
Unassigned

Bug Description

same bug as http://savannah.gnu.org/bugs/?35757

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: screen 4.1.0~20120320gitdb59704-9
ProcVersionSignature: Ubuntu 3.13.0-29.53-generic 3.13.11.2
Uname: Linux 3.13.0-29-generic i686
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: i386
Date: Tue Jun 24 04:40:21 2014
InstallationDate: Installed on 2014-01-30 (144 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha i386 (20140129)
ProcEnviron:
 LC_TIME=en_DK.UTF-8
 TERM=screen
 LC_COLLATE=en_DK.UTF-8
 PATH=(custom, no user)
 SHELL=/bin/bash
SourcePackage: screen
UpgradeStatus: No upgrade log present (probably fresh install)

gregrwm (gregrwm) wrote :
Kick In (kick-d) on 2014-06-25
Changed in screen (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Axel Beckert (xtaran) wrote :

JFTR: This fix is included in the latest upstream release 4.2.1 which is currently available in Debian Experimental and will be uploaded to Debian Unstable soonish. It should propagate to Ubuntu Utopic automatically soon afterwards.

Jon Proulx (jproulx) wrote :

Any chance the fix will be back ported? broken screen in LTS is kinda bad...

Axel Beckert (xtaran) wrote :

4.2.1 is part of 14.10 Utopic and also available in trusty-backports.

Changed in screen (Ubuntu):
status: Triaged → Fix Released
Fake Name (lemuix-2) wrote :

This issue is not fixed.

I'm running screen Screen version 4.02.01 (GNU) 28-Apr-14, installed from screen/trusty-backports, and the issue /still/ periodically reoccurs (generally when I'm doing a whole bunch of stuff, and is the most inconvenient.

Fake Name (lemuix-2) wrote :

I should add, following this recipe here: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681572 still reproduces the issue exactly.

Here is a copy of the repro:

- enable the alternate screen: ^A :altscreen on
- be sure to have at least two windows opened, then split with ^A S
- open Vim
- make the current region bigger with ^A :resize 83% (same with +number or
  while decreasing the other size) or remove it entirely with ^A X
- close Vim and screen crashes with [screen caught signal 11. (core dumped)]

The screen package I have is "screen (4.2.1-2~ubuntu14.04.1)", this is on ubuntu 14.04.1 LTS.

I spent a little while trying to compile screen from source, but didn't get anywhere.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681572 seems to indicate that this is actually fixed in 4.2.1-*3*, which is /not/ in the backports.

Is there any way to get the actually fixed version backported?

Fake Name (lemuix-2) wrote :

Ok, got screen to compile from source I checked out from git, and it appears the issue is indeed fixed in 4.2.1-3.

This really, /really/ shouldn't even be in backports, this really needs to be just a straight-out normal release for all platforms.

Having screen occationally shit the bed and take your entire session with it is just unacceptable. 4.2.1-3 needs to be released as a normal patch for all the LTS platforms.

Hi,

Fake Name wrote:
> I should add, following this recipe here: https://bugs.debian.org/cgi-
> bin/bugreport.cgi?bug=681572 still reproduces the issue exactly.
>
> Here is a copy of the repro:

Thanks for the details as there are two different instructions in the
bug report you mentioned.

> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=681572 seems to
> indicate that this is actually fixed in 4.2.1-*3*,

That's the case.

Seems that my comment about being "fixed upstream in 4.2.1" referred
to https://savannah.gnu.org/bugs/?35757#comment5 while I noticed only
afterwards that upstream had to fix the fix with what I cherry-picked
later for 4.2.1-3.

So yes, in Ubuntu this is only fixed in the upcoming 15.04 Vivid
release, but present in Utopic and Trusty-Backports which just have a
4.2.1-2 or a backport thereof.

  Regards, Axel
--
 ,''`. | Axel Beckert <email address hidden>, http://people.debian.org/~abe/
: :' : | Debian Developer, ftp.ch.debian.org Admin
`. `' | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5
  `- | 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE

Changed in screen (Debian):
status: Unknown → Fix Released
Fake Name (lemuix-2) wrote :

So..... it's not getting fixed?

I use LTS releases be cause I assumed they were actually.... supported (that's what the "S" in LTS means, or so I thought). Why on earth would this not be released for all the currently "supported" variants.

Admittedly, it's rather hard to trigger, but it's a complete dealbreaker when if it is triggered, particularly if you have long-running tasks in a screen session (which is what I use it for). It occasionally triggers on exiting htop, and basically ruins my entire day.

Fake Name (lemuix) wrote :

I just ran into this issue AGAIN on a different box.

How the hell is this in ANY way "LONG TERM **SUPPORT**"? A very broadly used component of the OS CRASHES AND KILLS ALL CONTAINED PROCESS RANDOMLY.

Me having to compile screen myself for EVERY "SUPPORTED" instance of Ubuntu I have would be farcical if it weren't so annoying.

description: updated
Fake Name (lemuix) wrote :

I'm YET AGAIN having to build screen from source for a "SUPPORTED" distro.

HELLLLOOOOOOOOOOOOOO

I'm still having this issue on Ubuntu 16.04 (at least I believe it is this one) - once per day screen crashes on me when I resize the window.

[[screen caught signal 11. (core dumped)]

martin@dogmeat ~ % screen --version
Screen version 4.03.01 (GNU) 28-Jun-15

martin@dogmeat ~ % lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 16.04 LTS
Release: 16.04
Codename: xenial

Fake Name (lemuix-2) wrote :

@martin.von.wittich - Get used to pulling screen sources and compiling it yourself. No one at ubuntu has any interest in actually supporting their "supported" OS.

It's fortunately pretty easy to build a non-fucked version of screen:

 - `apt-get install build-essential ncurses-dev` to get the dependencies.
 - Grab the latest from http://ftp.gnu.org/gnu/screen/ (currently screen-4.3.1.tar.gz)
 - `tar -xvf screen-4.3.1.tar.gz && cd screen-4.3.1 && ./configure && make -j4 && sudo make install` will make and install a version of screen without 2 year old game breaking bugs.

Then, you just have to make sure you don't accidentally let the "SUPPORTED" broken version get installed, because it can clobber the manual version that actually doesn't periodically kill all your processes,
because fuck bothering to actually fix things.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.