hardstatus coloring broken in 4.1.0~2012… when using %= padding

Bug #1257895 reported by Curtis Lee Bolin on 2013-12-04
8
This bug affects 2 people
Affects Status Importance Assigned to Milestone
screen
Unknown
Unknown
screen (Debian)
Fix Released
Unknown
screen (Ubuntu)
High
Unassigned

Bug Description

I use hardstatus string with screen, but the newest version in Trusty breaks it (Screen version 4.01.00devel (GNU) 2-May-06). It works fine in Saucy (Screen version 4.00.03jw4 (FAU) 2-May-06) and earlier.

My ".screenrc":
    hardstatus alwayslastline
    hardstatus string "%{= kg}[ %{r}%H %{g}][%{b}%= %{=kw}%?%-Lw%?%{r}(%{w}%n*%f %t%?(%u)%?%{r})%{b}%?%+Lw%?%?%= %{g}][%{y}%Y.%m.%d %{w}%c:%s %{g}]"

I'll attach images of it working in Saucy and broken in Trusty.

Thank You For Your Time

Related branches

This is it working properly in a lxc of Saucy.

This is it broken in Trusty. I am on the 3 screen.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in screen (Ubuntu):
status: New → Confirmed
Axel Beckert (xtaran) wrote :

Can you please reduce the example to a minimal .screenrc which reproduces the issue?

From the screen shots I'm not sure what difference is really unwanted and which is just from a different window being currently on top of the stack. Both look reasonable to me.

Changed in screen (Ubuntu):
status: Confirmed → Incomplete
Axel Beckert (xtaran) wrote :

Ok, I think I found the difference: The current window on top should be highlighted, but the highlight sometimes has a few characters offset to the actual text.

Changed in screen (Ubuntu):
status: Incomplete → Confirmed
Axel Beckert (xtaran) wrote :

The (close to) minimal hardstatus line to reproduce this issue is "%{k}%=%-w%{r}[%n %t]%{k}%+w%="

Axel Beckert (xtaran) wrote :

It already has been reported upstream at https://savannah.gnu.org/bugs/?func=detailitem&item_id=32339

Thanks Axel. You are ten steps ahead of me.
On Dec 4, 2013 4:20 PM, "Axel Beckert" <email address hidden> wrote:

> It already has been reported upstream at
> https://savannah.gnu.org/bugs/?func=detailitem&item_id=32339
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1257895
>
> Title:
> Screen in Trusty breaks hardstatus string
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/screen/+bug/1257895/+subscriptions
>

Axel Beckert (xtaran) on 2013-12-04
summary: - Screen in Trusty breaks hardstatus string
+ hardstatus coloring broken in 4.1.0~2012… when using %= padding
tags: added: trusty
Changed in screen (Debian):
status: Unknown → Confirmed

Renders essential features or functionality of the package (or a dependent one) broken.

Changed in screen (Ubuntu):
importance: Undecided → High
Axel Beckert (xtaran) on 2014-05-17
Changed in screen (Ubuntu):
status: Confirmed → Fix Committed
Changed in screen (Debian):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package screen - 4.2.1-3

---------------
screen (4.2.1-3) unstable; urgency=low

  * Cherry-pick 7d8fd3ad from upstream to fix segfaults with full screen
    text-mode applications and altscreen on (Closes: #681572)
  * Cherry-pick 8ffd5f46 from upstream to fix caption/hardstatus color
    rendering errors (Closes: #731388, LP: #1257895)
  * Add a very simple TAP-based DEP8 test suite under debian/tests/t.
  * Change Vcs-Browser header to new cgit web interface.
  * Bump Standards-Version to 3.9.6 (no changes needed)
  * Add lintian overrides for configure-generated-file-in-source as
    config.{log,status} are listed in debian/clean.

 -- Axel Beckert <email address hidden> Thu, 09 Oct 2014 03:19:07 +0200

Changed in screen (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.