byobu does not contain a scroll bar, and does not scroll with Shift-PageUp

Bug #1089008 reported by Brian on 2012-12-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Wishlist
Dustin Kirkland 
screen (Ubuntu)
Undecided
Unassigned

Bug Description

When using byobu, I expect to be able to type 'ls -l' and then 'Shift-PgUp' to see what scrolled past the display.

Instead, I cannot scroll up with 'Shift-PgUp' and there is no scroll bar on the window. I have also run 'screen' from gnome-terminal, then 'C-a c' to start a bash shell and I cannot scroll.

$ lsb_release -rd
Description: Ubuntu 12.04.1 LTS
Release: 12.04

$ apt-cache policy screen
screen:
  Installed: 4.0.3-14ubuntu8
  Candidate: 4.0.3-14ubuntu8
  Version table:
 *** 4.0.3-14ubuntu8 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: screen 4.0.3-14ubuntu8
ProcVersionSignature: Ubuntu 3.2.0-34.53-generic 3.2.33
Uname: Linux 3.2.0-34-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu15
Architecture: amd64
Date: Tue Dec 11 11:43:53 2012
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: screen
UpgradeStatus: Upgraded to precise on 2012-12-10 (1 days ago)

Brian (x-brian) wrote :
Axel Beckert (xtaran) wrote :

Shift-PgUp is something which is AFAIK intercepted by the terminal (either console, xterm or some other terminal application) and does usually not reach screen.

Use C-a [ and scroll then with PgUp/PgDn and cursor keys.

Brian (x-brian) wrote :

That does work: C-a [ allows scrolling with 'screen bash' and 'byobu' or 'screen byobu'

This is different from the behavior of byobu in 11.04, but may not be a bug in screen (I'm not sure what 'screen bash' did since I only used byobu in 11.04). It also may not be a bug in byobu if the functionality change was intentional; I just noticed that change now upon upgrade to 12.04.

Thanks for the info!

Hi Brian,

Brian wrote:
> That does work: C-a [ allows scrolling with 'screen bash' and 'byobu' or
> 'screen byobu'
>
> This is different from the behavior of byobu in 11.04,

Oh, ok. If that worked before with byobu, that was likely a feature of
byobu (despite I wonder how they managed to do that :-).

It maybe related to the fact that byobu switched from using screen to
using tmux by default a while ago.

> but may not be a bug in screen

Depends. Now that you mentioned that this is some kind of regression
it may be considered as feature wish for screen.

> (I'm not sure what 'screen bash' did since I only used byobu in
> 11.04).

Likely the same as now. There hasn't changed much in screen in Ubuntu
the last years. Even raring still has 4.0.3.

> It also may not be a bug in byobu if the functionality change was
> intentional; I just noticed that change now upon upgrade to 12.04.

Dustin may be able to answer this.

  Regards, Axel
--
 ,''`. | Axel Beckert <email address hidden>, http://people.debian.org/~abe/
: :' : | Debian Developer, ftp.ch.debian.org Admin
`. `' | 1024D: F067 EA27 26B9 C3FC 1486 202E C09E 1D89 9593 0EDE
  `- | 4096R: 2517 B724 C5F6 CA99 5329 6E61 2FF9 CD59 6126 16B5

Dustin Kirkland  (kirkland) wrote :

Howdy!

Within Byobu, it's much better to use Alt-PageUp / Alt-PageDown, rather than Shift-PageUp / Shift-PageDown.

This is due to the way that screen/tmux and your terminal hand scrollback buffers. With Alt-PageUp/Alt-PageDown, you'll be using the scrollback buffer built into Screen or Tmux, which is far better than the simple scrollback buffer built into your Terminal. This will enable to to accurate scrollback within your Byobu windows, splits, and sessions. If you use the one built into your terminal, you'll have very confusing scrollback behavior (windows, splits, and sessions will all be mixed together).

Now, all that said, you can enable Shift-PageUp / Shift-PageDown in your scrollback easily by adding the following to your ~/.screenrc:
termcapinfo xterm* ti@:te@

I'm going to go ahead and add this back into byobu's default screen profile.

Changed in screen (Ubuntu):
status: New → Invalid
Changed in byobu (Ubuntu):
status: New → In Progress
importance: Undecided → Wishlist
assignee: nobody → Dustin Kirkland (kirkland)
Dustin Kirkland  (kirkland) wrote :

Committed revision 1995.

Changed in byobu (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.23-0ubuntu1

---------------
byobu (5.23-0ubuntu1) raring; urgency=low

  [ Dustin Kirkland ]
  * configure.ac, debian/control, debian/copyright, README,
    usr/lib/byobu/rcs_cost, usr/share/man/man1/byobu.1,
    usr/share/man/man1/byobu-config.1, usr/share/man/man1/byobu-ctrl-
    a.1, usr/share/man/man1/byobu-enable.1, usr/share/man/man1/byobu-
    janitor.1, usr/share/man/man1/byobu-launcher.1,
    usr/share/man/man1/byobu-launcher-install.1,
    usr/share/man/man1/byobu-launcher-uninstall.1,
    usr/share/man/man1/byobu-layout.1, usr/share/man/man1/byobu-quiet.1,
    usr/share/man/man1/byobu-reconnect-sockets.1,
    usr/share/man/man1/byobu-screen.1, usr/share/man/man1/byobu-select-
    backend.1, usr/share/man/man1/byobu-select-profile.1,
    usr/share/man/man1/byobu-select-session.1, usr/share/man/man1/byobu-
    shell.1, usr/share/man/man1/byobu-silent.1,
    usr/share/man/man1/byobu-status.1, usr/share/man/man1/byobu-status-
    detail.1, usr/share/man/man1/byobu-tmux.1:
    - point to the new byobu.co website rather than the launchpad landing
      page
  * usr/share/byobu/profiles/common: LP: #1089008
    - re-enable shift-pgup/shift-pgdn in the terminal buffer in screen,
      to match our default in tmux
  * === added directory usr/share/byobu/pixmaps/highcontrast,
    debian/install, usr/share/byobu/pixmaps/highcontrast/byobu.svg:
    - add a byobu high contrast icon, LP: #1082241
    - simplify, removing detail
  * usr/lib/byobu/distro, usr/lib/byobu/logo: LP: #1094716
    - try to improve logo printing and distro detection on Mac
  * debian/control, debian/rules, usr/bin/byobu-config, usr/bin/byobu-
    select-session: LP: #1043048
    - get our python code pep8 compliant
      + except use tabs instead of spaces, and allow lines longer than
        80 characters
    - this should get byobu's python code working better with python3
  * debian/postrm:
    - fix lintian error

  [ Dustin Kirkland and Philip Muškovac ]
  * usr/lib/byobu/battery: LP: #1090831
    - some batteries use "CHARGE" while others use "ENERGY"

  [ Antonio Lorusso ]
  * usr/bin/byobu-status: LP: #1018538, #1073145, #1020674
    - fix select/copy/paste in iTerm2 and KDE
 -- Dustin Kirkland <email address hidden> Mon, 05 Nov 2012 13:48:13 +0100

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers