Screen resolution setting lost at boot

Bug #667926 reported by peterzay on 2010-10-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
screen-resolution-extra (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: screen-resolution-extra

After some boots, the saved screen resolution of 1280x800 is lost and reverts back to 1024x768. The problem is intermittent and not reproducible. The hardware is Lenovo ThinkPad SL500 with on board Intel graphics.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: screen-resolution-extra 0.13
ProcVersionSignature: Ubuntu 2.6.32-25.45-generic 2.6.32.21+drm33.7
Uname: Linux 2.6.32-25-generic i686
Architecture: i386
Date: Thu Oct 28 13:00:28 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
PackageArchitecture: all
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: screen-resolution-extra

peterzay (peterzay) wrote :
Bryce Harrington (bryce) wrote :

Not enough information has been provided to troubleshoot. See http://wiki.ubuntu.com/X/Reporting for instructions on reporting X issues.

I would check my ~/.config/monitors.xml, which should be what sets the defaults.

Changed in screen-resolution-extra (Ubuntu):
status: New → Invalid
peterzay (peterzay) wrote :

You will find attached the monitors.xml file which reveals nothing new.

The problem occurs every few months for no apparent reason. After boot, I reset to the desired max resolution of 1280x800.

peterzay (peterzay) wrote :

Here is the Xorg.0.log file.

peterzay (peterzay) wrote :

Here is the Xorg.0.log.old file.

Changed in screen-resolution-extra (Ubuntu):
status: Invalid → New
peterzay (peterzay) wrote :

I have just had a reoccurrence of this problem.

I am uploading the following files PRIOR to manually changing the resolution back to 1280x800:
- monitors.xml
- Xorg.0.log
- Xorg.0.log.old

I am also attaching a screenshot to illustrate the problem.

peterzay (peterzay) wrote :

Here is the monitors.xml file.

peterzay (peterzay) wrote :

Here is the Xorg.0.log file.

peterzay (peterzay) wrote :

Here is the Xorg.0.log.old file.

peterzay (peterzay) wrote :

I always boot 10.04 Lucid Lynx with the verbose option as a workaround to Bug #701060.

I have just experienced new behaviour to this screen resolution bug.

The screen of verbose text prior to the user login screen blinked and lost the previous saved resolution setting.

Rebooting reset the screen resolution to the previous saved setting.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers